Pine64 LTS GbE Problem
#1
Hello,


My company recently purchased more than 1000 pine64-LTSs.
And in 2019, more than 600 were purchased and used.

Until last year, pine64 was used only in a 10/100 switching environment, but this year it was tested to be used in a Giga network environment.
However, when I tested pine64-lts on the Giga network, a lot of packet loss appeared.
The problem that appeared in the existing Pine64+ seems to appear in the LTS version as well.
I knew that the H/W problem was solved recently, but what happened?


And in order to solve the situation, the device driver was forced to change to 100 Mbps to access the Gigia Switch, but the problem continued to appear.
The problem was confirmed with iperf3 and wireshark.
Additionally, it was confirmed that the 10/100 switch operates normally.
The problem appears only on 1G switch devices.

Please tell me the proper solution.

Test OS : Android 5.1
  Reply
#2
(06-19-2020, 08:31 AM)scchoi Wrote: Hello,


My company recently purchased more than 1000 pine64-LTSs.
And in 2019, more than 600 were purchased and used.

Until last year, pine64 was used only in a 10/100 switching environment, but this year it was tested to be used in a Giga network environment.
However, when I tested pine64-lts on the Giga network, a lot of packet loss appeared.
The problem that appeared in the existing Pine64+ seems to appear in the LTS version as well.
I knew that the H/W problem was solved recently, but what happened?


And in order to solve the situation, the device driver was forced to change to 100 Mbps to access the Gigia Switch, but the problem continued to appear.
The problem was confirmed with iperf3 and wireshark.
Additionally, it was confirmed that the 10/100 switch operates normally.
The problem appears only on 1G switch devices.

Please tell me the proper solution.

Test OS : Android 5.1

Please check with Android 6 or 7. Some old Android build doesn't optimize the delay line factor and this case cause GbE issue. The delay line also can be adjust by hardware and change 4.7K Ohm resistor from GR70 to GR69 location (refer to attached picture).
.jpg   GbE disable RX_DLY-2.jpg (Size: 135.98 KB / Downloads: 34)
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Selling my Pine64 2gb LTS with a bunch of accessories poponon 0 301 08-08-2019, 09:01 PM
Last Post: poponon
  change the charge LED indicator to Mode B on Pine64 LTS JTX 0 315 04-12-2019, 06:34 PM
Last Post: JTX
  Pine64 LTS Boot Media order Akash Gajjar 1 554 07-22-2018, 05:29 PM
Last Post: tllim
  Pine64 LTS Not booting krisclarkdev 2 764 05-13-2018, 10:22 PM
Last Post: krisclarkdev
  Pine64 LTS - DOA harcrow 8 1,330 03-30-2018, 02:13 PM
Last Post: davidgs
  Selling my Pine64+ racann 0 488 01-07-2018, 04:24 PM
Last Post: racann
  PINE64 LTS, pycnc and RAMPS 1.4 marnicgom 0 450 12-28-2017, 12:32 AM
Last Post: marnicgom
  EMMC cards in Pine64 store stephen fleming 16 11,894 12-26-2017, 12:19 PM
Last Post: tllim
  What memory to buy fo Pine64 LTS kalid0r 2 1,055 11-01-2017, 04:27 AM
Last Post: kalid0r

Forum Jump:


Users browsing this thread: 1 Guest(s)