Pin missing,loose spring in phone, audio jack not working
#1
Hello,

My audio jack is not working on my new UBports pinephone and I tried playing with the number 6 switch to no avail.
Then i noticed a set of pins, and one of the pins is missing, this explains why I saw a tiny spring in the back case of my phone when I opened it.
I assume this is an activation pin for the audio jack (it gets pressed inwards when the cover is put on the phone), it would explain why it is not working

If anyone knows what the pogo pins do and if it has any relation to the headphone jack i would be happy to know this.
Or if the headphone jack is working for others at all in general or if it is a work in progress.
If the pogo pins dont matter then there is no problem.
Maybe they have no relation to my problem.
#2
Pogo pins expose power and I2C for expansion devices whenever anyone gets round to making one. They don't have anything to do with the headphone jack, and nothing is using them by default. However it's possible that if one of them has come apart that one of the parts has got somewhere and caused a problem. It's also possible it's just a software issue with activating the right audio profile, especially as it's early days for the new hardware revision.
#3
(06-09-2020, 10:08 AM)wibble Wrote: Pogo pins expose power and I2C for expansion devices whenever anyone gets round to making one. They don't have anything to do with the headphone jack, and nothing is using them by default. However it's possible that if one of them has come apart that one of the parts has got somewhere and caused a problem. It's also possible it's just a software issue with activating the right audio profile, especially as it's early days for the new hardware revision.


That is comforting news to hear, so i was wrong it had to do with those pins.
If the pins do nothing to disrupt the normal operation of the phone then i dont mind if one is missing.
I do hear de pin rattling in the phone, but i suppose it will do no harm.
I will take it apart later, I dont want to do it yet with a brand new phone even if it is made for it.

I still wonder if anyone else has the same problem with the phone jack?
If it is work in progress than its oke its just i would like to know if it is not a hardware problem.

I also made a ticket for support of pine64 team and they responded they are looking at it so i will also wait what they will say but i expect the same awnser as yours, maybe they can also confirm if the audio jack is known not to be working for now due to the software being in development
#4
If there's the remains of a pin rattling around I'd take the battery out immediately - you never know what that bit may short out. Take photos - I'd expect Pine to be fine with you opening it to remove the remains of the pin, and they should be able to send you a replacement pin as they're available from the store as a spare.

Last time I checked the audio profiles in PostmarketOS they had one for speaker and one for phone - there wasn't one for the headphone socket. You should be ale to work out what alsamixer settings to adjust from the published details - if you're really licky someone will have worked it out and documented it already.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Phone will not turn on (but sometimes will) insidetrip101 9 930 08-29-2022, 08:05 AM
Last Post: insidetrip101
Thumbs Down Phone is unresponsive theneedful 14 2,255 08-12-2022, 08:18 AM
Last Post: theneedful
  Phone Dead Already? MarsColonist 4 988 08-11-2022, 11:52 AM
Last Post: auanta
  PPKB with phone; phone dies while charging SwordfishII 1 506 06-08-2022, 04:14 AM
Last Post: SwordfishII
  Hardware switch for mic is not working properly submariner 10 4,075 01-25-2022, 07:01 AM
Last Post: wibble
Question What's the Pinephone headphone jack/similar part? nfd 1 592 01-16-2022, 02:05 PM
Last Post: sundog
  PWM whine near earpiece in low signal phone call and loud sound sent to the other end vortex 29 16,478 01-14-2022, 11:00 AM
Last Post: eugenr
Shocked Pine phone caught on fire after inserting SDcard majikbear 6 1,734 12-01-2021, 01:34 AM
Last Post: ryo
  New vibration motor not working Zebulon Walton 5 3,812 11-13-2021, 03:00 AM
Last Post: kqlnut
  on off power button stopped working dcinoz 3 1,274 09-01-2021, 03:26 AM
Last Post: dcinoz

Forum Jump:


Users browsing this thread: 1 Guest(s)