Rock64 v3 with Real Time Clock (RTC), how to verify?
#1
After over 2 months' voyage, my Rock64 v3 finally was delivered. It is known to have a RTC (Real Time Clock) module that v2 does not have.

My question is, how can I verify RTC module is there working?

BTW, anyone can shed some light on what exactly the RTC module means for an OS?

My dmesg message is as follow (running OpenBSD 6.7):

OpenBSD 6.7 (GENERIC.MP) #1: Sat May 16 15:59:24 MDT 2020
    root@syspatch-67-arm64.openbsd.org:/usr/src/sys/arch/arm64/compile/GENERIC.MP
real mem  = 1006903296 (960MB)
avail mem = 945868800 (902MB)
mainbus0 at root: Pine64 Rock64
cpu0 at mainbus0 mpidr 0: ARM Cortex-A53 r0p4
cpu0: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
cpu0: 256KB 64b/line 16-way L2 cache
efi0 at mainbus0: UEFI 2.8
efi0: Das U-Boot rev 0x20200400
apm0 at mainbus0
psci0 at mainbus0: PSCI 1.1, SMCCC 1.2
syscon0 at mainbus0: "syscon"
"io-domains" at syscon0 not configured
"grf-gpio" at syscon0 not configured
"power-controller" at syscon0 not configured
"reboot-mode" at syscon0 not configured
rkclock0 at mainbus0
syscon1 at mainbus0: "syscon"
"usb2-phy" at syscon1 not configured
ampintc0 at mainbus0 nirq 160, ncpu 4 ipi: 0, 1: "interrupt-controller"
rkpinctrl0 at mainbus0: "pinctrl"
rkgpio0 at rkpinctrl0
rkgpio1 at rkpinctrl0
rkgpio2 at rkpinctrl0
rkgpio3 at rkpinctrl0
"opp_table0" at mainbus0 not configured
simplebus0 at mainbus0: "amba"
"dmac" at simplebus0 not configured
"arm-pmu" at mainbus0 not configured
rkdrm0 at mainbus0
drm0 at rkdrm0
agtimer0 at mainbus0: tick rate 24000 KHz
"xin24m" at mainbus0 not configured
"i2s" at mainbus0 not configured
"spdif" at mainbus0 not configured
com0 at mainbus0: ns16550, no working fifo
com0: console
rkiic0 at mainbus0
iic0 at rkiic0
rkpmic0 at iic0 addr 0x18: RK805
"spi" at mainbus0 not configured
"watchdog" at mainbus0 not configured
rktemp0 at mainbus0
"efuse" at mainbus0 not configured
"gpu" at mainbus0 not configured
"video-codec" at mainbus0 not configured
"iommu" at mainbus0 not configured
"vop" at mainbus0 not configured
"iommu" at mainbus0 not configured
"hdmi" at mainbus0 not configured
"codec" at mainbus0 not configured
"phy" at mainbus0 not configured
dwmmc0 at mainbus0: 50 MHz base clock
sdmmc0 at dwmmc0: 4-bit, sd high-speed, mmc high-speed, dma
dwmmc1 at mainbus0: 50 MHz base clock
sdmmc1 at dwmmc1: 8-bit, mmc high-speed, dma
dwge0 at mainbus0: address xx:xx:xx:xx:xx:xx
rgephy0 at dwge0 phy 0: RTL8169S/8110S/8211 PHY, rev. 6
"usb" at mainbus0 not configured
ehci0 at mainbus0
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "Generic EHCI root hub" rev 2.00/1.00 addr 1
ohci0 at mainbus0: version 1.0
"external-gmac-clock" at mainbus0 not configured
"sdmmc-regulator" at mainbus0 not configured
"vcc-host-5v-regulator" at mainbus0 not configured
"vcc-host1-5v-regulator" at mainbus0 not configured
"vcc-sys" at mainbus0 not configured
"ir-receiver" at mainbus0 not configured
"leds" at mainbus0 not configured
"sound" at mainbus0 not configured
"spdif-dit" at mainbus0 not configured
cpu1 at mainbus0 mpidr 1: ARM Cortex-A53 r0p4
cpu1: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
cpu1: 256KB 64b/line 16-way L2 cache
cpu2 at mainbus0 mpidr 2: ARM Cortex-A53 r0p4
cpu2: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
cpu2: 256KB 64b/line 16-way L2 cache
cpu3 at mainbus0 mpidr 3: ARM Cortex-A53 r0p4
cpu3: 32KB 64b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1 D-cache
cpu3: 256KB 64b/line 16-way L2 cache
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 configuration 1 interface 0 "Generic OHCI root hub" rev 1.00/1.00 addr 1
scsibus0 at sdmmc0: 2 targets, initiator 0
sd0 at scsibus0 targ 1 lun 0: <SD/MMC, SDU1, 0002> removable
sd0: 15100MB, 512 bytes/sector, 30924800 sectors
sdmmc1: can't enable card
vscsi0 at root
scsibus1 at vscsi0: 256 targets
softraid0 at root
scsibus2 at softraid0: 256 targets
bootfile: sd0a:/bsd
boot device: sd0
root on sd0a (f994f9ec2de5c2ae.a) swap on sd0b dump on sd0b
WARNING: bad clock chip time
WARNING: CHECK AND RESET THE DATE!
rkdrm0: no display interface ports configured
rock64$ dmesg | grep clock
rkclock0 at mainbus0
dwmmc0 at mainbus0: 50 MHz base clock
dwmmc1 at mainbus0: 50 MHz base clock
"external-gmac-clock" at mainbus0 not configured
WARNING: bad clock chip time
  Reply
#2
Might be worth running Armbian Linux on the board to see if your RTC is functioning as it should be. I've only v2 so I cant give you a status report.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 Real Time Clock nohandlebars 1 91 07-03-2020, 06:47 AM
Last Post: t4_4t
  Got an error message when trying to flash the Rock64 OS ilan 0 107 06-29-2020, 04:53 PM
Last Post: ilan
Big Grin Rock64 as a retro-gaming console: early impressions Luke 53 30,959 06-25-2020, 09:22 AM
Last Post: dagijay
  HDMI noise on Rock64 ab1jx 1 198 06-19-2020, 04:54 PM
Last Post: ab1jx
  Rock64 v2 network issues alephnull 2 740 05-29-2020, 06:00 AM
Last Post: maccarry
  Rock64 random freezes BTB 5 857 04-07-2020, 03:19 AM
Last Post: tomarm
Photo ROCK64 v3 4GB DDR board memory chip number Johannes 2 331 04-05-2020, 04:29 AM
Last Post: Johannes
  Disable Auto Power On Rock64 willowen100 4 329 03-11-2020, 08:24 AM
Last Post: Rocklobster
  Rock64 running OMV, how to setup RTL8812AU WiFi? electrosam 3 628 02-21-2020, 01:49 AM
Last Post: bigtreeman
  rock64 only works with 546 MB bionic-minimal-rock64-0.6.40-226-arm64 danjperron 2 349 02-17-2020, 01:37 PM
Last Post: danjperron

Forum Jump:


Users browsing this thread: 1 Guest(s)