Lollypop not detecting music collection
I've been using Mobian on my Pinephone since receiving it last month, and am absolutely amazed at how far it has come in such a short amount of time. This will definitely become my daily driver in the near future (as soon as Purism fixes the problem in libpurple that won't allow me to receive SMS messages via CDMA). Thank you to a-wai and the rest of the devs for all your hard work on this great project.

One small problem I'm having, however, is with the default music player Lollypop. When I start the app I get a message saying "Scan disabled, missing collection." And then it won't find my music. I've got Mobian installed on the eMMC and have a 128Gb SD card I'd like to use to hold my music, photos, etc. At first I only had music on the SD card, told Lollypop where the music was located, but nothing came up in the app. Then I tried moving some music to the internal memory in the regular "Music" folder, redirected Lollypop to that folder, and it still didn't find it. I don't see a setting anywhere in Lollypop to enable a scan for my music, so I'm stuck.

I installed Rhythmbox and it sees my music just fine, but I'd like to give Lollypop a try since it's probably better-suited to a small screen.

Has anyone else experienced this? Any thoughts on how to fix it would be appreciated.
I just put an album in the Music folder.
Lollypop scan and find it.
Maybe uninstall and reinstall Lollypop.
(07-29-2020, 02:59 PM)chris_02 Wrote: I just put an album in the Music folder.
Lollypop scan and find it.
Maybe uninstall and reinstall Lollypop.

Ah, sometimes it's the easiest things I forget to do, thanks. At first it didn't work, though. I unstalled Lollypop, rebooted, then reinstalled it, and it still didn't work. But when uninstalling Lollypop I noticed it also uninstalled mobian-phosh and mobian-phosh-extras. On a whim I tried reinstalling mobian-phosh (which also reinstalled mobian-phosh-extras), and now it works! Thanks for the tip, @chris_02 .
I don't mean to perform thread necromancy, but I had a similar issue, and my solution was that mobian, my user, did not own the folders the music was in (downloaded them on separate machine and transferred), so i did:

cd ~/Music; sudo chown -R mobian: ./*
Not sure if sudo was necessary, but i did it anyway due to pure laziness of not wanting to type it again if it failed since I was taking a file away from root ownership

Forum Jump:

Users browsing this thread: 1 Guest(s)