[28/03/2017] openSUSE Tumbleweed Images for Pine64
Thanks for Terra854's work. I can't active the WiFi/Bluetooth module (https://www.pine64.org/?product=wifi-802...4-0-module) with openSUSE revision 28/03/2017 or version 07/12/2016. I tried the following steps.

1. I used the Ubuntu Desktop Image (20161215) with WiFi module, and I can connect to the WiFi. So I think the WiFi module is good.

2. I used the openSUSE image revision 28/03/2017, and followed the steps https://forum.pine64.org/showthread.php?tid=982 without setting the DHCP. After reboot, the WiFi was not automatically connected. The wlan0 appeared after I used the command:

sudo ip  link  set  wlan0  up
and WiFi signals appeared with the command:

sudo iwlist wlan0 scan

The I try to active the wlan0 (with some messages) by 
sudo wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf

Successfully initialized wpa_supplicant
nl80211: Could not re-add multicast membership for vendor events: -2 (No such file or dire

The output of ifconfig is:
eth0      Link encap:Ethernet  HWaddr A2:EE:96:E4:54:89  
         inet addr:  Bcast:  Mask:
         inet6 addr: fdd6:752:efa8:0:a0ee:96ff:fee4:5489/64 Scope:Global
         inet6 addr: fdd6:752:efa8::b26/64 Scope:Global
         inet6 addr: fe80::a0ee:96ff:fee4:5489/64 Scope:Link
         RX packets:207 errors:0 dropped:0 overruns:0 frame:0
         TX packets:179 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:21407 (20.9 Kb)  TX bytes:20570 (20.0 Kb)

lo        Link encap:Local Loopback  
         inet addr:  Mask:
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:65536  Metric:1
         RX packets:592 errors:0 dropped:0 overruns:0 frame:0
         TX packets:592 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:49136 (47.9 Kb)  TX bytes:49136 (47.9 Kb)

wlan0     Link encap:Ethernet  HWaddr 34:C3:D2:6D:4A:F6  
         inet6 addr: fe80::36c3:d2ff:fe6d:4af6/64 Scope:Link
         inet6 addr: fdd6:752:efa8:0:36c3:d2ff:fe6d:4af6/64 Scope:Global
         RX packets:38 errors:0 dropped:0 overruns:0 frame:0
         TX packets:10 errors:0 dropped:1 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:12973 (12.6 Kb)  TX bytes:1215 (1.1 Kb)

the iwconfig outpus is 
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"mywifi"  Nickname:"<WIFI@REALTEK>"
         Mode:Managed  Frequency:2.462 GHz  Access Point: 6C:B0:CE:E9:E9:7F  
         Bit Rate:150 Mb/s   Sensitivity:0/0  
         Retry:off   RTS thr:off   Fragment thr:off
         Encryption key:****-****-****-****-****-****-****-****   Security mode:open
         Power Management:off
         Link Quality=100/100  Signal level=-58 dBm  Noise level=0 dBm
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0   Missed beacon:0

dummy0    no wireless extensions.

sit0      no wireless extensions.

lo        no wireless extensions.

wlan1     unassociated  Nickname:"<WIFI@REALTEK>"
         Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated  
         Retry:off   RTS thr:off   Fragment thr:off
         Encryption key:off
         Power Management:off
         Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0   Missed beacon:0
I still can't connect to the WiFi.

3. I imageed a new openSUSE revision 28/03/2017, and tried to use yast.
In YaST2 --> System --> Network Settings, I edited the wlan0 (WLAN controller) information and saved. But the details of wlan0 were:

WLAN controller (Not connected)                                                
MAC : 34:c3:d2:6d:4a:f6                                                      
BusID : mmc1:0001:1
It seemed the wlan0 not active and I can't connect to WiFi.
Note that after the command
sudo wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf

the wlan0 in the YaST2 changed to
WLAN controller                                               
MAC : 34:c3:d2:6d:4a:f6                                                      
BusID : mmc1:0001:1

I still can't connect to WiFi.

Welcome any comments and suggestions  Smile.

Messages In This Thread
RE: [28/03/2017] openSUSE Tumbleweed Images for Pine64 - by foshuochanyu - 04-03-2017, 12:42 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  GUI on openSuSE joaoreino 10 14,795 01-23-2018, 09:00 PM
Last Post: tmechanic

Forum Jump:

Users browsing this thread: 1 Guest(s)