Rock64 Rev3 doesn't boot and leds blinking fast
#1
Hello,

I just purchased a 4gb Rock64 Rev3 model and i'm struggling in getting any image to boot properly, i tried latest Armbian, mrfixit and ayufan's image. Whenever i plug my power supply (5v 4A) the white, red and ethernet led starts blinking very fast while the green blink slowly. If i plug in and out my power supply it will eventualy boot, but never from the first time. Maybe my board is defective? Anyone else has this issue?
  Reply


Messages In This Thread
Rock64 Rev3 doesn't boot and leds blinking fast - by dishins - 08-11-2019, 07:57 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  openwrt for the rock64 wilsonYan 11 5,199 Yesterday, 10:26 AM
Last Post: helpmerock
  Armbian for Rock64 pineadmin 31 19,113 05-08-2021, 09:35 AM
Last Post: Wizzard
  Screen blinking pRcCjl4 0 67 05-08-2021, 12:16 AM
Last Post: pRcCjl4
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 113 56,618 05-02-2021, 04:48 AM
Last Post: mara
  Setting a MAC on Rock64 U-Boot kiriakos 2 389 03-23-2021, 04:51 AM
Last Post: kiriakos
  Getting from zero to spidev on ROCK64? MikeInMass 0 201 03-22-2021, 10:31 AM
Last Post: MikeInMass
  NextCloudPi image for Rock64, NC version 13.0.2. nachoparker 11 10,775 03-15-2021, 02:59 PM
Last Post: kiriakos
  DietPi OS for ROCK64 MichaIng 11 3,076 03-10-2021, 11:00 AM
Last Post: MichaIng
  Linux Images (ROCK64) pineadmin 164 144,222 02-12-2021, 10:14 AM
Last Post: useful64
  RETRO-GAMING: UPDATED RELEASE OF RECALBOX FOR THE ROCK64 Mrfixit2001 31 22,792 12-21-2020, 08:17 AM
Last Post: hermes73

Forum Jump:


Users browsing this thread: 1 Guest(s)