Booting from eMMC
#13
(11-06-2020, 01:52 AM)khantheengr Wrote:
(03-12-2020, 11:43 AM)IanJames Wrote:
(01-09-2018, 06:05 AM)erchache2000 Wrote:
(01-08-2018, 01:09 PM)saileshrajk Wrote: Hi,
I just received my Pine64-LTS version with 64GB eMMC. I am having major issues trying to boot from the emmc.
I have tried the following 

Downloaded the images from 
https://github.com/ayufan-pine64/linux-build/releases

mainly 

jessie-minimal-pine64-0.7.19-118.img.xz and xenial-minimal-pine64-bspkernel-0.7.19-118.img.xz

1. I then wrote the image to SD card and booted the Pine, which is fine.
2. Followed the instruction to 

sudo ./pine64_update_kernel.sh 0.7.19
sudo ./pine64_update_uboot.sh 0.7.19
sudo ./pine64_update_package.sh 0.7.19

3. executed sudo ./pine64_install........to_emmc.sh xenial-minimal 0.7.19

4. Tried setting the following
emmc_compat=on
emmc_compat=150mhz
emmc_compat=200mhz

5. removed the SD
6 booted with eMMC

I get nothing.

Does the boot take very long as compared to SD (i have left it for few hours)? I get nothing.
I have also tried to burn the above image directly to the emmc without any luck.

Is there something I am missing?

Thanks
Sailesh

Did you try a reboot beetwen point 2 and 3?

2. Update SD
2.5 Reboot
3. Install to eMMC


I just bought an LTS with 32G eMMC.
I also bought the "USB adapter for eMMc Module" for $4.99
(It allows you to burn an eMMc on your desktop computer just like an SD card)
I burned my eMMc using this, then put eMMc in the LTS.
Booted first time.

Ian James

hello James,
i am having the same problem can you please explain how did you managed to get it booted. and were you using pinea64-lts board. what was the IC name on emmc module and what type of image you were using to program emmc module.
thanks

Your post is quite old, so I bet the problem is solved by now. I used freeBSD, got it from their website. They have a build for pine64-lts.
I would recommend that after you burn to eMMc that you look at the eMMc from your computer to see if it "looks right".

Like I said, I'm sure by now you have solved the problem, so I won't give a really long explanation.

(I'm sure you know about "unpacking" an "filename.img.xz" file into an .img file.)

Ian
Sincerely,

Ian James
  Reply


Messages In This Thread
Booting from eMMC - by saileshrajk - 01-08-2018, 01:09 PM
RE: Booting from eMMC - by dkryder - 01-09-2018, 05:46 AM
RE: Booting from eMMC - by erchache2000 - 01-09-2018, 06:05 AM
RE: Booting from eMMC - by IanJames - 03-12-2020, 11:43 AM
RE: Booting from eMMC - by khantheengr - 11-06-2020, 01:52 AM
RE: Booting from eMMC - by IanJames - 02-16-2021, 01:02 PM
RE: Booting from eMMC - by saileshrajk - 01-09-2018, 10:52 AM
RE: Booting from eMMC - by ccaramel - 06-13-2018, 07:11 AM
RE: Booting from eMMC - by Luke - 06-13-2018, 09:33 AM
RE: Booting from eMMC - by ccaramel - 06-14-2018, 12:32 AM
RE: Booting from eMMC - by ccaramel - 06-14-2018, 11:30 AM
RE: Booting from eMMC - by paradise - 07-31-2018, 10:28 AM
RE: Booting from eMMC - by poVoq - 08-15-2020, 10:43 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  eMMC fail in 2% of flashing barucha 10 4,300 12-14-2020, 06:51 AM
Last Post: Little_Johnny
  Problem with EMMC bootup and detection khantheengr 6 1,791 12-10-2020, 05:26 PM
Last Post: poVoq
  SoPine eMMC compatibility Terra854 4 3,655 02-20-2020, 07:52 PM
Last Post: mcrognale
  LTS can't see eMMC devices 1291 4 2,693 02-20-2020, 07:43 PM
Last Post: mcrognale
  Pine64 LTS Not booting krisclarkdev 2 1,488 05-13-2018, 10:22 PM
Last Post: krisclarkdev
  Pine A64-LTS not booting williamcolls 1 1,042 03-29-2018, 01:09 PM
Last Post: dkryder
  EMMC cards in Pine64 store stephen fleming 16 18,773 12-26-2017, 12:19 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)