Z-Wave and openzwave+node-openzwave-shared
#1
Sad 
Hi,

I've installed the Ubuntu 16.04 Longsleep image and then I use the Z-wave EU pot module on euler bus.
Installing openzwave library (at openzwave) and node wrapper (at  openzwave-shared).
It works correctly with the ZW090 Z-Stick Gen5 EU USB device (accessed on /dev/ttyACM0)
but with official pine64 z-wave pot module, on discovery, I don't found any device (the access setting in on the correct /dev/ttyS2).
The pine64 module is well found on /dev/ttyS2 interface but the at scan complete it show 0 device.
Here the 2 logs:

USB Stick on /dev/ttyACM0:

Code:
Initialising OpenZWave 1.4.0 binary addon for Node.JS.
    OpenZWave Security API is ENABLED
    ZWave device db    : /usr/local/etc/openzwave
    User settings path : /home/ubuntu/Morpheos.Momo.NodeJS/lib/_providers/discovery/openzwave/openzwave-lib/build/Release/../../
    Option Overrides : --ConsoleOutput false
connecting to /dev/ttyACM0
Could Not Open OZW Log File.
scanning homeid=0xc85baf68...
node6: nop
node6: node sleep
node1: Aeotec, ZW090 Z-Stick Gen5 EU
node1: name="", type="Static PC Controller", location=""
node1: class 32
node1:   Basic=0
node8: nop
in which there are found 2 nodes (node6 and node8)

Pine64 Z-wave pot module:

Code:
initialising OpenZWave addon (/home/ubuntu/OZW_Test/ozws_anto/node_modules/openzwave-shared/lib/../build/Release/openzwave_shared.node)
Initialising OpenZWave 1.4.0 binary addon for Node.JS.
    OpenZWave Security API is ENABLED
    ZWave device db    : /usr/local/etc/openzwave
    User settings path : /home/ubuntu/OZW_Test/ozws_anto/node_modules/openzwave-shared/build/Release/../../
    Option Overrides : --ConsoleOutput false
connecting to /dev/ttyS2
scanning homeid=0xf6b92336...
node1: Sigma Designs, UZB Z-Wave USB Adapter
node1: name="", type="Static PC Controller", location=""
node1: class 32
node1:   Basic=0
====> scan complete
in which there isn't found any node.

Somebody help me, please?
Thanks in advance.

PS. I would avoid to use OpenHAB.
  Reply


Messages In This Thread
Z-Wave and openzwave+node-openzwave-shared - by saro - 08-31-2017, 08:39 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
Question Z-Wave module pinout to make it compatible with Pi b+ ebretteville 59 39,261 07-12-2019, 08:55 AM
Last Post: kris240376
  Z-Wave - Full and Low Power Inclusion mode B34N 1 2,038 03-26-2017, 06:03 PM
Last Post: B34N
  Z Wave Module and still using GPIO bang 2 2,842 01-16-2017, 03:12 AM
Last Post: bang
  Z-Wave US module with adapter aegrotatio 4 3,204 01-08-2017, 12:03 AM
Last Post: aegrotatio
  RaZberry Module (z-wave) need support to get it working! Luxus 13 8,858 11-03-2016, 02:04 AM
Last Post: Luxus
  Z-Wave module problem vintagewaffle 0 1,255 10-26-2016, 10:50 AM
Last Post: vintagewaffle
Video Australia/New Zealand Z-Wave module Jnimmo 46 24,237 10-02-2016, 02:25 PM
Last Post: tllim
  [EU] Z-Wave module tutorials? meowbot 2 2,765 09-13-2016, 07:54 PM
Last Post: Ghost
  Z-wave module compatibility? Yomet 2 2,577 03-23-2016, 10:15 AM
Last Post: Yomet
  Z-Wave or Z-Wave plus and what about API rjo 4 3,345 02-22-2016, 02:24 AM
Last Post: rjo

Forum Jump:


Users browsing this thread: 1 Guest(s)