USB Wireless Drivers with Longsleep Linux Kernel
#3
(06-10-2016, 12:16 PM)longsleep Wrote: Headers are installed in a way out-of-tree modules can be compiled since the latest release (3.10.101-4-pine64-longsleep-51) make sure you have this and it should work. Else post full output to http://paste.ubuntu.com and share the link here.

I'm sorry I don't quite understand, I am using the Ubuntu build from this link:

https://www.stdin.xyz/downloads/people/l...es/ubuntu/

When I run uname -r I see "3.10.101-0-pine64-longsleep" but no 51 at the end.  I see your 51 build at this link:

https://www.stdin.xyz/downloads/people/l...ges/linux/

But I only know how to flash the .img to a SD card, I'm not sure what I need to do with the .xz files here to get an image on the SD that will boot in the Pine64.  Do I follow the same process of using the "dd" command?  Perhaps the README.md at this link?:

https://www.stdin.xyz/downloads/people/l...README.txt

If you could point me in the right direction I would appreciate it.

**UPDATE**


Re-Installed this img: https://www.stdin.xyz/downloads/people/l...es/ubuntu/

I found this link:

http://forum.pine64.org/showthread.php?tid=982

In regards to the "demsg" hundreds of things are printed out and I don't know what I'm looking for.

I had to install "wireless-tools" to be able to run iwconfig but running that showed:

eth0 no wireless extensions

sit0 no wireless extensions

lo no wireless extensions

I again tried to run "make all" on the driver i got from github (see link in original post), also note first I installed "git" and "build-essential".  Here is a link to the error:

http://paste.ubuntu.com/17195195/

Next i tried the github repo's README DKMS instructions to see if that would work.

On the "dkms build" build I got this missing headers error:

http://paste.ubuntu.com/17195303/

This package: "linux-headers-3.10.101-0-pine64-longsleep" does not exist so it cannot be installed.

Any advice would be appreciated.  Thanks.
  Reply


Messages In This Thread
RE: USB Wireless Drivers with Longsleep Linux Kernel - by jacobscarter - 06-10-2016, 06:08 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
  +LTS/SOPINE Compilation procedure for U-Boot and Linux for pineA64 LTS. [email protected] 1 204 06-05-2019, 11:50 PM
Last Post: igorp
  Frustrations with Wifi, VNC, Longsleep, etc. NexusDude 1 140 06-05-2019, 11:43 PM
Last Post: igorp
  Pine Board using linux stuck during boot sequence ktaragorn 0 156 03-23-2019, 04:06 AM
Last Post: ktaragorn
  How can I get a wireless dongle working on Xenial Desktop latest build Rocklobster 1 562 04-16-2018, 03:09 PM
Last Post: Rocklobster
Question Mali driver on linux? jamiechang917 8 2,046 03-04-2018, 03:01 PM
Last Post: Brian Beuken
  (ARCHIVED) Ubuntu Xenial Image (BSP Kernel) longsleep 337 157,309 01-31-2018, 11:58 AM
Last Post: Luke
  How to add kernel modules to Ubuntu 16.04 on PINE64+ Taiki Bessho 1 1,125 04-12-2017, 10:01 PM
Last Post: MarkHaysHarris777
  config error installing XML-RPC on longsleep Ubuntu tinkertom 2 1,139 02-22-2017, 06:50 AM
Last Post: MarkHaysHarris777
  linux mint fra0hf 9 1,735 10-29-2016, 11:41 AM
Last Post: jkmooney
Rainbow Ubuntu with Android Kernel JasperBrown 5 1,617 07-05-2016, 06:49 AM
Last Post: xalius

Forum Jump:


Users browsing this thread: 1 Guest(s)