need some help with a dpkg error
#1
i'm runing into an issue with the new stretch mate 0.5.15-136. i think the issue arose during the install of vlc media player which came pre-installed on the build but the install is reported as broken due to a problem with libgles1-mesa. when i try   "sudo apt --fix-broken install"  the repair process starts but halts


rock64@rock64:~/Downloads$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libgles1-mesa
The following NEW packages will be installed:
  libgles1-mesa
0 upgraded, 1 newly installed, 0 to remove and 19 not upgraded.
2 not fully installed or removed.
Need to get 0 B/46.2 kB of archives.
After this operation, 87.0 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 85649 files and directories currently installed.)
Preparing to unpack .../libgles1-mesa_13.0.6-1+b2_arm64.deb ...
Unpacking libgles1-mesa:arm64 (13.0.6-1+b2) ...
dpkg: error processing archive /var/cache/apt/archives/libgles1-mesa_13.0.6-1+b2_arm64.deb (--unpack):
 trying to overwrite '/usr/lib/aarch64-linux-gnu/libGLESv1_CM.so.1', which is also in package libmali-rk-utgard-2th-r7p0:arm64 1.5-4ayufan12
Errors were encountered while processing:
 /var/cache/apt/archives/libgles1-mesa_13.0.6-1+b2_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


as best i can tell is the issue is dpkg is trying to overwrite the current libmesgles1 , specifically the file '/usr/lib/aarch64-linux-gnu/libGLESv1_CM.so.1,  that is associated with vlc media player but errors out due to the file also being in the installed libmali from ayufan. here is the dpkg error,

dpkg: error processing archive /var/cache/apt/archives/libgles1-mesa_13.0.6-1+b2_arm64.deb (--unpack):
 trying to overwrite '/usr/lib/aarch64-linux-gnu/libGLESv1_CM.so.1', which is also in package libmali-rk-utgard-2th-r7p0:arm64 1.5-4ayufan12

the interesting thing about all this is i'm unable to install any packages due to this broken package issue until i fix this same file in two places and not alloed to update one of them because the same file is elsewhere and i guess 2 different builds of the same file can not exist at the same time even though in different directories   i'm not really sure of the resolution since i've never faced it and thought to report it in the forum before doing a net search. but i think the original install of vlc media player was broken due to libmali having the same file but probably a different build of the file than vlc media player.

so if anyone has any ideas i'd appreciate the help. thanks.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  opemmediavault plugin error on "Check" clach04 0 4,707 04-21-2020, 10:13 PM
Last Post: clach04
  Gpio error wile using GPIOtest.py Aditya Rastogi 0 1,946 01-31-2019, 02:41 AM
Last Post: Aditya Rastogi
  gstreamer error sdarktemplar 1 2,837 08-02-2018, 11:08 PM
Last Post: tllim
  docker contaainer error on "docker login" edwinbmiller 0 1,619 06-18-2018, 10:08 AM
Last Post: edwinbmiller
  Apt-get update duplicate entry error Jxck 1 3,086 06-02-2018, 02:26 PM
Last Post: evilbunny
  mmc0: error -110 edwinbmiller 6 7,213 03-29-2018, 12:44 PM
Last Post: edwinbmiller
  Error building Rock 64 kernel Bapple 3 4,731 02-13-2018, 08:23 AM
Last Post: xalius
Question LoadTrustBL error when booting pedroz 0 1,668 02-09-2018, 08:35 AM
Last Post: pedroz
  Error when installing some packages - Installing new rk3328-rock64.dtb. msg thewonderer 0 1,862 02-07-2018, 05:22 AM
Last Post: thewonderer
  Ayufun Pre-Release Repo Error jl_678 0 1,573 11-17-2017, 02:33 PM
Last Post: jl_678

Forum Jump:


Users browsing this thread: 1 Guest(s)