Help with a MicroSD card problem on Rock 64
I recieved my Rock 64 yesterday. Using a Windows laptop, I downloaded a couple of images for the Rock 64
I formatted a MicroSD card with SD formatter, then burned a image, using win32diskimg, all in windows {using a usb sd card reader/writer}.

It all went great, plugged the card in the rock 64, and booted up, no problems.

Here is my problem ... once I put a microSD card into the Rock 64, and boot it up .... I can no longer put that Microsd card back into the usb stick, and have it recognized,

I plug the usb stcik into the computer )windows, or Rock64 .. they recognize usb reader/writer, but not the MicroSD card inserted into it.

I will note, when I take the microsd card out of the usb stick, and put it back into the rock 64, the card works fine .. so the card is not destroyed is like .. the rock 64, once it boots up with the microsd card .. it sets some kind of .. bit or something, stopping it from being seen, in a usb reader/writer.

I have tried it with 2 MicroSD cards now ... I also have tried plugging the usb stick into the Rock 64, with a MicroSD card, that was used previously in a rock64, same result.

I have no idea why this is happening. I have re-written microsd cards many times, for the pi 3, never a problem.

I have not expanded the microsd card, to use all the space on it yet .. but can't see why that would make a diffrence.

I am a relative newbie,when it comes to Linux, so maybe this is just something I don't know {although, as I mentioned, never had this problem, with my Pi's.

Any ideas?

Thanks, Jake
My guess is that one of the partitions (which windows does not recognise/ can't mount) gets expanded on first boot ... or something to this effect. There are many more partitions on the R64 linux images than on the RPI or Pin64 ...
You can find me on IRC, Discord and Twitter

That makes sense to me .. but I am hoping there is a .. fix ... a way around this problem.

For example ... I burned a 64 bit version of Xenial mate on one microsd card, and a 32 bit version, on another card. The 64 bit works fine, but the 32 bit version .... I get to the login screen ... and mouse & keyboard work fine {using a Logitech K400 plus} .. but once I login ... Xwnial boots up fine, but the keyboard - trackpad ceases to work.

Both the images I burned, are Xenial .. I am wondering if this .. not being able to reformat the microsd cards, is just in Xwnial, or all the images.

I have several more MicroSD cards, but don't want to burn, and use any of them on the rock 64, if I can't ever use them for anything else .. or, for that fact, I can't even reformat them, to use again on the rock 64, with a diffrent image.

Just because you can't see the partitions, or they are not mountable doesn't mean that you cant reformat the SD card ... Of course you'll be able to reuse your cards. You just need to format the entire SD; just use Windows disk management or whatever other tool is available on Windows ...
On nix you can just use dd. On Linux, Disks and gparted see all the partitions just fine. I bet that Disk Utility in OSX also wont have an issue seeing an formatting the SD cards (haven't checked tho - so just a guess). Its just Windows being crap Tongue

[edit] here is one utility I found at random. Here is some other guide with links.
You can find me on IRC, Discord and Twitter

Thanks Luke ....

Forgot all about GParted .. brain fart.

deleted all the partitions on the microsd card in gparted, then, using disk management on windows, created a new volume .. and all is well.

I also went ahead and resized the partition, on the sd card in the rock64, to use all the empty space, while I was in gparted.

You are rught about the rock 64 images using a lot more partitions, then the PI ... looks like 7 on the rock 64.

Again, thanks for helping the noob.

For future refrence ....

I was curious when the 7 partitions are created, so I took note when I burned a image on my windows PC. All the partitions are created, when the image is burned. As soon as I exit the program used to burn the image, the sdcard is unmounted from the PC.

Not really important, I was just curious, if they were created in a first run script.

I struggled with this recently and found a novel solution. I took the Linux sdcard and put it in a camera and formatted it inside the camera. It worked perfectly and all the extra partitions were removed. I liked this strategy better than using something like gparted or windows disk management which if used improperly could ruin your hard drive.

Sent from my SM-T537V using Tapatalk

Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 Debian 11 (Bullseye) install problem jbize 15 8,797 10-12-2023, 05:14 PM
Last Post: tpaul
  Buildroot 2021.08 not booting from SD card jimmy 1 2,085 11-08-2021, 02:25 AM
Last Post: hunderteins
  External hard drive problem k8Va 17 22,853 03-09-2021, 02:31 PM
Last Post: calinb
  Arch Linux Arm - external RTC problem max 1 3,031 08-17-2020, 10:35 AM
Last Post: max
  Read-only problem mikedhoore 5 6,973 07-14-2020, 11:41 AM
Last Post: zein
Question bluetooth rock64 problem deta 3 5,149 05-06-2020, 11:29 PM
Last Post: deta
  Fedora 31 crosscompilation fdt problem mimics debian 888789 kf5zmi 2 4,241 01-20-2020, 12:25 PM
Last Post: kf5zmi
  Rock 64 dashboard a639157781 0 1,895 01-07-2020, 10:14 AM
Last Post: a639157781
  Nextcloudpi SD card fills up. default_user8 13 17,033 12-04-2019, 01:30 PM
Last Post: Rocklobster
  ROCK64 Kernel compilation problem cao 0 2,504 01-21-2019, 01:21 AM
Last Post: cao

Forum Jump:

Users browsing this thread: 1 Guest(s)