RockPro64 - Armbian no sound from jack
#1
Anyone else problem with Armbian and getting no sound from the jack?
When I open a music stream and have a look in the volume control I see the graphic VU bar moving. Tried different stuff but can't find the solution from the problem.


I'm a total Linux n00b but I did find a command on the internet which I tried and said this:

master@rockpro64:/etc/alsa/conf.d$ aplay -L
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
jack
    JACK Audio Connection Kit
pulse
    PulseAudio Sound Server
sysdefault:CARD=rkes8316hpsound
    rk-es8316-hp-sound,
    Default Audio Device
dmix:CARD=rkes8316hpsound,DEV=0
    rk-es8316-hp-sound,
    Direct sample mixing device
dsnoop:CARD=rkes8316hpsound,DEV=0
    rk-es8316-hp-sound,
    Direct sample snooping device
hw:CARD=rkes8316hpsound,DEV=0
    rk-es8316-hp-sound,
    Direct hardware device without any conversions
plughw:CARD=rkes8316hpsound,DEV=0
    rk-es8316-hp-sound,
    Hardware device with all software conversions
usbstream:CARD=rkes8316hpsound
    rk-es8316-hp-sound
    USB Stream Output
sysdefault:CARD=rkspdifsound
    rk-spdif-sound,
    Default Audio Device
dmix:CARD=rkspdifsound,DEV=0
    rk-spdif-sound,
    Direct sample mixing device
dsnoop:CARD=rkspdifsound,DEV=0
    rk-spdif-sound,
    Direct sample snooping device
hw:CARD=rkspdifsound,DEV=0
    rk-spdif-sound,
    Direct hardware device without any conversions
plughw:CARD=rkspdifsound,DEV=0
    rk-spdif-sound,
    Hardware device with all software conversions
usbstream:CARD=rkspdifsound
    rk-spdif-sound
    USB Stream Output
sysdefault:CARD=rkhdmidpsound
    rk-hdmi-dp-sound,
    Default Audio Device
dmix:CARD=rkhdmidpsound,DEV=0
    rk-hdmi-dp-sound,
    Direct sample mixing device
dsnoop:CARD=rkhdmidpsound,DEV=0
    rk-hdmi-dp-sound,
    Direct sample snooping device
hw:CARD=rkhdmidpsound,DEV=0
    rk-hdmi-dp-sound,
    Direct hardware device without any conversions
plughw:CARD=rkhdmidpsound,DEV=0
    rk-hdmi-dp-sound,
    Hardware device with all software conversions
usbstream:CARD=rkhdmidpsound
    rk-hdmi-dp-sound
    USB Stream Output
master@rockpro64:/etc/alsa/conf.d$
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  New OS for RockPro64 is here, TwisterOS Armbian jtremblant 56 6,260 02-25-2021, 03:23 PM
Last Post: jtremblant
Question My Rockpro64 stopped booting with these error messages please help seaurchin 4 135 02-18-2021, 04:27 PM
Last Post: TRS-80
  Rockpro64 not stable... crashes now and then. Pineapple 18 4,560 02-16-2021, 02:45 PM
Last Post: TRS-80
Question Mainline Debian Buster on RockPro64 ? chrestomanci 36 9,589 02-14-2021, 02:37 PM
Last Post: foresto
  with armbian. my boad seems alive LMM 0 87 02-11-2021, 03:24 PM
Last Post: LMM
  Armbian images available Luke 45 24,540 02-08-2021, 10:34 PM
Last Post: NightCrawler504
  Alpine on RockPro64 mutemule 0 130 02-05-2021, 10:10 AM
Last Post: mutemule
  OpenSuse for ROCKPro64: testimage hemertje 1 210 02-01-2021, 04:25 AM
Last Post: cryolithic
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 41 18,103 01-29-2021, 06:13 AM
Last Post: mara
  Chromium OS for the RockPro64 is now available! Luke 9 4,545 01-09-2021, 12:13 PM
Last Post: Ruben

Forum Jump:


Users browsing this thread: 1 Guest(s)