can not boot pinebook pro from recent production run
#1
Photo 
Last week I recieved a pinebook pro. 2 days ago and was able to boot into manjaro. I then tried tried to install slackware as per the slackware aarch64  install instructions which seem relevant to earlier pbp's but not to the latest production run. Switch 24 is now a dip switch in a different location and it appears that the slackwareaarch64 flash-spi-pinebookpro.img does not work.

On the slackwarearm forum I was told by one member that he also has a pbp from the most recent production run and that the slackware installation would not work one the new pbp and that he installed by first using these instructions Which gave him tow-boot. I gave that a go but couldn't boot from the sd card. Used a brand new 32g class 10 card and a 16g class 10 card from pinestore. I also tried a couple of sd cards I had previously used to boot bananapros but could not boot from the sd card.

I have checked the ribbon cable sd slot connection and its good. I've tried the dip switch in both positions and with/without emmc installed. I've used the restore/reset buttons as well. 

As it turns out I can no longer boot into manjaro with dip switch 24 in its original position (see below) or indeed switch in the opposite position. I'm at a loss as where to go next. I've read some posts about this problem but without being able to boot from an sd card they weren't much help. Any suggestions would be most welcome.

[Image: attachment.php?attachmentid=39747&d=1666247242]
  Reply
#2
Further to my previous post I have also just received a ROCKPro64. I have not installed slack on it yet but the installer can boot from the sdcard.  If I install slack on the rpk I should be able to re-flash a manjaro image to the emmc card. If I can then boot manjaro I should then be able to flash tow-uboot to SPI. After that I should be  be able to select to boot from an sdcard with the slackware installer and install slack on a nvme ssd. after that install I'll essentially have a manjaro/slackware dual boot

Does this sound reasonable? I've been running pi's and banana's for quite some time but this is all new territory for me.
  Reply
#3
If I understand correctly, you messed up the SPI, Here's a link: https://wiki.pine64.org/index.php/Pinebook_Pro_SPI
Satisfied Pinephone & Pinebook Pro owner.
Thank you PineTeam for your outstanding work!
  Reply
#4
My advice is
1) disable the SPI ROM and eMMC
2) boot from micro-SD*
3) enable the SPI ROM and eMMC
4) zero out both the SPI ROM and eMMC
5) install your operating system (with U-boot) to eMMC

*Many readily available micro-SD card boot images don't actually boot without U-boot or Tow-boot on the SPI or eMMC. The only one I can say for certain does is the DietPi one from the wiki. I have read reports of other operating systems that work, but I know for certain that DietPi does.
:wq



[ SRA accepts you ]
  Reply
#5
Quote:4) zero out both the SPI ROM and eMMC
How would I go about doing that? I could put the emmc an my rockpro64 and zero it but how would I zero the spi if I can't boot anything from a sd card? Maybe try diet pi?
  Reply
#6
@KC9UDX
I just had a look at Diet Pi and it appears that it there is a tow-uboot bin in the image. Had a go anyway but no go. My understanding is that emmc boots if spi is clean, spi boots if u-boot ir some other such on board and if spi is clean and emmc is clean or not present then rk3399 will boot from an sd card. I expect I'll have to do a mask mode manually.
  Reply
#7
It is true that you won't be able to boot from micro-SD if the SPI ROM doesn't transfer boot, which is what's happening to you.

I haven't had to do this, but I expect you could short the appropriate pins on the SPI ROM chip so that it doesn't boot and boot to micro-sd (or eMMC). Otherwise yes, you'll have to to the mask ROM mode thing.

The only reason I mention DietPi is that I know it works. I found out the hard way that all the bootable micro-sd cards I made did not actually boot with a blank eMMC. So I went to the wiki and tried various images, and DietPi was the first one that worked. I was able to use that to zero the eMMC and then write U-boot and NetBSD to it. So if I were you, I'd put that DietPi micro-SD in, and short the appropriate pins on the SPI ROM. When the boot process starts, you can remove your short. Once booted, immediately zero the SPI ROM.
:wq



[ SRA accepts you ]
  Reply
#8
Photo 
Thanks for that. Are you talking about pins CLK and VSS as in the the chip on this page?
  Reply
#9
That picture is correct, yes ground clock,, Vss (or any ground) -> clock
the clock Vcc is behind a 10k resistor, so the power for clock is 0.3 ma (or so)
uboot does not seem to have very good error recovery if all is not the way it should be
ie, unpartitioned media, unformated media
  Reply
#10
OK ... By shorting CLK and VSS pins I had access to the sd card. I had put the salackwareaarch64 spi recovery image on an sd card so after powering on the pbp and unshorting the pins the SPI was re-written and I now have access to the slack installer on an sd card.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Partial boot after installing Manjaro on emmc regivanx 11 254 02-06-2023, 09:11 AM
Last Post: wdt
  Pinebook Pro for sale (Austria / Europe) pato3 0 90 02-03-2023, 01:14 AM
Last Post: pato3
  Unable to Boot anything (emmc or SDcard) line72 5 303 01-17-2023, 12:07 PM
Last Post: nfms
Exclamation PineBook Pro shuts down immediately after booting zogkarndon 5 357 01-10-2023, 10:16 AM
Last Post: Perl6_user
  Pinebook Pro Initial Impressions kunger 440 465,038 01-09-2023, 01:37 PM
Last Post: wdt
  new Pinebook Pro making occasional noises kozak 2 344 12-31-2022, 05:45 AM
Last Post: kozak
  eMMC problem with Tow-Boot/u-boot on SPI repa 1 271 12-30-2022, 11:08 AM
Last Post: repa
  Pinebook Pro for sale GreyHobbyist 0 254 12-27-2022, 11:44 AM
Last Post: GreyHobbyist
Question Inquiring about the PineBook Pro Taiwanese Independence 4 776 12-21-2022, 11:20 PM
Last Post: wangyukunshan
  Firefox causes my pinebook to completely freeze[how to troubleshoot] jcarty 4 546 12-21-2022, 03:55 AM
Last Post: LivingLinux

Forum Jump:


Users browsing this thread: 1 Guest(s)