Pinebook Pro won't boot
I was following the instructions on here, before halfway through the process of flashing u-boot, the screen went black, I assume because the battery ran out, so I plugged it in and now it won't boot up at all, the only feedback I get is the red dot from the charging cable being plugged in and the CPU is warm now. The power indicator on the keyboard no longer lights up. I've attempted to boot with the emmc both enabled and disabled, while on battery and while plugged in, and with the SD card inserted and removed, all to the same result. Is there anything I can do? I believe my spi flash is corrupted.
(08-26-2022, 12:58 AM)wangyukunshan Wrote:

It didn't work for me and I'm not getting the power light when I try to turn it on like they do in this post
Same boat. Booted from SD flashed Manjaro Gnome distro for PbPro to emmc, never turned on again. eMMC switch did nothing. Power button useless. Reset did nothing. Battery or a/c bypass did nothing. Removed eMMC did nothing. Can't get it to power to even try booting from the SD card again.

Absolute trash. F Pine. F Pinebook Pro.
Your impatience and lack of understanding does not imply a bad product or company. I have seen reports of Pinebooks Pro being thrown in the trash. If you feel inclined to do that, please sell it in stead

It seems to me that it has gotten popular lately to flash U-boot (and alternatives) to SPI flash, making troubleshooting more difficult.

The biggest problem I find is making a micro-sd card that actually boots. Most of them that seem to boot rely on a working and cooperative U-boot on the eMMC. The second biggest problem is making sure the PBP is actually turned off after locking up from an errant boot. Then you have to make sure that SPI flash is erased (all zeroes) or is disabled.

I recently went through the list of bootable sd images in the wiki and the first one I could find that actually worked was DietPi, which I was able to use to wipe out the eMMC and recover the system. I would expect you could erase the SPI flash as well. Others have reported other operating system image that work. But I know the DietPi one works.

[ SRA accepts you ]

Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinebook Pro ANSI for Sale crazychaz 0 70 12-02-2022, 10:37 AM
Last Post: crazychaz
  Pinebook Pro+/2 or so :) saddamus 1 98 12-02-2022, 10:12 AM
Last Post: xgpt
  Pinebook Pro drains ny battery after shutting it off Tongman 4 228 12-01-2022, 02:50 AM
Last Post: KC9UDX
  how to make a bootable USB linux sine pinebook will not boot up River 12 288 11-29-2022, 05:41 AM
Last Post: KC9UDX
  Firefox causes my pinebook to completely freeze[how to troubleshoot] jcarty 1 93 11-26-2022, 09:32 AM
Last Post: KC9UDX
  Pinebook Pro only started once River 8 221 11-25-2022, 06:54 PM
Last Post: River
  PineBook Pro - Did I buy the wrong computer? astral 7 810 11-18-2022, 10:18 PM
Last Post: KiteX3
  U-boot Updates jaredoconnor 5 307 11-17-2022, 04:25 PM
Last Post: wdt
  Pinebook Pro Initial Impressions kunger 437 443,876 11-17-2022, 01:05 PM
Last Post: tophneal
Question High Pitch Noise Coming From Pinebook Pro Feakster 60 61,223 11-16-2022, 02:51 PM
Last Post: kebab

Forum Jump:

Users browsing this thread: 1 Guest(s)