Did i break my wifi with the keyboard?
#1
Hello dear fellow pinephonians.

I recently got my pinephone keyboard and was too excited to search for proper instructions,
so i connected the keyboard, while the pinephone was running. I have no idea, if this was the
problem, or if i created the damage on some other way, but my wifi (also bluetooth) does not work anymore.

I am running arch linux with phosh. The wifi card is properly detected and can be disabled/enabled via phosh ui or nmcli,
but whatever i try, i can't seem to find any networks.
I also tried searching from the terminal, using
Code:
sudo iw dev wlan0 scan
but so far no luck.

I also tried disabling/enabling wifi with the tiny switch on the back on the pinephone. No luck as well.
Has this happened to anyone else and has anyone an idea, if this is fixable?

I am currently downloading megis multi-distro image, to see, if this still happens, when i use another system.
  Reply
#2
WiFi did not work in Mobian, PostmarketOS and SailfishOS as well.
  Reply
#3
Did you find a fix for this? I'm having the same issue on my UBports CE Pinephone running Mobian Bookworm from eMMC and the latest (from late january) multiboot image from uSD.

Wireless and bluetooth show as on and can be toggled off from both graphical and terminal interfaces but scanning for devices show no networks in any of the OS images I've tried.

The same happens with the phone removed from the keyboard cover. Both wifi/bt were fine yesterday in the eMMC Mobian install.
  Reply
#4
I don't know if you damaged it, but I’m on Mobian’s weekly build; WiFi, Bluetooth and the keyboard are working fine with the PinePhone.
(Bluetooth connected to my JBL Speaker with no problems & it even picked up my neighbor’s T.V.)

Here’s a link:
https://images.mobian-project.org/pinephone/weekly/
Thank you PineTeam for your work!
  Reply
#5
I'm also running the latest Mobian build from eMMC, but just to be sure I flashed a fresh uSD card with the latest weekly (2022-01-16): same result. All hardware toggles are on, and I get no wifi networks found standing right next to my router (though the wifi chip seems to be found by the os, as it is toggleable in the settings). Bluetooth seems to not even be found, as the settings page just says "no bluetooth device present".

This happens with the keyboard cover, with the stock cover and with no cover at all.
  Reply
#6
I found the wifi to be working strangely in general. The message I get in wpa_supplicant.service is "nl80211: kernel reports: Authentication algorithm number required'" and then it won't do anything until I suspend and resume, get lucky directly or not, maybe reboot. I bet the driver is has just too many issues, it's not in Linux mainlin for reasons.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Mobian and Keyboard tim.senecal 13 2,844 06-23-2022, 10:09 PM
Last Post: SukiiPooru
  keyboard and usb-c oihantto64 16 2,160 06-11-2022, 05:41 PM
Last Post: theResonant
  Keyboard support broken in Mobian? MacarioMorenoUK 2 178 06-08-2022, 02:34 AM
Last Post: MacarioMorenoUK
  Can't find "-" on the keyboard gilwood 1 154 06-05-2022, 12:57 PM
Last Post: tecdroid
  Why not Atheros ath9k_htc for wifi? altulke 11 688 05-19-2022, 01:55 PM
Last Post: altulke
  adding some keys to pp keyboard case, pageup, pagedown, f11, f12, maybe others zetabeta 1 221 04-30-2022, 08:18 PM
Last Post: TRS-80
  pine64 keyboard pogo 'no-go' pins --- 3 717 04-29-2022, 04:59 AM
Last Post: Humid Stylus
  PinePhone Keyboard KJ6OHG 10 2,230 03-02-2022, 10:38 AM
Last Post: lacriz
  No underscore on pinephone keyboard gilwood 3 681 02-25-2022, 07:43 AM
Last Post: gilwood
  Wifi doesn't respond jmlich 6 906 02-04-2022, 06:50 PM
Last Post: bcnaz

Forum Jump:


Users browsing this thread: 1 Guest(s)