2021.10 u-boot broken on emmc
#1
I just spent a while troubleshooting and I didn't see any post.

The most recent u-boot release, 2021.10, doesn't work for booting from the emmc. It works fine on the sd card with emmc disabled.  Here's the error that it sends over serial:

Code:
U-Boot TPL 2021.10-1 (Oct 10 2021 - 22:34:18)
Channel 0: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
Channel 1: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
256B stride
lpddr4_set_rate: change freq to 400000000 mhz 0, 1
lpddr4_set_rate: change freq to 800000000 mhz 1, 0
Trying to boot from BOOTROM
Returning to boot ROM...

U-Boot SPL 2021.10-1 (Oct 10 2021 - 22:34:18 +0000)
Trying to boot from SPI
Trying to boot from MMC2
Card did not respond to voltage select! : -110
spl: mmc init failed with error: -95
SPL: failed to boot from all boot devices
### ERROR ### Please RESET the board ###

Someone reported it on the u-boot mailing list but it hasn't gotten much follow up
https://www.mail-archive.com/u-boot@list...16881.html
  Reply
#2
(10-26-2021, 08:33 PM)clonex10100 Wrote: I just spent a while troubleshooting and I didn't see any post.

The most recent u-boot release, 2021.10, doesn't work for booting from the emmc. It works fine on the sd card with emmc disabled.  Here's the error that it sends over serial:

Code:
U-Boot TPL 2021.10-1 (Oct 10 2021 - 22:34:18)
Channel 0: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
Channel 1: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
256B stride
lpddr4_set_rate: change freq to 400000000 mhz 0, 1
lpddr4_set_rate: change freq to 800000000 mhz 1, 0
Trying to boot from BOOTROM
Returning to boot ROM...

U-Boot SPL 2021.10-1 (Oct 10 2021 - 22:34:18 +0000)
Trying to boot from SPI
Trying to boot from MMC2
Card did not respond to voltage select! : -110
spl: mmc init failed with error: -95
SPL: failed to boot from all boot devices
### ERROR ### Please RESET the board ###

Someone reported it on the u-boot mailing list but it hasn't gotten much follow up
https://www.mail-archive.com/u-boot@list...16881.html
I think very few people update U-Boot, but it looks like it is better people don't update to U-boot 2021.10.
Thanks for the report.
  Reply
#3
I'm not updating uboot often enough but this did caught me by surprise once I flashed the eMMC...

Device: Pinebook Pro 128GB No:246 / MainOS: Manjaro ARM
Godot and Flutter - creating something can be fun with the right tools!
  Reply
#4
Not sure if this related, but I just noticed this in the fixes section of the latest Manjaro (not sure if this was already reported with earlier updates).

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

https://forum.manjaro.org/t/arm-stable-u...ls/94518/2
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Partial boot after installing Manjaro on emmc regivanx 6 124 01-31-2023, 06:48 AM
Last Post: wdt
  Broken usb-c to hdmi with kernel 5.18+ rfm83 6 873 01-22-2023, 09:55 PM
Last Post: rfm83
  Unable to Boot anything (emmc or SDcard) line72 5 281 01-17-2023, 12:07 PM
Last Post: nfms
  eMMC problem with Tow-Boot/u-boot on SPI repa 1 248 12-30-2022, 11:08 AM
Last Post: repa
  how to make a bootable USB linux sine pinebook will not boot up River 14 1,043 12-11-2022, 11:12 PM
Last Post: wdt
  What OS have you recently flashed onto PBP eMMC? jcun4128 6 732 11-26-2022, 09:39 AM
Last Post: KC9UDX
  U-boot Updates jaredoconnor 5 703 11-17-2022, 04:25 PM
Last Post: wdt
  1st boot chrisrook 5 1,158 11-15-2022, 02:51 PM
Last Post: igorp
  Cannot Boot From SD Card xp19375 4 821 11-12-2022, 11:26 AM
Last Post: KC9UDX
  Unable to boot from emmc after flashing it rfm83 3 630 11-08-2022, 10:59 PM
Last Post: rfm83

Forum Jump:


Users browsing this thread: 2 Guest(s)