PXE boot - unable to login
#1
Hi all,
  I try to boot over the network (PXE boot) and follow the tutorial https://forum.pine64.org/showthread.php?tid=6814 with the Armbian image. After some hours to understand at the end that iptables was blocking the tftp connection Angry I was able to boot but I cannot login : it is stuck when I enter the login or new password.
Do you have an idea of how to solve this issue ? root mount error ? NFS problem ?

LMM
  Reply
#2
(04-22-2021, 07:44 AM)LMM Wrote: Hi all,
  I try to boot over the network (PXE boot) and follow the tutorial https://forum.pine64.org/showthread.php?tid=6814 with the Armbian image. After some hours to understand at the end that iptables was blocking the tftp connection Angry I was able to boot but I cannot login : it is stuck when I enter the login or new password.
Do you have an idea of how to solve this issue ? root mount error ? NFS problem ?

LMM

I tried with both @ayufan  and @sigmaris  U-boot :

- Sigmaris U-boot stopped at booting level :
Code:
....
TFTP from server 172.21.200.1; our IP address is 172.21.200.31
Filename 'dtb-5.10.21-rockchip64/rockchip/rk3399-rockpro64.dtb'.
Load address: 0x1f00000
Loading: ######
         1.4 MiB/s
done
Bytes transferred = 75809 (12821 hex)
Moving Image from 0x2080000 to 0x2200000, end=3de0000
## Flattened Device Tree blob at 01f00000
   Booting using the fdt blob at 0x1f00000

- Ayufan stopped at login level
  Reply
#3
Now it works with a not "first boot" boot files. But only with ayufan u-boot.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Unable to Run GNOME or KDE due to "dmidecode" segmentation fault rrs64 5 3,276 05-04-2022, 02:14 AM
Last Post: phoebepearl123
  enble boot after power loss/restore dkebler 4 601 04-18-2022, 03:58 AM
Last Post: ok38
  no boot white led flashing moserwi 3 392 03-28-2022, 07:26 PM
Last Post: Rocklobster
  Cannot get my board to boot deutschlmao 10 1,129 03-19-2022, 07:45 PM
Last Post: Rocklobster
  Enabling secure boot arturkow 4 929 11-25-2021, 04:57 AM
Last Post: arturkow
  Device unable to boot Lunix33 9 3,474 09-23-2021, 01:38 AM
Last Post: LMM
  Flashed SPI, able to ping RP64 but not boot from sdcard/usb korefuji 2 1,283 08-26-2021, 11:41 AM
Last Post: LMM
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 103 62,747 07-08-2021, 04:55 PM
Last Post: Mentaluproar
  First boot - no fan, no display... is it broken? rantoie 1 1,289 04-28-2021, 04:41 PM
Last Post: rantoie
  unable to boot from SDCard Charles Tarkowski 4 2,965 12-16-2020, 11:11 AM
Last Post: Charles Tarkowski

Forum Jump:


Users browsing this thread: 1 Guest(s)