accident got 12v at my rock64
#1
hello,
i got accidently plug psu 12v to my rock64, what i can do to make it run again?

i plug 5v 3amp the green lamp is on. but cannot boot at all

what i can help to solved this. looks like something burn. what i must check?
is this chip "25Q127C" got burn if i got plug wrong psu?
  Reply
#2
I've actually done the same thing before -- your Rock64 is almost definitely dead, sorry. 12V will pretty much kill everything on the board.
Community administrator and sysadmin for PINE64
(Translation: If something breaks on the website, forum, or chat network, I'm a good person to yell at about it)

  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Are HW design files available for ROCK64? irenek 1 357 09-29-2020, 05:57 PM
Last Post: tllim
  No sound from Rock64 DAC codebreaker 2 222 09-29-2020, 02:14 PM
Last Post: codebreaker
  Which Voltage and Amper to supply both Rock64 + External drive enclosure ? prog-amateur 0 262 08-21-2020, 09:16 PM
Last Post: prog-amateur
Information Rock64 RTL8188EU Wifi Adapter from Pine Store Tested Well MarkHaysHarris777 7 2,682 05-13-2020, 06:00 PM
Last Post: Leon Rembowski
  Help! Rock64 won't boot anything! trohn_javolta 3 884 03-09-2020, 06:03 PM
Last Post: tllim
  Power Supply and Sinks for multi-Rock64 env Davo-CC 1 1,555 01-02-2020, 02:26 PM
Last Post: dpgraham
Lightbulb Mount a HeatSink on the Rock64 using 3M Thermal Tapes MarkHaysHarris777 22 17,136 11-29-2019, 03:14 AM
Last Post: ab1jx
  My Rock64 died (with a happy ending!) rmbusy 1 1,012 08-15-2019, 06:48 PM
Last Post: tllim
Information Brushless Fan (5v) for Rock64 Clear Case Soft PWM Drive 2N2222 MarkHaysHarris777 7 6,447 07-09-2019, 06:15 AM
Last Post: merwone
  Rock64 stereo audio dac add-on board with RockPro64 Tim13 1 880 07-08-2019, 07:15 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)