Rock64 ethernet not working during install OpenBSD

Just got my Rock64 v2 1GB ram yesterday, and I failed installing OpenBSD, just because the Ethernet not working.

This was my first time dealing with a series connection, it went fine, until when actual installing, it stuck at not being able to downloading anything through network.

The Rock64 actually got an IP address from DHCP ant it seemed fine, the ethernet just didn't transfer.

I was using the steps from OpenBSD mailing list as follow:

dd if=miniroot66.fs of=/dev/rsd2c bs=1m

mount /dev/sd2i /mnt
mkdir /mnt/rockchip
cp /usr/local/share/dtb/arm64/rockchip/rk3328-rock64.dtb /mnt/rockchip
umount /mnt

dd if=/usr/local/share/u-boot/rock64-rk3328/idbloader.img of=/dev/sd2c bs=512 seek=64 conv=sync
dd if=/usr/local/share/u-boot/rock64-rk3328/u-boot.itb of=/dev/sd2c bs=512 seek=16384 conv=sync

It worked until failed to use the Ethernet to download data. How do I do to make it work?
Please can you try OpenBSD 6.7?

Just installed 6.7 on a board. No problems with my board. Also version v2.0 but the 4GiB version.
(05-21-2020, 11:02 AM)krjdev Wrote: Please can you try OpenBSD 6.7?

Just installed 6.7 on a board. No problems with my board. Also version v2.0 but the 4GiB version.

To some extend, 6.7 can be installed. Only in the end when the kernel was relinking, this error message bump out repeatedly:

    dwmmc0: timeout on data busy

I have to plug the power supply and restart it. As you can imagine, it stuck at:
Enter pathname of shell or RETURN for sh:

Any ideas how to solve this? Perhaps I need a new version of rk3328-rock64.dtb, idbloader.img and u-boot.itb.

Edit: I will report back after I redo the process with latest files.

Edit1: Yes, this time I got it working!
Now OpenBSD 6.7 is running on it, however it seems lack cpu frequency info and such, I am afraid it cannot be running at its full potential.

All files for installation are taken from 6.7 release. Anyone know how to solve this issue?

Edit: It turned out to be that I missed one step after all:
mount /dev/sd2i /mnt
mkdir /mnt/rockchip
cp /usr/local/share/dtb/arm64/rockchip/rk3328-rock64.dtb /mnt/rockchip
umount /mnt

Now this issue has resolved.
Just to be clear of my situation, I have bought two batches of Rock64 v2, the one worked with OpenBSD 6.7 is batch 2.

I just found it when I was trying to switch the micro SD card from installed batch 2 Rock64 v2 to the batch 1 machine, the internet access became painfully slow.

It seems the issue at my first post in this thread is still there.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Tutorial: Install OpenBSD on ROCK64 media board krjdev 31 41,989 04-29-2023, 04:32 AM
Last Post: newestssd
  FreeBSD and gig ethernet roboman 2 2,826 11-04-2021, 12:51 AM
Last Post: Enig123
  OpenBSD 6.7 microSD card image krjdev 4 8,495 05-31-2020, 12:46 PM
Last Post: krjdev
Information NetBSD for Rock64 Luke 4 8,351 01-14-2020, 10:19 PM
Last Post: fmotsch
  OpenBSD: GPIO with the I2C device PCF8574(A) krjdev 0 3,801 08-09-2018, 06:41 AM
Last Post: krjdev
  AMENDED: OpenBSD, GigE Adapters/Chipsets, and ROCK64 STEREO AUDIO DAC ADD-ON BOARD jovval 1 4,209 08-07-2018, 02:44 AM
Last Post: krjdev

Forum Jump:

Users browsing this thread: 1 Guest(s)