Is it possible to start a Linux X11 Server using the 7" DSI LCD?
#1
The problem: I cannot start an Xorg server with startx or xinit, and I never get past Xorg being unable to find a screen to display to.

Hardware: SoPine64, 7" LCD(https://store.pine64.org/?product=7-lcd-...reen-panel)
OS(output of uname -a): Linux sopine 3.10.105-bsp-1.2-ayufan-140 #1 SMP PREEMPT Tue Oct 30 14:21:35 UTC 2018 aarch64 aarch64 aarch64 GNU/Linux
Downloaded from https://github.com/ayufan-pine64/linux-b...tag/0.7.30 > assets > bionic-minimal-sopine-bspkernel-0.7.30-140.img.xz

I am using this specific OS because this is the only one I could find that enables using the 7" LCD with Linux

What I can do:
I can connect the display to the DSI port, connect a keyboard via usb and access the terminal on the lcd screen after enabling the lcd display via /boot/uEnv.txt
But I cannot start an Xorg server

Log file after running startx 
~/.local/share/xorg/Xorg.0.log

Code:
X.Org X Server 1.19.6
Release Date: 2017-12-20
[  2670.852] X Protocol Version 11, Revision 0
[  2670.853] Build Operating System: Linux 4.4.0-148-generic aarch64 Ubuntu
[  2670.855] Current Operating System: Linux sopine 3.10.105-bsp-1.2-ayufan-140
#1 SMP PREEMPT Tue Oct 30 14:21:35 UTC 2018 aarch64
[  2670.855] Kernel command line: console=ttyS0,115200n8 enforcing=0 cma=384M no
_console_suspend androidboot.serialno=041078918210181d070f androidboot.hardware=
sun50iw1p1 androidboot.selinux=permissive earlyprintk=sunxi-uart,0x01c28000 logl
evel=8 root=/dev/mmcblk0p2 eth0_speed=auto
[  2670.862] Build Date: 03 June 2019  08:11:53AM
[  2670.865] xorg-server 2:1.19.6-1ubuntu4.3 (For technical support please see h
ttp://www.ubuntu.com/support)
[  2670.867] Current version of pixman: 0.34.0
[  2670.871]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  2670.872] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2670.882] (==) Log file: "/home/pine64/.local/share/xorg/Xorg.0.log", Time: T
ue Feb  4 23:45:50 2020
[  2670.886] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  2670.889] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2670.889] (==) No Layout section.  Using the first Screen section.
[  2670.889] (==) No screen section available. Using defaults.
[  2670.889] (**) |-->Screen "Default Screen Section" (0)
[  2670.889] (**) |   |-->Monitor "<default monitor>"
[  2670.890] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
[  2670.890] (**) |   |-->Device "Allwinner A10/A13 FBDEV"
[  2670.890] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[  2670.890] (==) Automatically adding devices
[  2670.890] (==) Automatically enabling devices
[  2670.890] (==) Automatically adding GPU devices
[  2670.890] (==) Automatically binding GPU devices
[  2670.890] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  2670.891] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  2670.891]    Entry deleted from font path.
[  2670.891] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  2670.891]    Entry deleted from font path.
[  2670.891] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  2670.891]    Entry deleted from font path.
[  2670.891] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[  2670.891]    Entry deleted from font path.
[  2670.891] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  2670.891]    Entry deleted from font path.
[  2670.891] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  2670.891]    Entry deleted from font path.
[  2670.891] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        built-ins
[  2670.891] (==) ModulePath set to "/usr/lib/xorg/modules"
[  2670.891] (II) The server relies on udev to provide the list of input devices
.
        If no devices become available, reconfigure udev or disable AutoAddDevic
es.
[  2670.891] (II) Loader magic: 0x557678d010
[  2670.891] (II) Module ABI versions:
[  2670.891]    X.Org ANSI C Emulation: 0.4
[  2670.891]    X.Org Video Driver: 23.0
[  2670.891]    X.Org XInput driver : 24.1
[  2670.891]    X.Org Server Extension : 10.0
[  2670.893] (++) using VT number 1

[  2670.896] (II) systemd-logind: took control of session /org/freedesktop/login
1/session/c1
[  2670.897] (II) no primary bus or device found
[  2670.897] (II) LoadModule: "glx"
[  2670.898] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  2670.901] (II) Module glx: vendor="X.Org Foundation"
[  2670.901]    compiled for 1.19.6, module version = 1.0.0
[  2670.901]    ABI class: X.Org Server Extension, version 10.0
[  2670.901] (II) LoadModule: "fbturbo"
[  2670.902] (WW) Warning, couldn't open module fbturbo
[  2670.902] (II) UnloadModule: "fbturbo"
[  2670.902] (II) Unloading fbturbo
[  2670.902] (EE) Failed to load module "fbturbo" (module does not exist, 0)
[  2670.902] (==) Matched modesetting as autoconfigured driver 0
[  2670.902] (==) Matched fbdev as autoconfigured driver 1
[  2670.902] (==) Assigned the driver to the xf86ConfigLayout
[  2670.902] (II) LoadModule: "modesetting"
[  2670.902] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  2670.903] (II) Module modesetting: vendor="X.Org Foundation"
[  2670.903]    compiled for 1.19.6, module version = 1.19.6
[  2670.903]    Module class: X.Org Video Driver
[  2670.903]    ABI class: X.Org Video Driver, version 23.0
[  2670.903] (II) LoadModule: "fbdev"
[  2670.903] (WW) Warning, couldn't open module fbdev
[  2670.903] (II) UnloadModule: "fbdev"
[  2670.903] (II) Unloading fbdev
[  2670.903] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  2670.903] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  2670.903] (WW) Falling back to old probe method for modesetting
[  2670.904] (EE) open /dev/dri/card0: No such file or directory
[  2670.904] (WW) Falling back to old probe method for modesetting
[  2670.904] (EE) open /dev/dri/card0: No such file or directory
[  2670.904] (EE) No devices detected.
[  2670.904] (EE)
Fatal server error:
[  2670.904] (EE) no screens found(EE)
[  2670.904] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[  2670.904] (EE) Please also check the log file at "/home/pine64/.local/share/x
org/Xorg.0.log" for additional information.
[  2670.904] (EE)
[  2670.934] (EE) Server terminated with error (1). Closing log file.

What I've tried:
Running startx
Running xinit
Running X -configure
Modifying the existing X configuration files to reference what I think are the proper drivers for the LCD
The X configuration files are hosted online here: https://github.com/ayufan-pine64/linux-b...org.conf.d
Analyzing the hardware configuration using lspci(nothing), lsusb, lshw, lsmod, modinfo disp
Trying to install other drivers xf86-video-fbdev, xf86-video-modesetting, xf86-video-vesa

Any help is greatly appreciated. If anyone has started an X server before in a similar environment let me know
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)