Only reach command line

I finally got my Pine64 2GB board. The creation of an SD card went quite smooth, thanks to all the contributions and people who created the images.

I loaded the longsleep Ubuntu 20160421 image, and it booted up without any pains. 

My question is: I only get to the command line. It does not boot through to the GUI. I ran sudo apt-get update and it updated all packages.

Any suggestions?
Do you know what gui interface you prefer? Gnome, KDE, Xcfe, lxde....... An Internet search should be able to help you with installing that desktop manager. It sounds like you created a new user? And maybe you're missing your ~/.xinitrc file for your new user? Use nano (or your preferred command line browser, vim, etc)

nano ~/.xinitrc

See if it comes up with an empty file. If it does, then you need to copy the default file from the system files.
any interface will do Smile really...any. at this stage i'm only reaching the command line. i've tried the scripts by terra854 but that comes up with a lot of errors.

i didnt create a new user, i just installed the ubuntu image created by longsleep, i think it creates the default user ubuntu.

not really sure how to use nano...i'm really new with linux and have only been playing around with dd, gparted, and the rescue software for data recovery.
Ok. Try this command:

Apt-get install nano
Nano ~/xinitrc

What are the results?

Can you post a pic or something with the errors you're getting? That would be helpful.

Problem solved with the 20160501 build of Xubuntu posted on the wiki page.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Which command line only OS? For streaming audio zirconx 5 2,984 09-27-2016, 06:53 AM
Last Post: zirconx

Forum Jump:

Users browsing this thread: 1 Guest(s)