Booting from USB3 while USB2 devices are connected
#1
Hi all,

I've got the v2 board and basically trying to do what the title says.
I installed U-Boot version "1065-g95f6152134" following ayufan's instructions.

- Booting with only USB3 rootfs attached WORKS
- Booting with only USB2 rootfs attached WORKS
- Booting with USB2 rootfs and all other USB ports occupied with non-bootable drives WORKS
- Booting with USB3 rootfs and USB2 ports occupied: FAILS

What I tried so far:
  • Downgrading U-Boot.
  • Testing with 2 different drives.
  • Testing with two different operating systems: Arch (mainline kernel v.5.2.11 and latest uboot from official repo), ayufan's Debian Buster minimal v0.9.14-1159.
Background details:
I've had this board since it launched and been running from MicroSD & Debian.
System has always been slow and recently I identified the cause being the slow on-board reader. 
On board: ~20MB/s read | ~8MB/s write
MicroSD USB3 Adapter: 120MB/s read | 35MB/s write
Using Lexar x1000 UHS-II MicroSD.
I've had this experience with 3 different (slower, but still capable) MicroSD cards.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  ROCK64 not booting TheGiolly 10 270 09-09-2019, 06:57 AM
Last Post: Rocklobster
  Another non-booting ROCK64 SuburbanDad 13 698 06-19-2019, 01:48 AM
Last Post: mcerveny
  usb3 bandwidth pas059 0 264 11-30-2018, 03:34 AM
Last Post: pas059
  booting a kernel over tftp hibernick 0 278 03-08-2018, 10:37 AM
Last Post: hibernick
  Booting from USB Luke 0 5,647 01-21-2018, 03:52 PM
Last Post: Luke
  Rock64 performance: eMMC / SD Card / USB3 (SSD/HDD) Blastmun 15 8,902 08-16-2017, 08:44 AM
Last Post: stuartiannaylor

Forum Jump:


Users browsing this thread: 1 Guest(s)