Netatalk on Debian
#1
Hello, 
I tried, several times, to install Netatalk 3.1.8 on Debian Image (pine64-image-debianlxde-31065bsp), but i can´t get it to work. After configuring my screen stays black, the Pine wont start.

1. install all depencies:
Code:
sudo apt-get install build-essential libevent-dev libssl-dev libgcrypt11-dev libkrb5-dev libpam0g-dev libwrap0-dev libdb-dev libtdb-dev libmysqlclient-dev avahi-daemon libavahi-client-dev libacl1-dev libldap2-dev libcrack2-dev systemtap-sdt-dev libdbus-1-dev libdbus-glib-1-dev libglib2.0-dev tracker libtracker-sparql-1.0-dev libtracker-miner-1.0-dev

this is the output
Code:
...
Fetched 24.2 MB in 31s (760 kB/s)                                                                                      
debconf: delaying package configuration, since apt-utils is not installed
(Reading database ... 94683 files and directories currently installed.)
Preparing to unpack .../libglib2.0-bin_2.42.1-1+b1_arm64.deb ...
Unpacking libglib2.0-bin (2.42.1-1+b1) over (2.42.1-1) ...
Preparing to unpack .../libpcre3_2%3a8.35-3.3+deb8u4_arm64.deb ...
Unpacking libpcre3:arm64 (2:8.35-3.3+deb8u4) over (2:8.35-3.3+deb8u2) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up libpcre3:arm64 (2:8.35-3.3+deb8u4) ...
Processing triggers for libc-bin (2.19-18+deb8u2) ...
(Reading database ... 94684 files and directories currently installed.)
Preparing to unpack .../libglib2.0-0_2.42.1-1+b1_arm64.deb ...
Unpacking libglib2.0-0:arm64 (2.42.1-1+b1) over (2.42.1-1) ...
Preparing to unpack .../libk5crypto3_1.12.1+dfsg-19+deb8u2_arm64.deb ...
Unpacking libk5crypto3:arm64 (1.12.1+dfsg-19+deb8u2) over (1.12.1+dfsg-19+deb8u1) ...
Preparing to unpack .../libgssapi-krb5-2_1.12.1+dfsg-19+deb8u2_arm64.deb ...
Unpacking libgssapi-krb5-2:arm64 (1.12.1+dfsg-19+deb8u2) over (1.12.1+dfsg-19+deb8u1) ...
Preparing to unpack .../libkrb5-3_1.12.1+dfsg-19+deb8u2_arm64.deb ...
Unpacking libkrb5-3:arm64 (1.12.1+dfsg-19+deb8u2) over (1.12.1+dfsg-19+deb8u1) ...
Preparing to unpack .../libkrb5support0_1.12.1+dfsg-19+deb8u2_arm64.deb ...
Unpacking libkrb5support0:arm64 (1.12.1+dfsg-19+deb8u2) over (1.12.1+dfsg-19+deb8u1) ...
Preparing to unpack .../libpam0g_1.1.8-3.1+deb8u1+b1_arm64.deb ...
Unpacking libpam0g:arm64 (1.1.8-3.1+deb8u1+b1) over (1.1.8-3.1+deb8u1) ...
Setting up libpam0g:arm64 (1.1.8-3.1+deb8u1+b1) ...
Processing triggers for libc-bin (2.19-18+deb8u2) ...
(Reading database ... 94686 files and directories currently installed.)
Preparing to unpack .../libgcrypt20_1.6.3-2+deb8u1_arm64.deb ...
Unpacking libgcrypt20:arm64 (1.6.3-2+deb8u1) over (1.6.3-2) ...
Setting up libgcrypt20:arm64 (1.6.3-2+deb8u1) ...
Processing triggers for libc-bin (2.19-18+deb8u2) ...
(Reading database ... 94686 files and directories currently installed.)
Preparing to unpack .../libssl1.0.0_1.0.1k-3+deb8u4_arm64.deb ...
Unpacking libssl1.0.0:arm64 (1.0.1k-3+deb8u4) over (1.0.1k-3+deb8u2) ...
Selecting previously unselected package libgssrpc4:arm64.
Preparing to unpack .../libgssrpc4_1.12.1+dfsg-19+deb8u2_arm64.deb ...
Unpacking libgssrpc4:arm64 (1.12.1+dfsg-19+deb8u2) ...
Selecting previously unselected package libkadm5clnt-mit9:arm64.
Preparing to unpack .../libkadm5clnt-mit9_1.12.1+dfsg-19+deb8u2_arm64.deb ...
Unpacking libkadm5clnt-mit9:arm64 (1.12.1+dfsg-19+deb8u2) ...
Selecting previously unselected package libkdb5-7:arm64.
Preparing to unpack .../libkdb5-7_1.12.1+dfsg-19+deb8u2_arm64.deb ...
Unpacking libkdb5-7:arm64 (1.12.1+dfsg-19+deb8u2) ...
Selecting previously unselected package libkadm5srv-mit9:arm64.
Preparing to unpack .../libkadm5srv-mit9_1.12.1+dfsg-19+deb8u2_arm64.deb ...
Unpacking libkadm5srv-mit9:arm64 (1.12.1+dfsg-19+deb8u2) ...
Selecting previously unselected package libassuan0:arm64.
Preparing to unpack .../libassuan0_2.1.2-2_arm64.deb ...
Unpacking libassuan0:arm64 (2.1.2-2) ...
Selecting previously unselected package libevent-core-2.0-5:arm64.
Preparing to unpack .../libevent-core-2.0-5_2.0.21-stable-2_arm64.deb ...
Unpacking libevent-core-2.0-5:arm64 (2.0.21-stable-2) ...
Selecting previously unselected package libevent-extra-2.0-5:arm64.
Preparing to unpack .../libevent-extra-2.0-5_2.0.21-stable-2_arm64.deb ...
Unpacking libevent-extra-2.0-5:arm64 (2.0.21-stable-2) ...
Selecting previously unselected package libevent-openssl-2.0-5:arm64.
Preparing to unpack .../libevent-openssl-2.0-5_2.0.21-stable-2_arm64.deb ...
Unpacking libevent-openssl-2.0-5:arm64 (2.0.21-stable-2) ...
Selecting previously unselected package libevent-pthreads-2.0-5:arm64.
Preparing to unpack .../libevent-pthreads-2.0-5_2.0.21-stable-2_arm64.deb ...
Unpacking libevent-pthreads-2.0-5:arm64 (2.0.21-stable-2) ...
Selecting previously unselected package libexempi3:arm64.
Preparing to unpack .../libexempi3_2.2.1-2_arm64.deb ...
Unpacking libexempi3:arm64 (2.2.1-2) ...
Selecting previously unselected package pinentry-gtk2.
Preparing to unpack .../pinentry-gtk2_0.8.3-2_arm64.deb ...
Unpacking pinentry-gtk2 (0.8.3-2) ...
Selecting previously unselected package libpth20:arm64.
Preparing to unpack .../libpth20_2.0.7-20_arm64.deb ...
Unpacking libpth20:arm64 (2.0.7-20) ...
Selecting previously unselected package gnupg-agent.
Preparing to unpack .../gnupg-agent_2.0.26-6_arm64.deb ...
Unpacking gnupg-agent (2.0.26-6) ...
Selecting previously unselected package libksba8:arm64.
Preparing to unpack .../libksba8_1.3.2-1_arm64.deb ...
Unpacking libksba8:arm64 (1.3.2-1) ...
Selecting previously unselected package gnupg2.
Preparing to unpack .../gnupg2_2.0.26-6_arm64.deb ...
Unpacking gnupg2 (2.0.26-6) ...
Selecting previously unselected package libgpgme11:arm64.
Preparing to unpack .../libgpgme11_1.5.1-6_arm64.deb ...
Unpacking libgpgme11:arm64 (1.5.1-6) ...
Selecting previously unselected package libgmime-2.6-0:arm64.
Preparing to unpack .../libgmime-2.6-0_2.6.20-1+b1_arm64.deb ...
Unpacking libgmime-2.6-0:arm64 (2.6.20-1+b1) ...
Selecting previously unselected package libmediaart-1.0-0:arm64.
Preparing to unpack .../libmediaart-1.0-0_0.7.0-2_arm64.deb ...
Unpacking libmediaart-1.0-0:arm64 (0.7.0-2) ...
Selecting previously unselected package mysql-common.
Preparing to unpack .../mysql-common_5.5.47-0+deb8u1_all.deb ...
Unpacking mysql-common (5.5.47-0+deb8u1) ...
Selecting previously unselected package libmysqlclient18:arm64.
Preparing to unpack .../libmysqlclient18_5.5.47-0+deb8u1_arm64.deb ...
Unpacking libmysqlclient18:arm64 (5.5.47-0+deb8u1) ...
Selecting previously unselected package libpcrecpp0:arm64.
Preparing to unpack .../libpcrecpp0_2%3a8.35-3.3+deb8u4_arm64.deb ...
Unpacking libpcrecpp0:arm64 (2:8.35-3.3+deb8u4) ...
Selecting previously unselected package libiptcdata0.
Preparing to unpack .../libiptcdata0_1.0.4-4_arm64.deb ...
Unpacking libiptcdata0 (1.0.4-4) ...
Selecting previously unselected package libunistring0:arm64.
Preparing to unpack .../libunistring0_0.9.3-5.2+b2_arm64.deb ...
Unpacking libunistring0:arm64 (0.9.3-5.2+b2) ...
Selecting previously unselected package libtracker-sparql-1.0-0:arm64.
Preparing to unpack .../libtracker-sparql-1.0-0_1.2.4-2_arm64.deb ...
Unpacking libtracker-sparql-1.0-0:arm64 (1.2.4-2) ...
Selecting previously unselected package libtracker-control-1.0-0:arm64.
Preparing to unpack .../libtracker-control-1.0-0_1.2.4-2_arm64.deb ...
Unpacking libtracker-control-1.0-0:arm64 (1.2.4-2) ...
Selecting previously unselected package libtracker-miner-1.0-0:arm64.
Preparing to unpack .../libtracker-miner-1.0-0_1.2.4-2_arm64.deb ...
Unpacking libtracker-miner-1.0-0:arm64 (1.2.4-2) ...
Selecting previously unselected package libupower-glib3:arm64.
Preparing to unpack .../libupower-glib3_0.99.1-3.2_arm64.deb ...
Unpacking libupower-glib3:arm64 (0.99.1-3.2) ...
Selecting previously unselected package gir1.2-mediaart-1.0:arm64.
Preparing to unpack .../gir1.2-mediaart-1.0_0.7.0-2_arm64.deb ...
Unpacking gir1.2-mediaart-1.0:arm64 (0.7.0-2) ...
Selecting previously unselected package gir1.2-tracker-1.0:arm64.
Preparing to unpack .../gir1.2-tracker-1.0_1.2.4-2_arm64.deb ...
Unpacking gir1.2-tracker-1.0:arm64 (1.2.4-2) ...
Selecting previously unselected package comerr-dev.
Preparing to unpack .../comerr-dev_2.1-1.42.12-1.1_arm64.deb ...
Unpacking comerr-dev (2.1-1.42.12-1.1) ...
Selecting previously unselected package krb5-multidev.
Preparing to unpack .../krb5-multidev_1.12.1+dfsg-19+deb8u2_arm64.deb ...
Unpacking krb5-multidev (1.12.1+dfsg-19+deb8u2) ...
Selecting previously unselected package libavahi-common-dev.
Preparing to unpack .../libavahi-common-dev_0.6.31-5_arm64.deb ...
Unpacking libavahi-common-dev (0.6.31-5) ...
Selecting previously unselected package libdbus-1-dev:arm64.
Preparing to unpack .../libdbus-1-dev_1.8.20-0+deb8u1_arm64.deb ...
Unpacking libdbus-1-dev:arm64 (1.8.20-0+deb8u1) ...
Selecting previously unselected package libavahi-client-dev.
Preparing to unpack .../libavahi-client-dev_0.6.31-5_arm64.deb ...
Unpacking libavahi-client-dev (0.6.31-5) ...
Selecting previously unselected package libpcre3-dev:arm64.
Preparing to unpack .../libpcre3-dev_2%3a8.35-3.3+deb8u4_arm64.deb ...
Unpacking libpcre3-dev:arm64 (2:8.35-3.3+deb8u4) ...
Selecting previously unselected package libglib2.0-dev.
Preparing to unpack .../libglib2.0-dev_2.42.1-1+b1_arm64.deb ...
Unpacking libglib2.0-dev (2.42.1-1+b1) ...
Selecting previously unselected package libdbus-glib-1-dev.
Preparing to unpack .../libdbus-glib-1-dev_0.102-1_arm64.deb ...
Unpacking libdbus-glib-1-dev (0.102-1) ...
Selecting previously unselected package libevent-dev.
Preparing to unpack .../libevent-dev_2.0.21-stable-2_arm64.deb ...
Unpacking libevent-dev (2.0.21-stable-2) ...
Selecting previously unselected package libgpg-error-dev.
Preparing to unpack .../libgpg-error-dev_1.17-3_arm64.deb ...
Unpacking libgpg-error-dev (1.17-3) ...
Selecting previously unselected package libgcrypt20-dev.
Preparing to unpack .../libgcrypt20-dev_1.6.3-2+deb8u1_arm64.deb ...
Unpacking libgcrypt20-dev (1.6.3-2+deb8u1) ...
Selecting previously unselected package libgcrypt11-dev.
Preparing to unpack .../libgcrypt11-dev_1.5.4-3+really1.6.3-2+deb8u1_all.deb ...
Unpacking libgcrypt11-dev (1.5.4-3+really1.6.3-2+deb8u1) ...
Selecting previously unselected package libgdk-pixbuf2.0-dev.
Preparing to unpack .../libgdk-pixbuf2.0-dev_2.31.1-2+deb8u4_arm64.deb ...
Unpacking libgdk-pixbuf2.0-dev (2.31.1-2+deb8u4) ...
Selecting previously unselected package libgsf-1-common.
Preparing to unpack .../libgsf-1-common_1.14.30-2_all.deb ...
Unpacking libgsf-1-common (1.14.30-2) ...
Selecting previously unselected package libgsf-1-114.
Preparing to unpack .../libgsf-1-114_1.14.30-2_arm64.deb ...
Unpacking libgsf-1-114 (1.14.30-2) ...
Selecting previously unselected package libmediaart-1.0-dev:arm64.
Preparing to unpack .../libmediaart-1.0-dev_0.7.0-2_arm64.deb ...
Unpacking libmediaart-1.0-dev:arm64 (0.7.0-2) ...
Selecting previously unselected package libmysqlclient-dev.
Preparing to unpack .../libmysqlclient-dev_5.5.47-0+deb8u1_arm64.deb ...
Unpacking libmysqlclient-dev (5.5.47-0+deb8u1) ...
Selecting previously unselected package libpam0g-dev:arm64.
Preparing to unpack .../libpam0g-dev_1.1.8-3.1+deb8u1+b1_arm64.deb ...
Unpacking libpam0g-dev:arm64 (1.1.8-3.1+deb8u1+b1) ...
Selecting previously unselected package libssl-dev:arm64.
Preparing to unpack .../libssl-dev_1.0.1k-3+deb8u4_arm64.deb ...
Unpacking libssl-dev:arm64 (1.0.1k-3+deb8u4) ...
Selecting previously unselected package libssl-doc.
Preparing to unpack .../libssl-doc_1.0.1k-3+deb8u4_all.deb ...
Unpacking libssl-doc (1.0.1k-3+deb8u4) ...
Selecting previously unselected package libtdb-dev.
Preparing to unpack .../libtdb-dev_1.3.1-1_arm64.deb ...
Unpacking libtdb-dev (1.3.1-1) ...
Selecting previously unselected package libtotem-plparser18.
Preparing to unpack .../libtotem-plparser18_3.10.3-1_arm64.deb ...
Unpacking libtotem-plparser18 (3.10.3-1) ...
Selecting previously unselected package libtracker-sparql-1.0-dev:arm64.
Preparing to unpack .../libtracker-sparql-1.0-dev_1.2.4-2_arm64.deb ...
Unpacking libtracker-sparql-1.0-dev:arm64 (1.2.4-2) ...
Selecting previously unselected package libtracker-miner-1.0-dev:arm64.
Preparing to unpack .../libtracker-miner-1.0-dev_1.2.4-2_arm64.deb ...
Unpacking libtracker-miner-1.0-dev:arm64 (1.2.4-2) ...
Selecting previously unselected package libwrap0-dev:arm64.
Preparing to unpack .../libwrap0-dev_7.6.q-25_arm64.deb ...
Unpacking libwrap0-dev:arm64 (7.6.q-25) ...
Selecting previously unselected package systemtap-sdt-dev.
Preparing to unpack .../systemtap-sdt-dev_2.6-0.2_arm64.deb ...
Unpacking systemtap-sdt-dev (2.6-0.2) ...
Selecting previously unselected package tracker.
Preparing to unpack .../tracker_1.2.4-2_arm64.deb ...
Unpacking tracker (1.2.4-2) ...
Selecting previously unselected package tracker-extract.
Preparing to unpack .../tracker-extract_1.2.4-2_arm64.deb ...
Unpacking tracker-extract (1.2.4-2) ...
Selecting previously unselected package tracker-gui.
Preparing to unpack .../tracker-gui_1.2.4-2_arm64.deb ...
Unpacking tracker-gui (1.2.4-2) ...
Selecting previously unselected package tracker-miner-fs.
Preparing to unpack .../tracker-miner-fs_1.2.4-2_arm64.deb ...
Unpacking tracker-miner-fs (1.2.4-2) ...
Selecting previously unselected package tracker-utils.
Preparing to unpack .../tracker-utils_1.2.4-2_arm64.deb ...
Unpacking tracker-utils (1.2.4-2) ...
Selecting previously unselected package upower.
Preparing to unpack .../upower_0.99.1-3.2_arm64.deb ...
Unpacking upower (0.99.1-3.2) ...
Selecting previously unselected package libattr1-dev:arm64.
Preparing to unpack .../libattr1-dev_1%3a2.4.47-2_arm64.deb ...
Unpacking libattr1-dev:arm64 (1:2.4.47-2) ...
Selecting previously unselected package libacl1-dev.
Preparing to unpack .../libacl1-dev_2.2.52-2_arm64.deb ...
Unpacking libacl1-dev (2.2.52-2) ...
Selecting previously unselected package libcrack2-dev.
Preparing to unpack .../libcrack2-dev_2.9.2-1_arm64.deb ...
Unpacking libcrack2-dev (2.9.2-1) ...
Selecting previously unselected package libdb5.3-dev.
Preparing to unpack .../libdb5.3-dev_5.3.28-9_arm64.deb ...
Unpacking libdb5.3-dev (5.3.28-9) ...
Selecting previously unselected package libdb-dev:arm64.
Preparing to unpack .../libdb-dev_5.3.0+b2_arm64.deb ...
Unpacking libdb-dev:arm64 (5.3.0+b2) ...
Selecting previously unselected package libkrb5-dev.
Preparing to unpack .../libkrb5-dev_1.12.1+dfsg-19+deb8u2_arm64.deb ...
Unpacking libkrb5-dev (1.12.1+dfsg-19+deb8u2) ...
Selecting previously unselected package libldap2-dev:arm64.
Preparing to unpack .../libldap2-dev_2.4.40+dfsg-1+deb8u2_arm64.deb ...
Unpacking libldap2-dev:arm64 (2.4.40+dfsg-1+deb8u2) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for dbus (1.8.20-0+deb8u1) ...
Setting up libglib2.0-0:arm64 (2.42.1-1+b1) ...
Setting up libkrb5support0:arm64 (1.12.1+dfsg-19+deb8u2) ...
Setting up libk5crypto3:arm64 (1.12.1+dfsg-19+deb8u2) ...
Setting up libkrb5-3:arm64 (1.12.1+dfsg-19+deb8u2) ...
Setting up ca-certificates-java (20140324) ...
/var/lib/dpkg/info/ca-certificates-java.postinst: line 7: warning: setlocale: LC_CTYPE: cannot change locale (C.UTF-8): No such file or directory
Adding debian:VeriSign_Class_3_Public_Primary_Certification_Authority_-_G4.pem
Adding debian:StartCom_Certification_Authority_2.pem
Adding debian:NetLock_Qualified_=Class_QA=_Root.pem
Adding debian:Cybertrust_Global_Root.pem
Adding debian:ApplicationCA_-_Japanese_Government.pem
Adding debian:ACCVRAIZ1.pem
Warning: there was a problem reading the certificate file /etc/ssl/certs/Certinomis_-_Autorit?_Racine.pem. Message:
 /etc/ssl/certs/Certinomis_-_Autorit?_Racine.pem (No such file or directory)
Adding debian:USERTrust_ECC_Certification_Authority.pem
Adding debian:Verisign_Class_3_Public_Primary_Certification_Authority_2.pem
Adding debian:TWCA_Global_Root_CA.pem
Adding debian:Comodo_Trusted_Services_root.pem
Adding debian:IdenTrust_Public_Sector_Root_CA_1.pem
Adding debian:Hongkong_Post_Root_CA_1.pem
Adding debian:Starfield_Class_2_CA.pem
Adding debian:Certigna.pem
Adding debian:TWCA_Root_Certification_Authority.pem
Adding debian:DigiCert_Trusted_Root_G4.pem
Adding debian:Go_Daddy_Root_Certificate_Authority_-_G2.pem
Adding debian:CFCA_EV_ROOT.pem
Adding debian:IGC_A.pem
Adding debian:Staat_der_Nederlanden_Root_CA.pem
Adding debian:Deutsche_Telekom_Root_CA_2.pem
Warning: there was a problem reading the certificate file /etc/ssl/certs/EBG_Elektronik_Sertifika_Hizmet_Sa?lay?c?s?.pem. Message:
 /etc/ssl/certs/EBG_Elektronik_Sertifika_Hizmet_Sa?lay?c?s?.pem (No such file or directory)
Adding debian:SwissSign_Platinum_CA_-_G2.pem
Adding debian:Hellenic_Academic_and_Research_Institutions_RootCA_2011.pem
Adding debian:Equifax_Secure_CA.pem
Adding debian:Buypass_Class_3_Root_CA.pem
Adding debian:StartCom_Certification_Authority.pem
Warning: there was a problem reading the certificate file /etc/ssl/certs/T?RKTRUST_Elektronik_Sertifika_Hizmet_Sa?lay?c?s?_H5.pem. Message:
 /etc/ssl/certs/T?RKTRUST_Elektronik_Sertifika_Hizmet_Sa?lay?c?s?_H5.pem (No such file or directory)
Adding debian:SecureSign_RootCA11.pem
Adding debian:Actalis_Authentication_Root_CA.pem
Adding debian:XRamp_Global_CA_Root.pem
Warning: there was a problem reading the certificate file /etc/ssl/certs/AC_Ra?z_Certic?mara_S.A..pem. Message:
 /etc/ssl/certs/AC_Ra?z_Certic?mara_S.A..pem (No such file or directory)
Adding debian:GlobalSign_Root_CA.pem
Adding debian:VeriSign_Class_3_Public_Primary_Certification_Authority_-_G5.pem
Adding debian:VeriSign_Universal_Root_Certification_Authority.pem
Adding debian:Swisscom_Root_CA_1.pem
Adding debian:Certum_Root_CA.pem
Adding debian:DigiCert_High_Assurance_EV_Root_CA.pem
Adding debian:Autoridad_de_Certificacion_Firmaprofesional_CIF_A62634068.pem
Adding debian:DigiCert_Global_Root_CA.pem
Adding debian:Microsec_e-Szigno_Root_CA.pem
Adding debian:PSCProcert.pem
Adding debian:Security_Communication_EV_RootCA1.pem
Adding debian:Sonera_Class_2_Root_CA.pem
Adding debian:ComSign_CA.pem
Adding debian:D-TRUST_Root_Class_3_CA_2_EV_2009.pem
Adding debian:DigiCert_Global_Root_G3.pem
Adding debian:Certinomis_-_Root_CA.pem
Adding debian:SwissSign_Gold_CA_-_G2.pem
Adding debian:WoSign.pem
Adding debian:DST_Root_CA_X3.pem
Adding debian:Camerfirma_Chambers_of_Commerce_Root.pem
Adding debian:Comodo_Secure_Services_root.pem
Adding debian:WellsSecure_Public_Root_Certificate_Authority.pem
Adding debian:Visa_eCommerce_Root.pem
Adding debian:certSIGN_ROOT_CA.pem
Adding debian:spi-cacert-2008.pem
Adding debian:EC-ACC.pem
Adding debian:thawte_Primary_Root_CA.pem
Adding debian:Taiwan_GRCA.pem
Adding debian:CA_WoSign_ECC_Root.pem
Adding debian:Comodo_AAA_Services_root.pem
Adding debian:GeoTrust_Global_CA.pem
Adding debian:Izenpe.com.pem
Adding debian:UTN_USERFirst_Hardware_Root_CA.pem
Adding debian:DigiCert_Assured_ID_Root_G3.pem
Adding debian:GlobalSign_ECC_Root_CA_-_R5.pem
Adding debian:Root_CA_Generalitat_Valenciana.pem
Adding debian:Juur-SK.pem
Adding debian:Camerfirma_Global_Chambersign_Root.pem
Adding debian:Global_Chambersign_Root_-_2008.pem
Adding debian:GeoTrust_Primary_Certification_Authority_-_G2.pem
Adding debian:CNNIC_ROOT.pem
Adding debian:Security_Communication_RootCA2.pem
Adding debian:Verisign_Class_1_Public_Primary_Certification_Authority_-_G2.pem
Adding debian:Verisign_Class_1_Public_Primary_Certification_Authority_-_G3.pem
Adding debian:NetLock_Notary_=Class_A=_Root.pem
Adding debian:QuoVadis_Root_CA_2_G3.pem
Adding debian:T-TeleSec_GlobalRoot_Class_3.pem
Adding debian:AddTrust_Low-Value_Services_Root.pem
Adding debian:S-TRUST_Authentication_and_Encryption_Root_CA_2005_PN.pem
Adding debian:GeoTrust_Primary_Certification_Authority.pem
Adding debian:Swisscom_Root_EV_CA_2.pem
Adding debian:CA_Disig_Root_R1.pem
Adding debian:Entrust.net_Premium_2048_Secure_Server_CA.pem
Adding debian:Atos_TrustedRoot_2011.pem
Adding debian:Equifax_Secure_Global_eBusiness_CA.pem
Adding debian:Verisign_Class_2_Public_Primary_Certification_Authority_-_G2.pem
Adding debian:USERTrust_RSA_Certification_Authority.pem
Adding debian:Verisign_Class_1_Public_Primary_Certification_Authority.pem
Adding debian:ePKI_Root_Certification_Authority.pem
Adding debian:NetLock_Express_=Class_C=_Root.pem
Adding debian:OISTE_WISeKey_Global_Root_GA_CA.pem
Adding debian:QuoVadis_Root_CA_3_G3.pem
Adding debian:DST_ACES_CA_X6.pem
Adding debian:DigiCert_Assured_ID_Root_CA.pem
Adding debian:Secure_Global_CA.pem
Adding debian:StartCom_Certification_Authority_G2.pem
Adding debian:Certplus_Class_2_Primary_CA.pem
Adding debian:Entrust_Root_Certification_Authority_-_EC1.pem
Adding debian:GeoTrust_Primary_Certification_Authority_-_G3.pem
Adding debian:NetLock_Business_=Class_B=_Root.pem
Adding debian:E-Tugra_Certification_Authority.pem
Adding debian:EE_Certification_Centre_Root_CA.pem
Adding debian:SecureTrust_CA.pem
Adding debian:COMODO_ECC_Certification_Authority.pem
Adding debian:T-TeleSec_GlobalRoot_Class_2.pem
Adding debian:SwissSign_Silver_CA_-_G2.pem
Adding debian:DigiCert_Global_Root_G2.pem
Adding debian:Go_Daddy_Class_2_CA.pem
Adding debian:QuoVadis_Root_CA_1_G3.pem
Adding debian:CA_Disig_Root_R2.pem
Warning: there was a problem reading the certificate file /etc/ssl/certs/T?RKTRUST_Elektronik_Sertifika_Hizmet_Sa?lay?c?s?_H6.pem. Message:
 /etc/ssl/certs/T?RKTRUST_Elektronik_Sertifika_Hizmet_Sa?lay?c?s?_H6.pem (No such file or directory)
Adding debian:S-TRUST_Universal_Root_CA.pem
Adding debian:COMODO_RSA_Certification_Authority.pem
Adding debian:CA_Disig.pem
Adding debian:Certification_Authority_of_WoSign_G2.pem
Adding debian:QuoVadis_Root_CA.pem
Adding debian:Starfield_Root_Certificate_Authority_-_G2.pem
Adding debian:thawte_Primary_Root_CA_-_G3.pem
Adding debian:Buypass_Class_2_CA_1.pem
Adding debian:AffirmTrust_Premium.pem
Adding debian:Buypass_Class_2_Root_CA.pem
Adding debian:GlobalSign_ECC_Root_CA_-_R4.pem
Adding debian:Verisign_Class_3_Public_Primary_Certification_Authority_-_G2.pem
Adding debian:TC_TrustCenter_Class_3_CA_II.pem
Adding debian:D-TRUST_Root_Class_3_CA_2_2009.pem
Adding debian:COMODO_Certification_Authority.pem
Adding debian:AffirmTrust_Networking.pem
Warning: there was a problem reading the certificate file /etc/ssl/certs/NetLock_Arany_=Class_Gold=_F?tan?s?tv?ny.pem. Message:
 /etc/ssl/certs/NetLock_Arany_=Class_Gold=_F?tan?s?tv?ny.pem (No such file or directory)
Adding debian:GeoTrust_Universal_CA.pem
Adding debian:AffirmTrust_Commercial.pem
Adding debian:Entrust_Root_Certification_Authority.pem
Adding debian:thawte_Primary_Root_CA_-_G2.pem
Adding debian:AddTrust_Public_Services_Root.pem
Adding debian:IdenTrust_Commercial_Root_CA_1.pem
Adding debian:Network_Solutions_Certificate_Authority.pem
Adding debian:Starfield_Services_Root_Certificate_Authority_-_G2.pem
Adding debian:Staat_der_Nederlanden_EV_Root_CA.pem
Adding debian:TeliaSonera_Root_CA_v1.pem
Adding debian:GlobalSign_Root_CA_-_R3.pem
Adding debian:Sonera_Class_1_Root_CA.pem
Adding debian:ACEDICOM_Root.pem
Adding debian:TURKTRUST_Certificate_Services_Provider_Root_2007.pem
Adding debian:RSA_Security_2048_v3.pem
Adding debian:WoSign_China.pem
Adding debian:AffirmTrust_Premium_ECC.pem
Adding debian:Chambers_of_Commerce_Root_-_2008.pem
Adding debian:Security_Communication_Root_CA.pem
Adding debian:GlobalSign_Root_CA_-_R2.pem
Adding debian:Microsec_e-Szigno_Root_CA_2009.pem
Adding debian:QuoVadis_Root_CA_2.pem
Warning: there was a problem reading the certificate file /etc/ssl/certs/T?B?TAK_UEKAE_K?k_Sertifika_Hizmet_Sa?lay?c?s?_-_S?r?m_3.pem. Message:
 /etc/ssl/certs/T?B?TAK_UEKAE_K?k_Sertifika_Hizmet_Sa?lay?c?s?_-_S?r?m_3.pem (No such file or directory)
Adding debian:GeoTrust_Global_CA_2.pem
Adding debian:Equifax_Secure_eBusiness_CA_1.pem
Adding debian:Verisign_Class_2_Public_Primary_Certification_Authority_-_G3.pem
Adding debian:China_Internet_Network_Information_Center_EV_Certificates_Root.pem
Adding debian:Verisign_Class_3_Public_Primary_Certification_Authority_-_G3.pem
Adding debian:GeoTrust_Universal_CA_2.pem
Adding debian:Staat_der_Nederlanden_Root_CA_-_G3.pem
Adding debian:Entrust_Root_Certification_Authority_-_G2.pem
Adding debian:UTN_USERFirst_Email_Root_CA.pem
Adding debian:AddTrust_Qualified_Certificates_Root.pem
Adding debian:Swisscom_Root_CA_2.pem
Adding debian:Staat_der_Nederlanden_Root_CA_-_G2.pem
Adding debian:Baltimore_CyberTrust_Root.pem
Adding debian:QuoVadis_Root_CA_3.pem
Adding debian:Trustis_FPS_Root_CA.pem
Adding debian:OISTE_WISeKey_Global_Root_GB_CA.pem
Adding debian:Verisign_Class_3_Public_Primary_Certification_Authority.pem
Adding debian:AddTrust_External_Root.pem
Adding debian:DigiCert_Assured_ID_Root_G2.pem
Adding debian:Certum_Trusted_Network_CA.pem
done.
Setting up libglib2.0-bin (2.42.1-1+b1) ...
Setting up libgssapi-krb5-2:arm64 (1.12.1+dfsg-19+deb8u2) ...
Setting up libssl1.0.0:arm64 (1.0.1k-3+deb8u4) ...
Setting up libgssrpc4:arm64 (1.12.1+dfsg-19+deb8u2) ...
Setting up libkadm5clnt-mit9:arm64 (1.12.1+dfsg-19+deb8u2) ...
Setting up libkdb5-7:arm64 (1.12.1+dfsg-19+deb8u2) ...
Setting up libkadm5srv-mit9:arm64 (1.12.1+dfsg-19+deb8u2) ...
Setting up libassuan0:arm64 (2.1.2-2) ...
Setting up libevent-core-2.0-5:arm64 (2.0.21-stable-2) ...
Setting up libevent-extra-2.0-5:arm64 (2.0.21-stable-2) ...
Setting up libevent-openssl-2.0-5:arm64 (2.0.21-stable-2) ...
Setting up libevent-pthreads-2.0-5:arm64 (2.0.21-stable-2) ...
Setting up libexempi3:arm64 (2.2.1-2) ...
Setting up pinentry-gtk2 (0.8.3-2) ...
Setting up libpth20:arm64 (2.0.7-20) ...
Setting up gnupg-agent (2.0.26-6) ...
Setting up libksba8:arm64 (1.3.2-1) ...
Setting up gnupg2 (2.0.26-6) ...
Setting up libgpgme11:arm64 (1.5.1-6) ...
Setting up libgmime-2.6-0:arm64 (2.6.20-1+b1) ...
Setting up libmediaart-1.0-0:arm64 (0.7.0-2) ...
Setting up mysql-common (5.5.47-0+deb8u1) ...
Setting up libmysqlclient18:arm64 (5.5.47-0+deb8u1) ...
Setting up libpcrecpp0:arm64 (2:8.35-3.3+deb8u4) ...
Setting up libiptcdata0 (1.0.4-4) ...
Setting up libunistring0:arm64 (0.9.3-5.2+b2) ...
Setting up libtracker-sparql-1.0-0:arm64 (1.2.4-2) ...
Setting up libtracker-control-1.0-0:arm64 (1.2.4-2) ...
Setting up libtracker-miner-1.0-0:arm64 (1.2.4-2) ...
Setting up libupower-glib3:arm64 (0.99.1-3.2) ...
Setting up gir1.2-mediaart-1.0:arm64 (0.7.0-2) ...
Setting up gir1.2-tracker-1.0:arm64 (1.2.4-2) ...
Setting up comerr-dev (2.1-1.42.12-1.1) ...
Setting up krb5-multidev (1.12.1+dfsg-19+deb8u2) ...
Setting up libavahi-common-dev (0.6.31-5) ...
Setting up libdbus-1-dev:arm64 (1.8.20-0+deb8u1) ...
Setting up libavahi-client-dev (0.6.31-5) ...
Setting up libpcre3-dev:arm64 (2:8.35-3.3+deb8u4) ...
Setting up libglib2.0-dev (2.42.1-1+b1) ...
Setting up libdbus-glib-1-dev (0.102-1) ...
Setting up libevent-dev (2.0.21-stable-2) ...
Setting up libgpg-error-dev (1.17-3) ...
Setting up libgcrypt20-dev (1.6.3-2+deb8u1) ...
Setting up libgcrypt11-dev (1.5.4-3+really1.6.3-2+deb8u1) ...
Setting up libgdk-pixbuf2.0-dev (2.31.1-2+deb8u4) ...
Setting up libgsf-1-common (1.14.30-2) ...
Setting up libgsf-1-114 (1.14.30-2) ...
Setting up libmediaart-1.0-dev:arm64 (0.7.0-2) ...
Setting up libmysqlclient-dev (5.5.47-0+deb8u1) ...
Setting up libpam0g-dev:arm64 (1.1.8-3.1+deb8u1+b1) ...
Setting up libssl-dev:arm64 (1.0.1k-3+deb8u4) ...
Setting up libssl-doc (1.0.1k-3+deb8u4) ...
Setting up libtdb-dev (1.3.1-1) ...
Setting up libtotem-plparser18 (3.10.3-1) ...
Setting up libtracker-sparql-1.0-dev:arm64 (1.2.4-2) ...
Setting up libtracker-miner-1.0-dev:arm64 (1.2.4-2) ...
Setting up libwrap0-dev:arm64 (7.6.q-25) ...
Setting up systemtap-sdt-dev (2.6-0.2) ...
Setting up tracker (1.2.4-2) ...
Setting up tracker-extract (1.2.4-2) ...
Setting up tracker-gui (1.2.4-2) ...
Setting up tracker-miner-fs (1.2.4-2) ...
Setting up tracker-utils (1.2.4-2) ...
Setting up upower (0.99.1-3.2) ...
Setting up libattr1-dev:arm64 (1:2.4.47-2) ...
Setting up libacl1-dev (2.2.52-2) ...
Setting up libcrack2-dev (2.9.2-1) ...
Setting up libdb5.3-dev (5.3.28-9) ...
Setting up libdb-dev:arm64 (5.3.0+b2) ...
Setting up libkrb5-dev (1.12.1+dfsg-19+deb8u2) ...
Setting up libldap2-dev:arm64 (2.4.40+dfsg-1+deb8u2) ...
Processing triggers for ca-certificates (20141019+deb8u1) ...
Updating certificates in /etc/ssl/certs... 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....
done.
done.
Setting up openjdk-7-jre-headless:arm64 (7u91-2.6.3-1~deb8u1) ...
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/bin/rmid to provide /usr/bin/rmid (rmid) in auto mode
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/bin/java to provide /usr/bin/java (java) in auto mode
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/bin/keytool to provide /usr/bin/keytool (keytool) in auto mode
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/bin/pack200 to provide /usr/bin/pack200 (pack200) in auto mode
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/bin/rmiregistry to provide /usr/bin/rmiregistry (rmiregistry) in auto mode
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/bin/unpack200 to provide /usr/bin/unpack200 (unpack200) in auto mode
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/bin/orbd to provide /usr/bin/orbd (orbd) in auto mode
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/bin/servertool to provide /usr/bin/servertool (servertool) in auto mode
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/bin/tnameserv to provide /usr/bin/tnameserv (tnameserv) in auto mode
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/lib/jexec to provide /usr/bin/jexec (jexec) in auto mode
Setting up openjdk-7-jre:arm64 (7u91-2.6.3-1~deb8u1) ...
update-alternatives: using /usr/lib/jvm/java-7-openjdk-arm64/jre/bin/policytool to provide /usr/bin/policytool (policytool) in auto mode
Setting up default-jre (2:1.7-52) ...
Processing triggers for libc-bin (2.19-18+deb8u2) ...
Processing triggers for dbus (1.8.20-0+deb8u1) ...
there are some errors, for example: 

Code:
/var/lib/dpkg/info/ca-certificates-java.postinst: line 7: warning: setlocale: LC_CTYPE: cannot change locale (C.UTF-8): No such file or directory

and:
Code:
Warning: there was a problem reading the certificate file /etc/ssl/certs/Certinomis_-_Autorit?_Racine.pem. Message:
 /etc/ssl/certs/Certinomis_-_Autorit?_Racine.pem (No such file or directory)

These "reading the certificate..." Errors are alot, do i have to worry about it? How can i solve them?


-- restart: works --

Then downloading netatalk and extract it
Code:
# https://sourceforge.net/projects/netatalk/
tar xvf netatalk-3.1.8.tar.bz2
cd netatalk-3.1.8

configure it, with following options (A)
Code:
./configure --with-init-style=debian-sysv --with-tracker-pkgconfig-version=1.0


output A:
Code:
Compilation summary:
   CPPFLAGS       = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)
   CFLAGS         = -D_U_="__attribute__((unused))" -g -O2
   LIBS           =
   PTHREADS:
       LIBS   =
       CFLAGS = -pthread
   TRACKER:
       LIBS   = -ltracker-sparql-1.0 -lgio-2.0 -lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0
       CFLAGS = -pthread -I/usr/include/tracker-1.0 -I/usr/include/tracker-1.0/libtracker-sparql -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include
   SSL:
       LIBS   =  -lcrypto
       CFLAGS =  -I/usr/include/openssl
   LIBGCRYPT:
       LIBS   = -lgcrypt
       CFLAGS =
   PAM:
       LIBS   =  -lpam
       CFLAGS =
   WRAP:
       LIBS   = -lwrap
       CFLAGS =
   BDB:
       LIBS   =  -ldb-5.3
       CFLAGS =
   ZEROCONF:
       LIBS   =  -lavahi-common -lavahi-client
       CFLAGS =  -D_REENTRANT
   LDAP:
       LIBS   =  -lldap
       CFLAGS =
   LIBEVENT:
       bundled
   TDB:
       bundled
   MySQL:
       LIBS   = -L/usr/lib/aarch64-linux-gnu -lmysqlclient -lpthread -lz -lm -ldl
       CFLAGS = -I/usr/include/mysql -DBIG_JOINS=1  -fno-strict-aliasing    -g -DNDEBUG
Configure summary:
   INIT STYLE:
        debian-sysv
   AFP:
        Extended Attributes: ad | sys
        ACL support: yes
        Spotlight: yes
   CNID:
        backends:  dbd last tdb mysql
   UAMS:
        DHX     (PAM SHADOW)
        DHX2    (PAM SHADOW)
        RANDNUM (afppasswd)
        clrtxt  (PAM SHADOW)
        guest
   Options:
        Zeroconf support:        yes
        tcp wrapper support:     yes
        quota support:           yes
        admin group support:     yes
        valid shell check:       yes
        cracklib support:        no
        ACL support:             auto
        Kerberos support:        yes
        LDAP support:            yes
        AFP stats via dbus:      yes
        dtrace probes:           yes
   Paths:
        Netatalk lockfile:       /var/lock/netatalk
        init directory:          /etc/init.d
        dbus system directory:   ${sysconfdir}/dbus-1/system.d
        pam config directory:    ${sysconfdir}/pam.d
   Documentation:
        Docbook:                 no

also used these options (B)
Code:
./configure \
       --with-init-style=debian-systemd \
       --without-libevent \
       --without-tdb \
       --with-cracklib \
       --enable-krbV-uam \
       --with-pam-confdir=/etc/pam.d \
       --with-dbus-sysconf-dir=/etc/dbus-1/system.d \
       --with-tracker-pkgconfig-version=1.0

-- restart: screen stays black, red led is on, ssh not possible, no linux logo --

output B:
Code:
Compilation summary:
   CPPFLAGS       = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)
   CFLAGS         = -D_U_="__attribute__((unused))" -g -O2
   LIBS           =  -lcrack
   PTHREADS:
       LIBS   =
       CFLAGS = -pthread
   TRACKER:
       LIBS   = -ltracker-sparql-1.0 -lgio-2.0 -lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0
       CFLAGS = -pthread -I/usr/include/tracker-1.0 -I/usr/include/tracker-1.0/libtracker-sparql -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include
   SSL:
       LIBS   =  -lcrypto
       CFLAGS =  -I/usr/include/openssl
   LIBGCRYPT:
       LIBS   = -lgcrypt
       CFLAGS =
   PAM:
       LIBS   =  -lpam
       CFLAGS =
   WRAP:
       LIBS   = -lwrap
       CFLAGS =
   BDB:
       LIBS   =  -ldb-5.3
       CFLAGS =
   GSSAPI:
       LIBS   = -L/usr/lib/aarch64-linux-gnu/mit-krb5 -Wl,-z,relro -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err
       CFLAGS = -isystem /usr/include/mit-krb5
   ZEROCONF:
       LIBS   =  -lavahi-common -lavahi-client
       CFLAGS =  -D_REENTRANT
   LDAP:
       LIBS   =  -lldap
       CFLAGS =
   LIBEVENT:
       LIBS   =
       CFLAGS =
   TDB:
       LIBS   = -ltdb
       CFLAGS =
   MySQL:
       LIBS   = -L/usr/lib/aarch64-linux-gnu -lmysqlclient -lpthread -lz -lm -ldl
       CFLAGS = -I/usr/include/mysql -DBIG_JOINS=1  -fno-strict-aliasing    -g -DNDEBUG
Configure summary:
   INIT STYLE:
        debian-systemd
   AFP:
        Extended Attributes: ad | sys
        ACL support: yes
        Spotlight: yes
   CNID:
        backends:  dbd last tdb mysql
   UAMS:
        DHX     (PAM SHADOW)
        DHX2    (PAM SHADOW)
        RANDNUM (afppasswd)
        Kerberos V
        clrtxt  (PAM SHADOW)
        guest
   Options:
        Zeroconf support:        yes
        tcp wrapper support:     yes
        quota support:           yes
        admin group support:     yes
        valid shell check:       yes
        cracklib support:        yes
        ACL support:             auto
        Kerberos support:        yes
        LDAP support:            yes
        AFP stats via dbus:      yes
        dtrace probes:           yes
   Paths:
        Netatalk lockfile:       /var/lock/netatalk
        init directory:          /lib/systemd/system
        dbus system directory:   /etc/dbus-1/system.d
        pam config directory:    /etc/pam.d
   Documentation:
        Docbook:                 no

-- restart: works --

Code:
make && make install

i can run 
Code:
afpd -V

and get an result:
Code:
afpd 3.1.8 - Apple Filing Protocol (AFP) daemon of Netatalk

This program is free software; you can redistribute it and/or modify it under
the terms of the GNU General Public License as published by the Free Software
Foundation; either version 2 of the License, or (at your option) any later
version. Please see the file COPYING for further information and details.

afpd has been compiled with support for these features:

         AFP versions:    2.2 3.0 3.1 3.2 3.3 3.4
        CNID backends:    dbd last tdb mysql
     Zeroconf support:    Avahi
 TCP wrappers support:    Yes
        Quota support:    Yes
  Admin group support:    Yes
   Valid shell checks:    Yes
     cracklib support:    Yes
           EA support:    ad | sys
          ACL support:    Yes
         LDAP support:    Yes
        D-Bus support:    Yes
    Spotlight support:    Yes
        DTrace probes:    Yes

             afp.conf:    /usr/local/etc/afp.conf
          extmap.conf:    /usr/local/etc/extmap.conf
      state directory:    /usr/local/var/netatalk/
   afp_signature.conf:    /usr/local/var/netatalk/afp_signature.conf
     afp_voluuid.conf:    /usr/local/var/netatalk/afp_voluuid.conf
      UAM search path:    /usr/local/lib/netatalk//
 Server messages path:    /usr/local/var/netatalk/msg/

-- restart: black screen, no ssh, red led is on --
Can somebody please help me? Tried it so many times! The Screen gets an Signal the LCD Panel is black.
  Reply
#2
Are you sure your board is not overheating maybe? Are you using heatsink? What is the temperature?

Also I think Apoletalk might requires some kernel modules. I am pretty sure they are not included in the longsleep kernel.

There is an older version of netatalk in Debian, it is always good idea to start with apt-get build-dep netatalk, to install some dependencies for build first. But it looks you managed to compile it.
  Reply
#3
(04-25-2016, 06:40 PM)baryluk Wrote: Are you sure your board is not overheating maybe? Are you using heatsink? What is the temperature?

No heatsink, cant test the temperature. Pretty sure there is no temperature problem, i can touch the board and its cold. 

Quote:There is an older version of netatalk in Debian, it is always good idea to start with apt-get build-dep netatalk, to install some dependencies for build first. But it looks you managed to compile it.
yes it seems to work, but i cant turn of the board. because when i want to start it again, it freezes.
  Reply
#4
Probably worth reflashing the sd card from scratch. Maybe some module autoloads on startup and it freezes the os, or some data are corrupted. You can copy stuff from sd card somewhere else if you need a backup.

Maybe you have a buggy kernel, or something. Try again with newest images and neweset longsleep kernels.
  Reply
#5
I reflashed about 20 times. There is no other data on the card.

I use the latest image. Also the latest kernel.

Arch Linux has a package for netatalk 3.x this works great, so I think it's not a kernel Problem.
  Reply
#6
I am not sure I am following. So, the board works ok after reflashing, until you do make install and restart only?
  Reply
#7
Yes, 'make' and 'make install' let the board freeze after Reboot.
With Ubuntu, Arch, etc not.
  Reply
#8
Ok. I will try this on my board.
  Reply
#9
I compiled 3.1.8, with just apt-get build-dep netatalk.

used this flags:

Code:
./configure        --with-init-style=debian-systemd        --without-libevent  --with-cracklib        --enable-krbV-uam        --with-pam-confdir=/etc/pam.d        --with-dbus-sysconf-dir=/etc/dbus-1/system.d        --with-tracker-pkgconfig-version=1.0 --with-cracklib=/var/cache/cracklib/cracklib_dict --enable-debian

output from configure:

Code:
Compilation summary:
    CPPFLAGS       = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)
    CFLAGS         = -D_U_="__attribute__((unused))" -g -O2
    LIBS           =  -lcrack
    PTHREADS:
        LIBS   =
        CFLAGS = -pthread
    LIBGCRYPT:
        LIBS   = -lgcrypt
        CFLAGS =
    PAM:
        LIBS   =  -lpam
        CFLAGS =
    WRAP:
        LIBS   = -lwrap
        CFLAGS =
    BDB:
        LIBS   =  -ldb-5.3
        CFLAGS =
    GSSAPI:
        LIBS   = -L/usr/lib/aarch64-linux-gnu/mit-krb5 -Wl,-z,relro -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err
        CFLAGS = -isystem /usr/include/mit-krb5
    ZEROCONF:
        LIBS   =  -lavahi-common -lavahi-client
        CFLAGS =  -D_REENTRANT
    LDAP:
        LIBS   =  -lldap
        CFLAGS =
    LIBEVENT:
        LIBS   =
        CFLAGS =
    TDB:
        bundled
Configure summary:
    INIT STYLE:
         debian-systemd
    AFP:
         Extended Attributes: ad | sys
         ACL support: yes
         Spotlight: no
    CNID:
         backends:  dbd last tdb
    UAMS:
         DHX2    (PAM SHADOW)
         Kerberos V
         clrtxt  (PAM SHADOW)
         guest
    Options:
         Zeroconf support:        yes
         tcp wrapper support:     yes
         quota support:           yes
         admin group support:     yes
         valid shell check:       yes
         cracklib support:        yes
         ACL support:             auto
         Kerberos support:        yes
         LDAP support:            yes
         AFP stats via dbus:      no
         dtrace probes:           yes
    Paths:
         Netatalk lockfile:       /var/lock/netatalk
         init directory:          /lib/systemd/system
         pam config directory:    /etc/pam.d
    Documentation:
         Docbook:                 no

Code:
$ sudo afpd -V
afpd 3.1.8 - Apple Filing Protocol (AFP) daemon of Netatalk

This program is free software; you can redistribute it and/or modify it under
the terms of the GNU General Public License as published by the Free Software
Foundation; either version 2 of the License, or (at your option) any later
version. Please see the file COPYING for further information and details.

afpd has been compiled with support for these features:

          AFP versions:    2.2 3.0 3.1 3.2 3.3 3.4
         CNID backends:    dbd last tdb
      Zeroconf support:    Avahi
  TCP wrappers support:    Yes
         Quota support:    Yes
   Admin group support:    Yes
    Valid shell checks:    Yes
      cracklib support:    Yes
            EA support:    ad | sys
           ACL support:    Yes
          LDAP support:    Yes
         D-Bus support:    No
     Spotlight support:    No
         DTrace probes:    Yes

              afp.conf:    /usr/local/etc/afp.conf
           extmap.conf:    /usr/local/etc/extmap.conf
       state directory:    /usr/local/var/netatalk/
    afp_signature.conf:    /usr/local/var/netatalk/afp_signature.conf
      afp_voluuid.conf:    /usr/local/var/netatalk/afp_voluuid.conf
       UAM search path:    /usr/local/lib/netatalk//
  Server messages path:    /usr/local/var/netatalk/msg/

I started afpd manually and it works.

I do not see why it would freeze after restart, but I can do that tomorrow (i am doing some other stuff on the board).
  Reply
#10
I rebooted the pine and everything is still fine.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Arch, Debian or other for Pinebook? cootcraig 3 284 05-01-2019, 09:11 AM
Last Post: cootcraig
  Pine64 will be supported by HypriotOS (a Debian Jessie based OS for running Docker) Quintus23M 9 7,164 02-03-2017, 05:50 AM
Last Post: pfeerick
  How to make multicast working on ubuntu and debian brengthdom 3 2,102 09-18-2016, 02:05 PM
Last Post: brengthdom
  SSH for noobs on Debian robertnew 12 4,250 05-07-2016, 08:02 AM
Last Post: Leoncito81
Lightbulb Debian (Raspbian-like) Pander 15 5,439 04-09-2016, 08:40 PM
Last Post: lenny.raposo-pine64.pro
  Minimal 64bit ARM RootFS for Debian and Ubuntu umiddelb 46 14,689 03-06-2016, 10:28 AM
Last Post: umiddelb
  1st Debian image and further information umiddelb 13 4,945 03-04-2016, 02:08 AM
Last Post: umiddelb

Forum Jump:


Users browsing this thread: 1 Guest(s)