x does not start: armsoc_drv.so undefined symbol AddGeneralSocket
#1
i did install: http://wiki.pine64.org/index.php/ROCKPro...an_Stretch

when trying to run 'startx' i get the following message:

$ startx


X.Org X Server 1.19.2
Release Date: 2017-03-02
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-8-arm64 aarch64 Debian
Current Operating System: Linux rockpro64 4.4.132-1075-rockchip-ayufan-ga83beded8524 #1 SMP Thu Jul 26 08:22:22 UTC 2018 aarch64
Kernel command line: earlycon=uart8250,mmio32,0xff1a0000 swiotlb=1 rw panic=10 init=/sbin/init coherent_pool=1M ethaddr=b6:2f:3e:b8:61:d2 eth1addr= serial=99afcb5d19e3b02 cgroup_enable=cpuset cgroup_memory=1 cgroup_enable=memory swapaccount=1 root=LABEL=linux-root rootwait rootfstype=ext4
Build Date: 03 November 2018 03:03:37AM
xorg-server 2:1.19.2-1+deb9u5 (https://www.debian.org/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.5.log", Time: Tue Mar 5 12:40:21 2019
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(WW) armsoc: module ABI major version (20) doesn't match the server's version (23)
/usr/lib/xorg/Xorg: symbol lookup error: /usr/lib/xorg/modules/drivers/armsoc_drv.so: undefined symbol: AddGeneralSocket
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

what is wrong with the armsoc driver?
  Reply
#2
Posted in wrong subforum - moved.
You can find me on IRC, Discord and Twitter


  Reply
#3
It looks like your Xserver is running ABI 23 and your armsoc_drv with ABI 20. That means your armsoc_drv is older than the rest of your Xserver.
Did you apt-get upgrade the xorg-server pkg? Than you need to upgade
xf86-video-armsoc as well.
Maybe https://github.com/ayufan-rock64/xf86-video-armsoc helps.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  OpenVPN will not start Cannot open TUN/TAP dev /dev/net/tun: No such file or director frewind 0 120 04-28-2019, 01:31 PM
Last Post: frewind

Forum Jump:


Users browsing this thread: 1 Guest(s)