Disappearing Ethernet port
#1
I was stoked to see the release of Armbian-Bionic for Pine A64+ and installed it on a card a couple of days ago. It all runs well except for one problem: when the system boots, the hard-wired Ethernet port doesn't work.

The system sees it as eth0. ethtool even reports "Link detected: yes". But there are no flashing LEDs, and no data actually gets transmitted.

Sometimes when I boot it up, neither of the Ethernet LEDs will light up at all. Sometimes when I boot it up, the left LED will flash once, then nothing. And very rarely, through no pattern I've been able to discern, the system will boot, both lights will flash, and all works beautifully.

I didn't keep an accurate count, but I'd say out of 30 boots yesterday (and by that, I mean I powered it off, then back on again), the Ethernet port only worked about 5 of those times. The rest, it was dead---no lights, but, as I said, the system claimed everything was OK.

I've been running this same Pine with longsleep 3.10.105 without these problems. I've rebooted it three times this morning just to test, and all three times, the Ethernet port was live and worked fine.

Any ideas? Has anyone else seen this issue? I've love to upgrade the kernel I'm running on the Pine, but not if I can't reliably count on the networking.

I have not yet tried Armbian-Stretch.

Thanks!
  Reply
#2
I just installed Armbian Stretch, and the results were even worse. The left LED on the Ethernet port would flash about once a second, but that was it. eth0 was created, ethtool reported link detected, but nothing was received or transmitted. Trying a ping showed nothing via the lights, just the steady flashing of the left LED, which did not correspond with the ping attempts.

It looks like there's something wrong with the Armbian images and the Ethernet port on the Pine A64+.
  Reply
#3
Just FYI, I checked a few days ago and found that Armbian has released an update (build 5.46, if memory serves). I installed it, and found that my problem has been fixed! I'm now running the 4.19 Linux kernel on my Pine A64+ machines.

Thanks, Armbian!
  Reply
#4
As a followup, the current Armbian releases work on two of my Pines, but not my third. The symptom is the same on the third. Examination shows that my third Pine was actually manufactured a little earlier than the other two, and the chip numbers are different. Apparently, the Armbian kernel doesn't (properly?) support the older Ethernet chip. So my third Pine is still running the longsleep kernel, and the Ethernet port works fine under that.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)