How to deactivate kernel output on ttyS2?
#1
Hi,
I'd like to fully deactivate the console output on ttyS2 as I'd like to use it. How is it possible to do it?
I'm quite new on Linux boards, I4ve try to search for that, understand that there are things to do with the u-boot or equivalent but really didn't find a simple how to to make it possible.
I'm using a Debian version on the RockPro64. The one recommended.
Thanks a lot
  Reply
#2
Use systemctl [stop|start|enable|disable]

1. Check for getty
$ ps aux | grep getty
root       829  0.0  0.0   3980  1992 ttyS2    Ss+  02:21   0:00 /sbin/agetty -o -p -- \u --keep-baud 115200,38400,9600 ttyS2 vt220

2. Stop getty on ttyS2.
$ sudo systemctl stop [email protected]

Repeating the ps command will show that getty is gone, but it will return after reboot.  To persist you can:

3. Disable getty on ttyS2:
$ sudo systemctl disable [email protected]
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  RockPro64 Official Kernel Support ASIC 10 2,315 07-22-2019, 02:43 AM
Last Post: stuartiannaylor
  kernel comparison Mentaluproar 2 127 07-10-2019, 05:49 AM
Last Post: beard5849
  Building a custom kernel on @mrfixit's Debian distro? Tim Jones 1 129 06-14-2019, 11:21 PM
Last Post: tllim
Question Libre kernel/distro on Pbook Pro? aleksei 0 110 06-06-2019, 11:20 PM
Last Post: aleksei
  Trying to update kernel rlevensa 1 256 03-22-2019, 09:36 AM
Last Post: Bullet64
  Update Kernel y0sh 1 372 10-20-2018, 01:33 PM
Last Post: tuxd3v
  strange behaviour on newer kernel tuxd3v 3 392 10-11-2018, 06:37 PM
Last Post: tuxd3v
  Linux Kernel 4.18.8 Bullet64 17 2,510 10-01-2018, 03:42 PM
Last Post: battlenut
  Help needed so a complete NOOB can compile a kernel, please dukla2000 5 598 09-24-2018, 05:51 PM
Last Post: dukla2000

Forum Jump:


Users browsing this thread: 1 Guest(s)