Google apps

First of all, i'm new to... well the SBCs, the RockPro64 and these forums. I'll try not to be too much of a pain Wink
Not a pro so keeping things simple, I've decided to run android (the 7.1.2 which can be found on the Rockpro64 help page). Yet, it does not include the google apps which is sad because they appear to be crucial to me since my board will be working along others devices via apps that require google apps. 
I've been tinkering for a while now, trying to install the google play store, but it's past time I give up so here I am. I'm guessing trying to install that from an apk may be quite optimistic.
The situation :
A Rockpro64 that boots just fine from a SD containing the Pine64 recommended android 7.1.2.
Network ok, dispaly ok, sound ok, keyboard/pointing ok. Seems to run fast and smooth. (Except from the parameter's app which crashes from time too time when I switch for too long between apps. But it's rare and not a part of normal use so no big deal.)
I have tried to install the google play store from apk (several ones from APK Mirror). Of course none could open. To be honest, i don't even really know for sure which version to get so I've had to try several. (Might be useful to indicate somewhere the architecture of the device under the form of this kind : armeabi, armeabi-v7a, [font=roboto, sans-serif]arm64-v8a, ect... Also would be useful to know if all DPI apps can run on the device.)[/font]
The Pushbullet app states on launch that it will not work without google apps, specifying that they're not compatible with my device.
Nothing I've tried worked so after a while I've come to the conclusion it would probably be way easier to just install Pushbullet on a Linux so I've installed the Pine64 recommended Ubuntu (the big one), but it never booted. Or if it did (because the white LED was lit) then the screen (HDMI) was just black. No idea why.

So, basically, I'd like some help to either install google apps on the 7.1.2 or get Ubuntu to boot from my SD.
I understand all this must probably sound very noobish, I apologize for that and thanks in advance for any help Smile
Please disregard my previous post since I found out G apps will only be available in a upcoming android version.
I switched to Ubuntu again and something must have gotten wrong during the firsy flash since it's running nicely this time.

Anyway : all is fine and running fast. All I have to do is install the apps I want (and there's a linux Pushbullet version Smile )
I'm also interested in seeing an android build with more in it. I think it will take rebuilding the stock image to include more apps by default. there are parts for this that only work on android and I have other reasons for wanting an android build as well. I have a second device now myself but I am waiting for the other parts I ordered to come in this week to set this one up.
Anyone have any success with Google Play Store or gpu use in Linux?
This is a letdown. I cant sideload anything useful on my Pine RockPro64 there are no apps in the stock build. So it's a $80 internet board.
A software power switch and performance monitor would also be nice.
All it has is a media player and web browser.
I know it's a developer board but that usually means hardware, not be a beta tester of the minimal OS available. Also I didn't plan on doing all the coding.
I have Rpi 3b, Tinkerboards, and now this, and this Pine RockPro64 is gathering dust.
The other boards are ready to make things. This one, not so much.

Forum Jump:

Users browsing this thread: 2 Guest(s)