Problem setting Pine64 LTS as a USB device
I am looking for help with setting the Pine64 LTS upper USB port as a USB Device(serial port)

My setup:
Pine64 LTS
Armbian_5.38_Pine64so_Ubuntu_xenial_default_3.10.107( I have also tried Armbian_5.35_Pine64so_Ubuntu_xenial_default_3.10.105 with the same results)
Original kernel configuration: Original kernel configuration
My current configuration: My current configuration
Kernel sources I use are form armbian package linux-source-default-pine64_5.38_all.deb and contain git versioning information with remote repository at

What I tried:
Rebooting without SD card into FEL mode to see if Pine will be enumerated on my PC, this works ok, so the actual connection works and the USB port on the Pine I picked is the correct one.

Armbian seem to be lacking the g_serial driver, so I recompiled the kernel with gadget support + g_serial module.
From what I understand, doing :
echo 0 > /sys/bus/platform/devices/usbc0.6/otg_role # Cannot find where I got this
modprobe g_serial use_acm=0
echo usb_device > /sys/bus/platform/devices/usbc0.6/otg_role # Cannot find where I got this from, but it makes sense
should be all that is required to make it work.
Here is the dmesg output taken after running these commands:

I tried this with and without Device Drivers -> USB support -> OTG support support in the kernel, does not seem to make a difference.

What happens:
/dev/ttyGS0 is created as expected

What does not happen:
I when I connect the Pine to my PC, it does not enumerate(it's missing from lsusb ) Sad

Can anyone tell me what I am doing wrong? Do I need some different version of the kernel?

Possibly Related Threads…
Thread Author Replies Views Last Post
  3G hat on Pine64 with Linux chema 0 1,365 07-11-2018, 05:25 AM
Last Post: chema
  About PINE64-LTS Operating Temperature spbrain 2 2,176 12-28-2017, 12:51 AM
Last Post: spbrain

Forum Jump:

Users browsing this thread: 1 Guest(s)