snapd
#1
I am trying to install NextCloud on my rock64 but i'm running into a problem.  NextCloud uses snapd to install its packages which is supposed to come with ubuntu 16.04 by default.  It does not appear to be installed on the rock64 xenial image version 0.5.15-136.  I tried installing it manually but it failed because it failed to mount the core.  The error was: "mount[31508]: mount: unknown filesystem type 'squashfs'".  I tried to do an internet search and it mentioned this can be an issue with custom linux kernals.  I wasn't able to find anything more helpful then that though in how to fix the issue.  Does anyone have any suggestions on how to fix this issue?  Also in case the forum manager sees this i might have made this thread on the wrong board earlier for the pine64.  If it did go through please remove it.

  Reply
#2
snaps come packaged as a squashfs filesystem. it seems that the o/s you are using can not identify squashfs. you probably need to contact ayufan on chat.
  Reply
#3
You have snaps for arm64? Other than that, maybe squashfs support is not enabled in the kernel, would have to check...
Come have a chat in the Pine A64 IRC channel >>
  Reply
#4
Try NextcloudPi. Nacho Parker built an instance of Nextcloud that is configured for SBC's like the Rock64. I am working on installing NCP on myRock64 now. Trying to work out some of the issues with either Armbian or Ayufan's Debian images.


Sent from my iPad using Tapatalk
  Reply
#5
Thanks for the information.  I will try to contact ayufan and also see if I can get the next cloud pi to work.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)