Prb booting emmc
It looks like there are a whole load of mccblk0 errors... maybe the image didn't write properly to the eMMC?

[    8.425110] mmcblk0: error -110 sending stop command, original cmd response 0x900, card status 0x400900
[    8.443631] mmcblk0: error -110 transferring data, sector 723888, nr 8, cmd response 0x900, card status 0x0
[    8.462326] mmcblk0: retrying using single block read
[    8.483187] mmcblk0: error -84 transferring data, sector 723893, nr 3, cmd response 0x900, card status 0x0
[    8.491267] blk_update_request: 1 callbacks suppressed
[    8.498841] blk_update_request: I/O error, dev mmcblk0, sector 723893
[    8.521195] dwmmc_rockchip ff520000.rksdmmc: All phases work, using default phase 0.
Thanks for your answer

In fact, I tried many methods to flash the os onto the emmc module :

- first, I used the emmc2usb adapter to simply flash it : fails
- second, I followed the "emmc jumper" method booting with a sd card : I saw the mmcb device, used the curl command to flash the os thru the network directly on it, but on reboot : fails again
- then, trying to do the same things wih the uboot falshed onto the SPI (just to try) : fails again

So, I think the issue doesn't come from the emmc module (because I test with 2 different). The emmc bus seems to work correctly because I can see my module booting from sd card with the emmc jumper... I tried with different os (strech minimal stable, strech minimal 0.6.X different versions, dietpi) and I can boot from sd card but never with the emmc module...

I really don't know how to solve that !

Just a question (for testing flashing again an os thru the network with the jumper method) : I flashed the uboot onto the spi. Can I use the method of the jumper with the uboot on spi ? 

Any idea is welcome ! Wink
(03-22-2018, 02:29 AM)darthyoh Wrote: Just a question (for testing flashing again an os thru the network with the jumper method) : I flashed the uboot onto the spi. Can I use the method of the jumper with the uboot on spi ?

AFAIK that should work fine... boot order is eMMC -> SPI -> SD, so by putting the jumper on you are making it skip straight from eMMC to SPI. And uboot should be looking to boot from the SD card, USB and the network.

I'm not convinced the eMMC isn't still the culprit. Try downloading and running this work-in-progress script to install a clean image to eMMC after you've booted from the SD card (if your rock64 has network access, that is)... curl -LO and then make it executable and run it with sudo. Probably use the xenial-minimal variant for now, so sudo ./ xenial-minimal  It will download the latest 'stable' version, and write to the eMMC. Power down the rock64, remove the SD card, power it up, and see what happens.

Possibly Related Threads…
Thread Author Replies Views Last Post
Question Compatible eMMC modules and benchmarks danboid 6 9,942 06-26-2019, 01:59 PM
Last Post: fallc0nn
Question Have eMMC adapter - but can't seem to fix eMMC card SirRyanTheGeek 3 3,446 05-04-2019, 04:19 AM
Last Post: burito111
  emmc module help default_user8 1 1,800 04-05-2019, 07:19 PM
Last Post: SirRyanTheGeek
  Dead eMMC? machina 8 5,507 11-21-2018, 05:05 AM
Last Post: machina
  FORSEE eMMC is reliable? ramprasad 3 3,286 11-12-2018, 03:34 PM
Last Post: Tortax
  can a SD card be used as storage with emmc boot Enzo 9 7,922 05-10-2018, 08:53 PM
Last Post: pfeerick
  Flashing full image to eMMc with a mSD card to eCMM adapter pytheas 2 2,510 04-09-2018, 03:56 AM
Last Post: Luke
  eMMC angelscream09 2 2,598 02-05-2018, 08:36 AM
Last Post: Luke
  Were do you get compatible emmc modules? Rar9 1 2,198 12-09-2017, 03:16 AM
Last Post: gkkpch
  eMMC problem tanisou 4 3,618 10-02-2017, 10:51 AM
Last Post: stuartiannaylor

Forum Jump:

Users browsing this thread: 1 Guest(s)