How to get syncthing to actually start syncing
#1
Bug 
I am using syncthing on many different devices without any problems. On PINE64 with Ubuntu Xenial and longsleep's kernel I installed syncthing from https://github.com/syncthing/syncthing/r....21.tar.gz It start and I can connect to other devices but the actual syncing is not starting. Is this an ethernet problem or could it be something else? How do I go about finding the cause and fixing it? Are there people here that got it working and if so, how? Thanks
  Reply
#2
Well, its a bit hard to tell without a log. Regarding your ethernet question; have you updated the kernel ? 

Pipe to logger and come back with what you have - create this script (suggest you set it to start at boot): 


Code:
#!/bin/sh

export HOME=/home/ubuntu
export STNORESTART=1
setuidgid jb /home/jb/bin/syncthing 2>&1 | logger -t syncthing
You can find me on IRC, Discord and Twitter


  Reply
#3
Ah, found the error. The web GUI was available to all on the network and that disabled syncing. I will discuss this in syncthing to get a more specific warning about this. Thanks nevertheless for trying to help me.

(01-26-2017, 06:53 AM)Pander Wrote: Ah, found the error. The web GUI was available to all on the network and that disabled syncing. I will discuss this in syncthing to get a more specific warning about this. Thanks nevertheless for trying to help me.

Nope, wasn't the error, but at least it works now. Perhaps that it upgraded itself fixed it.
  Reply
#4
Ah, it was the upgrade, see https://forum.syncthing.net/t/syncing-di...all/9101/4 so I encourage all that would like to use syncthing and had troubles before, now all should be fine.
  Reply
#5
glad to hear you worked it out Smile
You can find me on IRC, Discord and Twitter


  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Unable to start Pine Topgun505 16 2,222 11-13-2016, 12:01 AM
Last Post: Gnx

Forum Jump:


Users browsing this thread: 1 Guest(s)