Connect external devices via USB
Hello everybody,
I’m dealing with my new amazing PinePhone Pro just arrived.
I’m not new to linux but I’m facing a problem with external USB connections.

Currently, I’m running Kali Linux booting from Micro SSD.
No matter what I connect via USB, nothing is detected by my PinePhone Pro.
“Lsusb” command does not list any external device.

Is there something I’m missing?
Do the USB port have to be “activated”?

Thank you for your help!
Sounds like a faulty USB port. Or even the whole USB subsystem – does the modem (an internal USB device) work? It should also show up in lsusb (it is a Quectel device). And anything you plug into the USB-C port, either directly or through an adapter, hub, or dock with USB-A ports that plugs into the USB-C port, should definitely show up in lsusb at the very least. Unless said USB device is defective, turned off, or insufficiently powered (some devices require an external power supply and/or a USB port delivering more power than required by the spec), of course.

I have an original PinePhone (my old one, I had to get a new one to replace it) where the USB subsystem failed (the modem vanished from USB despite being soldered on, and the USB port for external devices stopped working for anything other than charging / power supply), but that was after a year and a half, not right when the device was shipped.

I would suggest that you contact the support of the store from which you bought the device (the Pine64 support if you bought the device directly from the Pine64 Store, the reseller's support if you went through a reseller, and note that the Pine64 EU Store is also a reseller). And do it quickly because the Pine64 Store only offers 30 days of warranty. (Resellers can set their own warranty periods, but they are likely to not offer anything longer than required by law.)
Hello, sorry for my late reply.
Lsusb shows the quectel internal modem and the root hubs but nothing more than this when any other (external) devices is connected to the usb port.
I’ve tried with several wireless adapters (I have 4) and usb cables.
The lsusb output is always the same.

All i do is under nethubter pro/kali running on a ssd card.
Quick update

I was able to let my alfa network adapter on the PinePhone Pro but not on Kali Linux/Nethubter Pro but on Mobian.
Definitely not an hardware problem of the usb port.
It looks like Nethunter does not recognize external usb devices when connected to the usb-c port.
I would love that someone of you could investigate on it e find out the problem.

With kali/nethunter, lsusb do not list any external devices.
Mobian does it perfectly.

So indeed, the hardware is perfectly fine then. Kali must be shipping a broken, outdated, or incorrectly configured kernel. Maybe you can somehow copy the kernel and initrd from Mobian to Kali and try booting it with that? (Given that the distributions are both Debian-based, the easiest is probably to just download the kernel debs from Mobian: and if you need it and install them on Kali.) That is not something the distributions will support in any way, but it might work around the issue.
Recently Megi reports that some small patch (only two lines) on the upstream for USB Type-C driver breaks the USB-C power source mode on PinephonePro in his blog. (

I have made a test kernel (6.6.16) excluded this patch on Mobian/Trixie and find that the phone retrieves the power source mode. (I confirmed with EPSON's AR glass, BT-30).
Mobian/Bookworm with 6.1 kernel dose not have this issue.

Megi has posted a comment to the upstream about the issue, eventually this issue will be solved.

Note: Removing the patch may cause another problem.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Tow-Boot, a new U-Boot option for Pinephone Pro and other devices Ulfnic 60 44,510 02-13-2024, 02:54 PM
Last Post: fxc
Wink Monitor mode packet injection and external wireless adapter chedder_bob 2 2,131 01-05-2023, 01:38 AM
Last Post: RTP

Forum Jump:

Users browsing this thread: 2 Guest(s)