Problems setting up webserver
#1
Hi guys,

i'm trying to get a web server for my wordpress site on my pine. i followed this site: http://www.wikihow.com/Make-a-Raspberry-Pi-Web-Server
When i try to install mysql with this code: sudo apt-get install mysql-server mysql-client php5-mysql

It says: The following packages have unmet dependencies:

 mysql-server : Depends: mysql-server-5.5 but it is not going to be installed

E: Unable to correct problems, you have held broken packages.



How can i fix this? does anybody has a good handheld for setting up my own server?



I'm using the following image: Debian Mate (3.10.102 BSP 2)

Pleas help me Smile
  Reply
#2
That message usually means that the package you need is not yet available on the arm64 architecture. You can check that usually at the package databases for Debian/Ubuntu:

https://packages.debian.org/search?lang=...sql-server

In this case, architecture seems not to be an issue since:

jessie (stable) (database): MySQL database server binaries and system database setup
5.5.50-0+deb8u1 [security]: amd64 arm64 armel armhf i386 mips mipsel powerpc ppc64el s390x

is available. Maybe some other dependency is broken...
Come have a chat in the Pine A64 IRC channel >>
  Reply
#3
On my Ubuntu Pine, all php5 stuffs don't exist, it is php7 that needs to be installed.
  Reply
#4
I know, that Luke has set up a Wordpress server on the Pine. I'll tell him to look at this thread :-)
  Reply
#5
If you use the debian image then the RPI instructions work perfectly. If you use ubuntu, then as martinayotte pointed out you need to use php7. So, unless you are super set on using ubuntu, I suggest just going with debian. BTW, the pine works really well as a lighweight (low traffic) webserver
You can find me on IRC, Discord and Twitter


  Reply
#6
(07-28-2016, 08:44 AM)Ernst Wrote: Hi guys,

i'm trying to get a web server for my wordpress site on my pine. i followed this site: http://www.wikihow.com/Make-a-Raspberry-Pi-Web-Server
When i try to install mysql with this code: sudo apt-get install mysql-server mysql-client php5-mysql

It says: The following packages have unmet dependencies:

 mysql-server : Depends: mysql-server-5.5 but it is not going to be installed

E: Unable to correct problems, you have held broken packages.



How can i fix this? does anybody has a good handheld for setting up my own server?



I'm using the following image: Debian Mate (3.10.102 BSP 2)

Pleas help me Smile
Debian packagers have a long history of being very strict about FOSS policies. Try apt-cache search MariaDB. It is a fork of MySQL and is effectively equivalent in every way, except that it isn't controlled by Oracle. 

I'm on Ubuntu, so I can only guess that this could be the source of the problem.
  Reply
#7
Hi,

My $.02 is that Debian uses older packages that more closely online with online tutorials. Ubuntu works great too, but I had more difficulties configuring it due to newer packages. Naturally the choice is yours and there is no right answer. However, for me, Debian was better from a simplicity standpoint.

This post provides a great point. You need to install PHP7. Now I am not sure how the inclusion of PHP7 changes the configuration requirements for Wordpress. There may be none or there could be quite a few. You need to sort that out. If you used Debian, you could follow the tutorial pretty much as written. I get fed up with stuff like this and just went with Debian and could not be happier.

I would add that I use MariaDB and it is pretty much a plug and play MySQL replacement.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  MIPI 10.1 inch lcd setting up vicb 3 1,064 03-17-2020, 02:01 PM
Last Post: chilicon
  Problems with Kickstarter Pledge danphuong34k 1 552 12-27-2017, 04:05 PM
Last Post: Wizardknight
Question +PINEBOOK How to go about setting up your own Jenkins build system for pine64 / pinebook images pfeerick 2 5,641 05-31-2017, 02:42 AM
Last Post: pfeerick

Forum Jump:


Users browsing this thread: 1 Guest(s)