Windows not recognizing Pinecil v2 for flashing
Hi guys, I got my Pinecil v2 a few days ago; just transplanted the guts into the clear case and thought I'd try updating to the latest firmware. Running into a problem.

I'm running Windows 7 x64 - it won't recognize the Pinecil in flashing mode/won't install a driver. In Device Manager it shows up as "CDC Virtual ComPort" and says device drivers are not installed.

I followed the instructions to the letter: held down the "-" button when connecting and held it for 15s after, along with all the PowerShell and blisp instructions. Executing blisp results in "Device not found". I tried three different cables (one generic, and two Anker USB-A to USB-C. All three work fine flashing my backup TS101) and every USB port on the laptop.

Guidance would be appreciated. Thanks in advance!

P.S. When I hook it up without holding "-", it does boot up with the screen active as expected, and Device Manager shows it under USB Controllers as "Unknown Device", but also says "No drivers are installed for this device."
(04-14-2023, 03:02 PM)insightbrewery Wrote: Hi guys, I got my Pinecil v2 a few days ago ... 
I do have exactly the same problem. Tried to search for Win 7x64 USB driver, nothing Sad  Blisp (running as admin) just keeps reporting "Device not found" Sad Any help would be highly appreciated. Thank you !
Well, it's not the cable or the Pinecil - it was recognized by my other Windows 11 laptop immediately. So must be a Win7 issue. I won't mark this as solved just yet - maybe we can figure out how to get it to work right on Win7 or what's different about our particular Win7 installations.

Device Manager on the Win11 laptop shows it's using usbser.sys as the driver. I tried have-disking that on the Win7 laptop, but it threw a Code 10 "failed to start". The Win7 laptop is a 2014 Dell Latitude E7470, to provide some more info.

Forum Jump:

Users browsing this thread: 1 Guest(s)