Struggling to get Android running
My recently-purchased Pine A64-LTS runs Armbian swimmingly. I also need to run Android on it— a seemingly trivial task, but one that has brought me to my wits end.

Here's what I've tried:
  • The official Android 6.0 image (in its 32GB variant). The first time I extracted and burned this image, I saw a blue light appear on the board, noticed that the CPU was running hot to the touch, and nothing else. I extracted and burned the image two more times and saw nothing at all happen.
  • The Android 7.1 community image. This image allows the board to turn on— however, it loops forever at the Android splash screen (in which it plays a fun animation before, in a normal scenario, shifting to the word "Android".) I attempted to burn it a second time with the same result.
  • The Android 6.0 community image. This image successfully boots, but something is clearly horribly wrong. It runs at ~10FPS with significant lag in all menus, and I can't get any sort of internet connection— neither Ethernet nor a USB Ethernet adapter yield a link, and wifi and Bluetooth refuse to turn on. The Ethernet jack on the board blinks an orange light rapidly forever. Thus, this image is unusable. I attempted to burn it a second time with the same result.

All images were burned the same Samsung 32GB microSD card using a ThinkPad built-in microSD slot, running Arch Linux with the following command:
sudo dd if=./IMAGE of=/dev/mmcblk0 bs=1MiB status=progress conv=fsync

Note that this exact combination was able to successfully boot Armbian prior.

Clearly, something is going horribly wrong with my board, being unable to boot Android despite so many failed attempts to make it so. My next attempts will be to boot the 8GB variant of the official Android 6 image, as well as the official Android 5 image, but I don't expect them to yield fruit. Though this is clearly a dated board with little support at this point, I'm posting here in the unlikely event that someone here will have some ideas.
i have been having the similar issues, with my Pine A64-LTS, im using windows 10 on my laptop to flash the images,
its a new pine board, new lcd screen,
i have tried Android 7 and 6, using 2 different 64gb and 2 different 32gb micro sd cards, and a 64gb emmc, i get a blank screen or the pine splash screen, but none load the os, i have tried both ayufan images and the official images, i have tried using the newer version and an older version of etcher and win32 disk imager, i have also tried the pine installer but it errors out when i go to flash the image, all my cards get corrupted too, i have tried about 30 times with different cards and readers, im not sure what the problem is,

is there a new version of pine installer for windows 10, can someone please share a working link please or links to working android images

Possibly Related Threads…
Thread Author Replies Views Last Post
  EMMC with Android on Sopine koekoeboy 1 5,035 05-29-2020, 11:42 PM
Last Post: tllim
  Android 7.1 (SOPINE) pineadmin 5 11,643 12-01-2019, 01:53 PM
Last Post: tllim
  Android 6.0.1 (PINE A64-LTS / SOPINE) pineadmin 4 7,873 12-30-2018, 08:36 PM
Last Post: wombat
  How to get & compile Android 5.1 for Pine A64-LTS spbrain 2 5,887 09-17-2018, 02:55 AM
Last Post: slapin
  Compile kernel /Android and can't detect SDHC from Kernel spbrain 6 11,746 01-25-2018, 05:34 AM
Last Post: Luke

Forum Jump:

Users browsing this thread: 1 Guest(s)