Can't get to usable. Hardware issue?
#1
Hello, 

I've done all the googling, I've tried all the things, but there are really very few options I can find, and some big walls in my flow. I've really managed no progress since receiving the device. 

On the factory OS, I inevitably encounter a system freeze. Timing wise, most notably, always before a complete download of updates can be completed. 

In attempting to simply use a different OS, I'm fairly confident I've created a bootable microSD, but have no alternative way to verify this. I've run into other threads suggesting that the device may continue to boot from factory install on eMMC until updates are completed, but to ...loop back... to earlier, I can't download all updates, much less install them. I did manage to complete installation from shipping state to install on eMMC, perhaps I'd be in better shape had I not. 

One theory I have is that my CPU is overheating, and I have a hardware issue, but I want to make a forum post before I go bugging pine for replacement hardware... shipping time... And I'm probably wrong anyway, but I have no idea what to do. 

Thanks in advance
  Reply
#2
UPDATE: I entered multi-user mode (no GUI) and I do not freeze. After some time, I am able to access an interestingly incomplete array of features that suggests to me that the eMMC is being *very* uncooperative... I can `lsblk` which produces a reasonably expectable output, but I cannot simply `ls` from the home directory. That command, and many others, produces the output: `-bash: /path/to/w/e: Input/output error`

`cd /`, `cd`, `cd bin` (working in `/`) all appear to work, but again, `ls` fails everywhere. 

`sudo -i` also fails, returning `-bash: /usr/bin/sudo: Input/output error`
  Reply
#3
SOLUTION: 

It was a hardware issue. The eMMC was loosely attached, hung on a switch that doesn't *quite* match the technical diagram found in the wiki under Internal Layout, 5.2. , but I believe to be that, not seated fully down. 

All appears good Smile
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Guide: Setup Latest Waydroid for Hardware Acceleration and/or Development nroth 2 679 11-11-2022, 04:47 PM
Last Post: nroth
Question Issue installing New OS Using SD Rudy558 2 2,614 06-29-2021, 03:37 AM
Last Post: TfromTexas
  Password Issue Doodenheimer 0 1,614 09-27-2020, 04:36 AM
Last Post: Doodenheimer
  7" LCD Issue mtcomp 4 5,854 08-14-2016, 05:23 PM
Last Post: h9k

Forum Jump:


Users browsing this thread: 1 Guest(s)