PPP caller hears themselves
Hi forum,

I have been trying to use my PPP explorer edition with latest beta Manjaro Phosh. I am finding that whoever calls me just gets bombed with the sound of their own voice.

I have tried playing with the volume levels of mic and speaker, both with gnome settings, and pulse control. I even tried setting the volume all the way down for everything and it still happens.

Is this maybe a hardware thing?
I can't think how it would be a hardware thing. An audio routing problem in software seems much more likely as in the best tradition of linux it offers you a variety of ways to shoot yourself in the foot. I'd suggest returning to defaults, but I don't know where the changes are stored.
Whether PPP or PP I have found using a good headset works best at all times. I use a Blackberry ear bud set and the voice quality is excellent.
I recently switched from Arch-Phosh to Mobian-Phosh, and setting the input volume to almost nothing solves this problem, which has existed since the beginning, for me. Also, I set Input/Output Configuration to Phone Call. Also, I turn the Output volume down as low as I can stand during a call and am learning to put my ear directly on the speaker.

I'm not sure if I ever thought to lower the input volume previously, but I am pretty sure that Mobian does a better job of saving Sound Settings across reboots.

At any rate, I had my first clean phone call in three months with one individual yesterday.
You could try investigating the modem's echo cancellation settings. The AT command manual includes AT+QEEC
Set Echo Cancellation Parameters, but provides no detail about what any of the parameters do. It may be purely a passthrough to some native Qualcomm settings. The call audio routing on the pinephone bypasses the alsa and pulseaudio mixers so we don't get to use software echo cancellation. I haven't checked the routing for the PPP but I suspect it's a similar situation.
You should edit /usr/share/alsa/ucm2/PinePhonePro/VoiceCall.conf and set the following mic boost options:

IN1 Boost 0

IN2 Boost 1

IN 3 Boost 0
Yup, that sorted it, it does work after all. Made a phone call on the PPP today, with these settings on Manjaro, it works. Thanks for those who posted help!
I also updated the firmware using gnome firmware tool for the modem in case that helped.
Saying that, the caller is very quiet to me, and also not sure if the device wakes from suspend for a call properly.
I was able to fix the echo issue with the PinePhone on Mobian by using alsamixer and pressing the F6 key to select the hardware. Then I set "Mic1 Boost" to 0 like mentioned on https://forum.manjaro.org/t/original-pin...ing/153873. Decreasing "Line Out" to around 50 also helped (this setting decreased the loudspeaker volume which was not working with the volume keys during a call).

Forum Jump:

Users browsing this thread: 1 Guest(s)