no cursor/caret in console?
#11
(06-27-2016, 02:57 PM)longsleep Wrote:
(06-27-2016, 02:37 PM)MarkHaysHarris777 Wrote: Will the mali driver fix the cursor problem too ?

No.

What's the answer for fixing it ...  manually, even...  Smile
  Reply
#12
(06-27-2016, 01:53 PM)longsleep Wrote: Sure can be fixed. But why anyone wants to use the fb console is beyond me. SSH in, use a desktop or UART.

hi longsleep;  ... been thinking about this last night. Some of the reason has to something to do with history, and some of the reason has something to do with work patterns based on that history.

Back in the day (1991) Linus Torvalds was the first person to work on the fbcon. In fact, it was one of the very first pieces he put into the kernel. He was not so much interested in creating an OS for the 386/486 he was mostly interested in building himself a set of tools (a console mostly) for accessing the unix machines @ the university at Helsinki. 

Many of us (admittedly grey-beards) have been booting into the CLI and using the fbcon (me-- all six of them, one or two of them running screen with some extra consoles !). Don't get me wrong, that does not mean that I don't want to boot my computers into a gui from time to time... but mostly (all of the PIs at the moment) boot into the CLI from where I use the fb consoles (what some of the rest of us call virtual consoles ). 

I realize the work this might be for you. You DO want to be remembered for the person who put the kernel on the PineA64 for gnu+linux!  You DO NOT want to be remembered as the guy who invented the cursorless fbcon!

Think about it for a minute... an fbcon is completely pointless; why even have it !  (let alone six of them)

The fbcon must support a cursor. I know you hate hearing that, but just sleep on it for a few days. 

best wishes,

marcus
  Reply
#13
Hi!

I use fbcon (precompiled in 3.4.79 kernel) on my old Cubietruck and have no issues with cursor. So looks like Mali400/fbcon has (may be emulated?) some cursor support.

Or it is A64-specific?

Also look at http://forum.odroid.com/viewtopic.php?f=...758#p82647 and below - there is CONFIG_FB_SOFT_CURSOR=y option in kernel config
  Reply
#14
(06-28-2016, 07:33 AM)av1024 Wrote: Hi!

I use fbcon (precompiled in 3.4.79 kernel) on my old Cubietruck and have no issues with cursor. So looks like Mali400/fbcon has (may be emulated?) some cursor support.

Or it is A64-specific?

Also look at http://forum.odroid.com/viewtopic.php?f=...758#p82647 and below - there is CONFIG_FB_SOFT_CURSOR=y option in kernel config

Yes, xalius alluded to a fbcon soft cursor (said they have synch problems). I booted my rasppi4 PI into CLI this morning (just now) and its fbcon cursor is a flashing underscore/ works well. 

I have heard that the Allwinner SoC does not have hardware cursor ?!?  I don't know if the Broacom SoC does.  I'll get on the Raspberry PI forum a little later and ask. 

I'd like to try the kernel compiled with the CONFIG_FB_SOFT_CURSOR=y enabled. 

marcus
  Reply
#15
(06-28-2016, 07:47 AM)MarkHaysHarris777 Wrote: I have heard that the Allwinner SoC does not have hardware cursor ?!?  I don't know if the Broacom SoC does.  I'll get on the Raspberry PI forum a little later and ask. 

I'd like to try the kernel compiled with the CONFIG_FB_SOFT_CURSOR=y enabled. 

marcus

Remember to disable (CONFIG_FB_OSD2_CURSOR=n) option.

BTW, I'm not at cubietruck now, but via VPN I can see there is no _any_ option in config.gz:
Code:
[ssh] [email protected]:~$ cat /proc/config.gz |gunzip|grep -i _FB
CONFIG_FB=y
# CONFIG_FB_DDC is not set
# CONFIG_FB_BOOT_VESA_SUPPORT is not set
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
# CONFIG_FB_CFB_REV_PIXELS_IN_BYTE is not set
CONFIG_FB_SYS_FILLRECT=m
CONFIG_FB_SYS_COPYAREA=m
CONFIG_FB_SYS_IMAGEBLIT=m
# CONFIG_FB_FOREIGN_ENDIAN is not set
# CONFIG_FB_SYS_FOPS is not set
# CONFIG_FB_WMT_GE_ROPS is not set
CONFIG_FB_DEFERRED_IO=y
# CONFIG_FB_SVGALIB is not set
# CONFIG_FB_MACMODES is not set
# CONFIG_FB_BACKLIGHT is not set
CONFIG_FB_MODE_HELPERS=y
# CONFIG_FB_TILEBLITTING is not set
CONFIG_FB_SUNXI=y
CONFIG_FB_SUNXI_RESERVED_MEM=y
CONFIG_FB_SUNXI_UMP=y
CONFIG_FB_SUNXI_LCD=y
CONFIG_FB_SUNXI_HDMI=y
# CONFIG_FB_ARMCLCD is not set
# CONFIG_FB_UVESA is not set
# CONFIG_FB_S1D13XXX is not set
# CONFIG_FB_SMSCUFX is not set
# CONFIG_FB_UDL is not set
# CONFIG_FB_VIRTUAL is not set
# CONFIG_FB_METRONOME is not set
# CONFIG_FB_BROADSHEET is not set
# CONFIG_FB_SM7XX is not set
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)