Camera is working on Linux
#1
The camera module is working on Linux 3.10.102.
Have a look here: http://forum.armbian.com/index.php/topic...or-pine64/
  Reply
#2
kewl including guvcview into the next debian image release (Mate and XFCE)
If you like my work be sure to check out my site or wish to donate to the cause

Cheers Big Grin
  Reply
#3
PKernel 3.10.102 longsleep, get
My modified guvcview github.com/avafinger
  Reply
#4
@lex, this?
https://github.com/avafinger/guvcview
updated to include pine64 yet?
btw, thanks. now i just need a camera.
  Reply
#5
nice... now i just need my camera to get here...
  Reply
#6
(06-22-2016, 10:47 PM)dkryder Wrote: @lex, this?
https://github.com/avafinger/guvcview
updated to include pine64 yet?
btw, thanks. now i just need a camera.

Yes, updated to compile on pine64+. 

BTW, if someone has hm5065 module should update to 3.10.102 and compile DTB and give it a try, maybe this can work (only if the module works on Android).
  Reply
#7
Nice! I should order a camera module, but I still got two USB cams sitting around...
Come have a chat in the Pine A64 IRC channel >>
  Reply
#8
On (up to date) Ubuntu I get:


Code:
$ guvcview
GUVCVIEW: version 2.0.2
GUVCVIEW: couldn't open /home/ubuntu/.config/guvcview2/video0 for read: No such file or directory
V4L2_CORE: ERROR opening V4L interface: No such file or directory

(process:8056): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.


Code:
$ uname -a

Linux localhost.localdomain 3.10.102-0-pine64-longsleep #7 SMP PREEMPT Fri Jun 17 21:30:48 CEST 2016 aarch64 aarch64 aarch64 GNU/Linux

There is no /dev/video* and no /dev/v4l*

How do I fix this or go about finding the cause?
  Reply
#9
STEP 1

sudo -i
resize_rootfs.sh
reboot

STEP 2 (After Reboot)
sudo -i
pine64_update_uboot.sh
pine64_update_kernel.sh
reboot

STEP 3
sudo -i
apt-get -f install
apt-get install v4l-utils
If you like my work be sure to check out my site or wish to donate to the cause

Cheers Big Grin
  Reply
#10
That doesn't help for me. I'm running Debian, uboot and kernel are updated to newest. It seems that system just doesn't see the camera at all. There's no /dev/video and dmesg shows v4l-modules loaded with "device as (null)". Full dmesg here.
There have been different information about the required kernel module. Some say it's hm5065, others ov6650 or s5k4ec. I've tried them all and several others with modprobe with no luck. At the moment my lsmod says
Code:
[email protected]:~# lsmod
Module                  Size  Used by
ov6650                 17419  0
soc_camera             23007  1 ov6650
soc_mediabus           12729  1 soc_camera
videobuf_core          21858  1 soc_camera
hm5065                 25664  0
s5k4ec                 33771  0
vfe_v4l2              747618  0
vfe_io                 34085  3 vfe_v4l2,hm5065,s5k4ec
mali                  199851  0
ir_lirc_codec          12756  0
lirc_dev               17032  1 ir_lirc_codec
ir_jvc_decoder         12487  0
ir_sanyo_decoder       12491  0
ir_sony_decoder        12489  0
ir_rc6_decoder         12520  0
ir_nec_decoder         12487  0
ir_rc5_decoder         12487  0
ir_mce_kbd_decoder     12628  0
ss                     33083  0
videobuf2_dma_contig    17668  1 vfe_v4l2
videobuf2_memops       12546  1 videobuf2_dma_contig
sunxi_ir_rx            12902  0
videobuf2_core         30952  2 vfe_v4l2,soc_camera
cedar_ve               17368  0
8723bs               1365012  0
cfg80211              374207  1 8723bs
Still no /dev/video, which I think should be there if v4l-device is working. The program suggested here (guvcview) does nothing because it can't find the video device.
Could someone with the soc camera working post their lsmod? Or dmesg? I have no idea where to continue now.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  13MP Camera cable extension saviod 2 111 06-21-2019, 06:05 AM
Last Post: saviod
  Camera Sasank 15 4,711 12-13-2018, 09:08 PM
Last Post: Mutani
  Himax 5 Megapixel Camera Module cannot fit into 7″ LCD Touch Screen Panel themyshop 3 482 05-10-2018, 04:28 PM
Last Post: tllim
  CSI / Camera Module Compatibility? vade 7 3,476 05-04-2017, 02:43 PM
Last Post: tllim
  Webcam vs camera module on pine64+ fkpkot 4 1,653 02-27-2017, 03:57 PM
Last Post: MarkHaysHarris777
  camera module and lcd integration jodybrown99 5 1,027 10-11-2016, 11:35 AM
Last Post: hikaricore
  camera port details? gourmand007 5 2,052 07-09-2016, 12:24 AM
Last Post: peteforde
  About the camera robopo 10 4,639 06-28-2016, 03:42 PM
Last Post: Pander
  Anyone get the camera to work yet? Havensal 15 3,397 06-28-2016, 03:37 PM
Last Post: Pander

Forum Jump:


Users browsing this thread: 1 Guest(s)