on off power button stopped working
#1
Hi,

Another thread mentions the $1 "PINEPHONE SIDE KEYS FLEX PCB" https://forum.pine64.org/showthread.php?...3#pid91693

I just took apart the Pinephone to replace the earpiece speaker and the on/off button no longer works - or at least not very often, I have to plug in USB-C cable to turn it on. And I can't reliably turn the screen on / off with the power on/off button.

I have removed the back cover and the inner plastic cover that goes round the back - the volume / on / off flexi cable is fully inserted into the motherboard 'slot'.  Vol up / down works fine, still. Looking at the side where the black and white 'cover' is on the vol up/down and on/off keys with a torch, the top of the on/off key area seems to have lots of small creases / thin vertical lines across the top half - I don't know if that would be the issue or the flexi itself?

Standard shipping to Adelaide, Australia is US$12, so very expensive US$13 total. Is there anywhere else I can buy it with more reasonable shipping?

Any suggestions as to what I could try to 'fix' this? I'm starting to realise that a lot of parts seem very fragile and can apparently be easily damaged when taking apart / putting back together. I have been very careful but you have to bend the flexi to get it back into the motherboard 'slot'.

Thanks for any advice. Anyone in Australia ordering something please let me know - it would be great to be able to reduce shipping costs. Not quite sure if I can live with it as it is. I might just switch back to my Android phone with Lineageos and without google apps!
Pinephone v1.2 UBports CE. Adelaide, Australia using Amaysim SIM (Optus network, non-VoLTE) with Mobian SD card.
Manjaro Plasma Mobile on EMMC.
  Reply
#2
(07-24-2021, 05:07 AM)dcinoz Wrote: Hi,

Another thread mentions the $1 "PINEPHONE SIDE KEYS FLEX PCB" https://forum.pine64.org/showthread.php?...3#pid91693

I just took apart the Pinephone to replace the earpiece speaker and the on/off button no longer works - or at least not very often, I have to plug in USB-C cable to turn it on. And I can't reliably turn the screen on / off with the power on/off button.

I have removed the back cover and the inner plastic cover that goes round the back - the volume / on / off flexi cable is fully inserted into the motherboard 'slot'.  Vol up / down works fine, still. Looking at the side where the black and white 'cover' is on the vol up/down and on/off keys with a torch, the top of the on/off key area seems to have lots of small creases / thin vertical lines across the top half - I don't know if that would be the issue or the flexi itself?

Standard shipping to Adelaide, Australia is US$12, so very expensive US$13 total. Is there anywhere else I can buy it with more reasonable shipping?

Any suggestions as to what I could try to 'fix' this? I'm starting to realise that a lot of parts seem very fragile and can apparently be easily damaged when taking apart / putting back together. I have been very careful but you have to bend the flexi to get it back into the motherboard 'slot'.

Thanks for any advice. Anyone in Australia ordering something please let me know - it would be great to be able to reduce shipping costs. Not quite sure if I can live with it as it is. I might just switch back to my Android phone with Lineageos and without google apps!

Please PM your shipping address to me, I will mail one PinePhone side keys witch boar to you using normal envelop.
  Reply
#3
Thanks for the offer, very much appreciated.

If anyone has instructions on how to replace the flex, thanks for letting me know.
Pinephone v1.2 UBports CE. Adelaide, Australia using Amaysim SIM (Optus network, non-VoLTE) with Mobian SD card.
Manjaro Plasma Mobile on EMMC.
  Reply
#4
@tllim thanks a lot for the flex, I have received it.

I removed the old one carefully (it is stuck on a metal strip) using a screwdriver and razor blade. The new one can be stuck in place (remove plastic from the rear and it's ready to go).

I connected the new flexi to the motherboard and the on / off button works, as do the volume up/down buttons!

I'm not sure how to avoid the issue again if I connect / disconnect it in the future.
Pinephone v1.2 UBports CE. Adelaide, Australia using Amaysim SIM (Optus network, non-VoLTE) with Mobian SD card.
Manjaro Plasma Mobile on EMMC.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Power supply vs battery albafrati 11 537 06-22-2022, 06:04 PM
Last Post: albafrati
  Hardware switch for mic is not working properly submariner 10 3,120 01-25-2022, 07:01 AM
Last Post: wibble
  New vibration motor not working Zebulon Walton 6 3,297 11-13-2021, 03:00 AM
Last Post: kqlnut
  Power consumption during the call some_pinephone_user 0 519 10-29-2021, 06:03 AM
Last Post: some_pinephone_user
  Won't boot until connected to power after sudden power loss brb78 1 893 08-30-2021, 12:41 AM
Last Post: bcnaz
  Regarding USB Power and Modem Initialization vidual 2 1,441 08-26-2021, 11:48 PM
Last Post: vidual
  LED not working on 3GB variant IVp 2 1,256 08-21-2021, 02:57 PM
Last Post: IVp
Sad PnePhone Braveheart Edition - Microphone NOT Working valentin 15 2,876 08-09-2021, 07:43 PM
Last Post: tllim
  Help needed: Jump drive not working UsnR2 5 2,600 07-09-2021, 03:22 PM
Last Post: UsnR2
  Pogo pins power clarification - reading schematics bokomaru 48 21,017 06-19-2021, 10:46 AM
Last Post: bokomaru

Forum Jump:


Users browsing this thread: 1 Guest(s)