Could pulseaudio be replaced with pipewire?
#1
On Debian Bullseye, pipewire can already be installed and configured as a drop-in replacement for pulseaudio. I have done this on my laptop and I appreciate the ease of configuring pipewire for high-quality Bluetooth audio (LDAC).

Unfortunately, on Mobian the pulseaudio-module-bluetooth package – which must be removed in order to use pipewire as a drop-in replacement for pulseaudio – is a hardcoded dependency for all of the various PinePhone-specific packages. Is this really necessary, or is it worth filing a bug on Mobian's tracker to make also pipewire capable of fulfilling this dependency?
  Reply
#2
I'd file a bug report against the pinephone-specific packages as it's going to become necessary sooner or later. Whether it'll Just Work is another matter, but there's only one way to find out.
  Reply
#3
Manjaro is already trying this out and there don't seem to be big problems, so it should probably work on Mobian too.
  Reply
#4
You don't have to remove pulseaudio from your system, you just have to disable pulseaudio, and enable pipewire-pulse. pipewire should already be installed on mobian because xdg-desktop-portal depends on it. You may need to install spa module to use bluetooth audio.

Here is my setup:
Code:
sudo cp /usr/share/doc/pipewire/examples/systemd/user/pipewire-pulse.{service,socket} /usr/lib/systemd/user/
sudo touch /etc/pipewire/media-session.d/with-pulseaudio
sudo apt install pipewire-audio-client-libraries libspa-0.2-bluetooth

systemctl --user daemon-reload
systemctl --user mask pulseaudio.service
systemctl --user enable pipewire-pulse.service pipewire-pulse.socket

sudo systemctl reboot

I tested my setup on mobian unstable and it kind of worked. Bluetooth headphone with A2DP worked. feedbackd becomes crazy (random vibration and ringing. Lots of error log.)
HSP/HFP and aptx does not work with my headset probably because the package in debian is too old.

Debian specific manual is installed at /usr/share/doc/pipewire-audio-client-libraries/README.Debian
  Reply
#5
(05-26-2021, 11:52 AM)awaittrot Wrote: You don't have to remove pulseaudio from your system, you just have to disable pulseaudio, and enable pipewire-pulse.

The Debian wiki's Pipewire article says that "At minimum, you will need to install the libspa-0.2-bluetooth package, remove the pulseaudio-module-bluetooth package..."
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Bug PulseAudio: connection terminated/daemon killed Zombie Feynman 0 1,281 08-24-2021, 09:48 AM
Last Post: Zombie Feynman
  Modem scripts replaced by eg25-manager by apt-get dist-upgrade Zebulon Walton 2 3,041 12-21-2020, 06:12 PM
Last Post: Zebulon Walton

Forum Jump:


Users browsing this thread: 1 Guest(s)