Start VPN at BOOT?
#1
I finally got openvpn to work with my config file. There is a lack of network management settings currently. I was wondering how to get openvpn to start and connect to vpn server at boot, and if there is network lock? to prevent connection without vpn.
  Reply
#2
(04-30-2021, 06:34 PM)donniedice Wrote: I finally got openvpn to work with my config file. There is a lack of network management settings currently. I was wondering how to get openvpn to start and connect to vpn server at boot, and if there is network lock? to prevent connection without vpn.

I also recently got openvpn working in Manjaro Phosh which is great :-)  Haven't spent much time looking for a way to get it to automatically connect at boot yet.. I have noticed that the VPN connection seems to 'go stale' after the phone goes to sleep, so I have to manually stop and restart it every time after waking it up.  Do you notice this happening too?  If anyone has any fixes or suggestions to address this I'm all ears :-)

As nice as it would be to get it to auto connect at boot, I'm so used to having to constantly manually reconnect it that I haven't bothered until I can sort out this issue first.

P.S. also my openvpn connection was leaking ipv6 so you may want to double check if this is happening to you.  I was able to disable ipv6 and prevent it from leaking.
  Reply
#3
(05-03-2021, 09:08 AM)OmniSightSeeing Wrote:
(04-30-2021, 06:34 PM)donniedice Wrote: I finally got openvpn to work with my config file. There is a lack of network management settings currently. I was wondering how to get openvpn to start and connect to vpn server at boot, and if there is network lock? to prevent connection without vpn.

I also recently got openvpn working in Manjaro Phosh which is great :-)  Haven't spent much time looking for a way to get it to automatically connect at boot yet.. I have noticed that the VPN connection seems to 'go stale' after the phone goes to sleep, so I have to manually stop and restart it every time after waking it up.  Do you notice this happening too?  If anyone has any fixes or suggestions to address this I'm all ears :-)

As nice as it would be to get it to auto connect at boot, I'm so used to having to constantly manually reconnect it that I haven't bothered until I can sort out this issue first.

P.S. also my openvpn connection was leaking ipv6 so you may want to double check if this is happening to you.  I was able to disable ipv6 and prevent it from leaking.


How did you guys do this? Can you give me an URL or point me in the right direction? Thank you
edit: I just changed OS to mobian and set it all up myself.. Much better then manjaro in my opinion.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Won't boot past the KDE splash screen nelstomlinson 5 571 07-10-2021, 04:46 PM
Last Post: mouffa
  After update black screen and unable to boot anything vmataixf 1 392 06-01-2021, 05:32 AM
Last Post: dcinoz
  PinePhone Beta Edition will not boot from MicroSD card Timothy_Ecc 8 1,631 04-30-2021, 03:42 PM
Last Post: Timothy_Ecc
Exclamation PinePhone Manjaro Edition, does not boot vdiazroa 2 1,247 11-28-2020, 02:00 PM
Last Post: bcg7
  Just tried booting up the dev release of KDE Mobile and phone wouldn't boot up. ragreenburg 1 1,020 09-11-2020, 07:34 PM
Last Post: DaveWoodX

Forum Jump:


Users browsing this thread: 1 Guest(s)