Carte PCIe bloquant le démarrage du Noyau / PCIe card blocking Kernel boot
#1
Bonjour ...

Je rencontre in problème avec un carte PCIe qui bloque mon RockPro64 dès le lancement du noyau.
Voici ce que la console m'affiche :

Code:
U-Boot 2020.10-armbian (Feb 04 2021 - 02:11:12 +0100)

SoC: Rockchip rk3399
Reset cause: POR
Model: Pine64 RockPro64 v2.1
DRAM:  3.9 GiB
PMIC:  RK808
MMC:  mmc@fe310000: 2, mmc@fe320000: 1, sdhci@fe330000: 0
Loading Environment from SPIFlash... SF: Detected gd25q128 with page size 256 Bytes, erase size 4 KiB, total 16 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:  serial
Err:  serial
Model: Pine64 RockPro64 v2.1
Net:  eth0: ethernet@fe300000
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc1 is current device
Scanning mmc 1:1...
Found U-Boot script /boot/boot.scr
3185 bytes read in 5 ms (622.1 KiB/s)
## Executing script at 00500000
Boot script loaded from mmc 1
213 bytes read in 4 ms (51.8 KiB/s)
13102297 bytes read in 558 ms (22.4 MiB/s)
28582400 bytes read in 1214 ms (22.5 MiB/s)
75846 bytes read in 13 ms (5.6 MiB/s)
267 bytes read in 8 ms (32.2 KiB/s)
Applying kernel provided DT overlay rockchip-pcie-gen2.dtbo
2698 bytes read in 9 ms (292 KiB/s)
Applying kernel provided DT fixup script (rockchip-fixup.scr)
## Executing script at 09000000
Moving Image from 0x2080000 to 0x2200000, end=3de0000
## Loading init Ramdisk from Legacy Image at 06000000 ...
  Image Name:  uInitrd
  Image Type:  AArch64 Linux RAMDisk Image (gzip compressed)
  Data Size:    13102233 Bytes = 12.5 MiB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... OK
## Flattened Device Tree blob at 01f00000
  Booting using the fdt blob at 0x1f00000
  Loading Ramdisk to f1291000, end f1f0fc99 ... OK
  Loading Device Tree to 00000000f1216000, end 00000000f1290fff ... OK

Starting kernel ...
... et l'affichage s'arrête là.
J'ai attendu plusieurs minutes mais rien de plus.
J'ai aussi testé un «ping» durant ce temps, au cas où ce ne soit qu'un problème de console :

Code:
...
From xxx.xxx.xxx.xxx icmp_seq=3493 Destination Host Unreachable
From xxx.xxx.xxx.xxx icmp_seq=3494 Destination Host Unreachable
From xxx.xxx.xxx.xxx icmp_seq=3495 Destination Host Unreachable
From xxx.xxx.xxx.xxx icmp_seq=3496 Destination Host Unreachable
From xxx.xxx.xxx.xxx icmp_seq=3500 Destination Host Unreachable
From xxx.xxx.xxx.xxx icmp_seq=3503 Destination Host Unreachable
...

La carte qui bloque le noyau au démarrage est celle-ci : Lorsque cette carte pcie n'est pas connectée, le noyau démarre sans aucun problème.
J'utilise maintenant le noyau ArmBian «5.10.16»,car avec le noyau «4.4.x», le problème était le même (voir pire).

Ayant aussi une carte «PCIE-EUX1-04 Ver.002» et ayant lu qu'elle était supportée par la carte RockPro64 : ... j'ai aussi testé cette carte mais cela ne fonctionne pas chez moi. Le résultat est le même.

Si quelqu'un aurait une piste ou une solution, je serai heureux qu'il me la transmette.

D'avance, Merci pour vos réponses.

Cordialement.

Hello ...

I run into a problem with a PCIe card that blocks my RockPro64 when the kernel is launched.
Here is what the console shows me :
Code:
U-Boot 2020.10-armbian (Feb 04 2021 - 02:11:12 +0100)

SoC: Rockchip rk3399
Reset cause: POR
Model: Pine64 RockPro64 v2.1
DRAM:  3.9 GiB
PMIC:  RK808
MMC:  mmc@fe310000: 2, mmc@fe320000: 1, sdhci@fe330000: 0
Loading Environment from SPIFlash... SF: Detected gd25q128 with page size 256 Bytes, erase size 4 KiB, total 16 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:  serial
Err:  serial
Model: Pine64 RockPro64 v2.1
Net:  eth0: ethernet@fe300000
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc1 is current device
Scanning mmc 1:1...
Found U-Boot script /boot/boot.scr
3185 bytes read in 5 ms (622.1 KiB/s)
## Executing script at 00500000
Boot script loaded from mmc 1
213 bytes read in 4 ms (51.8 KiB/s)
13102297 bytes read in 558 ms (22.4 MiB/s)
28582400 bytes read in 1214 ms (22.5 MiB/s)
75846 bytes read in 13 ms (5.6 MiB/s)
267 bytes read in 8 ms (32.2 KiB/s)
Applying kernel provided DT overlay rockchip-pcie-gen2.dtbo
2698 bytes read in 9 ms (292 KiB/s)
Applying kernel provided DT fixup script (rockchip-fixup.scr)
## Executing script at 09000000
Moving Image from 0x2080000 to 0x2200000, end=3de0000
## Loading init Ramdisk from Legacy Image at 06000000 ...
  Image Name:  uInitrd
  Image Type:  AArch64 Linux RAMDisk Image (gzip compressed)
  Data Size:    13102233 Bytes = 12.5 MiB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... OK
## Flattened Device Tree blob at 01f00000
  Booting using the fdt blob at 0x1f00000
  Loading Ramdisk to f1291000, end f1f0fc99 ... OK
  Loading Device Tree to 00000000f1216000, end 00000000f1290fff ... OK

Starting kernel ...
... and the signage stops there.
I waited several minutes but nothing more.
I also tested a «ping» during this time, in case it is only a console problem :
Code:
...
From xxx.xxx.xxx.xxx icmp_seq=3493 Destination Host Unreachable
From xxx.xxx.xxx.xxx icmp_seq=3494 Destination Host Unreachable
From xxx.xxx.xxx.xxx icmp_seq=3495 Destination Host Unreachable
From xxx.xxx.xxx.xxx icmp_seq=3496 Destination Host Unreachable
From xxx.xxx.xxx.xxx icmp_seq=3500 Destination Host Unreachable
From xxx.xxx.xxx.xxx icmp_seq=3503 Destination Host Unreachable
...

The board that blocks the kernel at boot time is: When this pcie card is not connected, the kernel starts without any problems.
I now use the ArmBian kernel «5.10.16», because with the kernel «4.4.x», the problem was the same (see worse).


Having also a card «PCIE-EUX1-04 Ver.002» and having read that it was supported by the RockPro64 card : ... i also tested this card but it does not work for me. The result is the same.

If someone has a lead or a solution, I would be happy to hear from them.

In advance, thank you for your answers.

Best Regards.
  Reply
#2
Try ayufan images. https://github.com/ayufan-rock64/linux-b...tag/0.9.14
  Reply
#3
Add `earlycon=uart8250,mmio32,0xff1a0000` to your command line to get the earlyboot crash messages.
Note that the PCIe controller is bugged, especially with switches and other complex devices.

There is a delay patch that allows one to configure the maximum timeout for the device, but it is incomplete and hasn't been submitted to mainline.
  Reply
#4
(02-17-2021, 04:23 AM)cmosfxx Wrote: Try ayufan images. https://github.com/ayufan-rock64/linux-b...tag/0.9.14

Re ...

Merci ...

J'ai testé l'image «buster-minimal-rockpro64-0.9.14-1159-arm64.img» : Le noyau démarre bien mais les LEDs bleues de la carte PCIe ne s'allument plus et la commande «lspci» est vide.

Avec l'image «buster-minimal-rockpro64-0.10.3-1171-arm64.img» : Le noyau démarre bien, les LEDs bleues de la carte PCIe s'illuminent ... mais le noyau mouline sur :
[Image: KBrmhCbzg55_ScreenShot-20210217-130517.png]
Après 15 minutes, j'ai abandonné :
[Image: KBrms2FC6x5_ScreenShot-20210217-131343.png]

Merci pour votre réponse.

Cordialement.


Re ...

Thank you ...

I tested the image «buster-minimal-rockpro64-0.9.14-1159-arm64. img» : The kernel starts well but the blue LEDs of the PCIe card no longer light and the «lspci» command is empty.

With the image «buster-minimal-rockpro64-0.10.3-1171-arm64.img» : The kernel starts well, the blue LEDs of the PCIe card light up ... but the core grinds on :
[Image: KBrmhCbzg55_ScreenShot-20210217-130517.png]
After 15 minutes, I gave up :
[Image: KBrms2FC6x5_ScreenShot-20210217-131343.png]

Thank you for your answer.

Best Regards.

(02-17-2021, 06:10 AM)pgwipeout Wrote: Add `earlycon=uart8250,mmio32,0xff1a0000` to your command line to get the earlyboot crash messages.
Note that the PCIe controller is bugged, especially with switches and other complex devices.

There is a delay patch that allows one to configure the maximum timeout for the device, but it is incomplete and hasn't been submitted to mainline.

Re ...

Merci pour votre réponse.
L'ajout de «earlycon=uart8250,mmio32,0xff1a0000» aux paramètres du noyau ne permet pas le démarrage du noyau et ne m'affiche aucune information sur un plantage du noyau :
[Image: KBrmNFVQ7X5_ScreenShot-20210217-133336.png]

Cordialement.

Re ...

Thank you for your answer.
Adding «earlycon=uart8250,mmio32,0xff1a0000» to the kernel settings does not allow the kernel to boot and does not show me any information about a kernel crash :
[Image: KBrmNFVQ7X5_ScreenShot-20210217-133336.png]

Best Regards.
  Reply
#5
Re ...

Sinon ... j'ai refait un nouveau test avec le noyau «4.4.213» et comme pour le noyau «5.10.12», il bloque après l'affichage de «Starting kernel ...», sauf qu'avec le noyau «4.4.213» toutes les cartes PCIe et le «Bridge» s'arrêtent.
«U-Boot» détecte bien le «Bridge» PCIe interne à la carte «RockPro64» (pci 0) mais aussi le «Brige» connecté au port PCIe (pci 1) :
[Image: KBrry5o8K85_ScreenShot-20210217-181514.png]

Pour le noyau «5.10.12», il y a même une LED jaune, de la carte SATA connectée, qui s'illumine pendant 1 seconde après l'affichage du «Starting kernel ...».

Donc, «U-Boot» reconnaît brièvement la carte PCIe connectée, je ne vois donc pas pourquoi le Noyau se fige !?

Cordialement.

Re ...

Otherwise ... I did a new test with the kernel «4.4.213» and as for the kernel «5.10.12», it blocks after the display of «Starting kernel ...», except that with the kernel «4.4.213» all PCIe cards and the «Bridge» stop.
«U-Boot» detects the internal PCIe «Bridge» to the «RockPro64» board (pci 0) but also the «Brige» connected to the PCIe port (pci 1) :
[Image: KBrry5o8K85_ScreenShot-20210217-181514.png]

For the «5.10.12» kernel, there is even a yellow LED, from the connected SATA board, which illuminates for 1 second after the display of the «Starting kernel ...».

So, «U-Boot» recognizes briefly the connected PCIe cards, so I don’t see why the Kernel freezes !?

Best Regards.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Right direction SATA card corax 2 180 09-15-2021, 12:46 PM
Last Post: corax
  RP64 Won't Boot After Power Down ColPanic_ 8 1,028 09-04-2021, 12:12 PM
Last Post: gechu
  RockPro64 has bad Memory (Software sogfaults and kernel panics) kop316 20 7,542 08-04-2021, 07:42 PM
Last Post: t4_4t
  Rockpro64 Sata Card kills itself jerry110 31 16,397 06-21-2021, 05:19 AM
Last Post: hyc
  Industrial memory card m.ekstrom 1 684 03-23-2021, 05:55 AM
Last Post: barray
  Multiport Gigabit Card? jerry110 24 13,751 02-26-2021, 03:54 PM
Last Post: kuleszdl
  Won't boot with SATA card rjzak 4 2,134 01-09-2021, 05:56 PM
Last Post: kuleszdl
  case for RockPro64 + PCI-E M.2 NVMe Card? AndyOfLinux 9 5,637 01-05-2021, 05:05 PM
Last Post: kuleszdl
  Nvidia GPU on PCIe Jamesthetechie 4 1,645 12-22-2020, 02:54 PM
Last Post: amiraeva
  Won't boot with 2.5GBe PCIe adaptor connected voltagex 1 1,186 10-20-2020, 12:22 PM
Last Post: xmixahlx

Forum Jump:


Users browsing this thread: 1 Guest(s)