Unable to find ZWave module?
#1
Hi,

I have a A64 1GB Board with the ZWave Plus IO Card which is running Armbian Focal by default. I'm trying to get see if the ZWave module is working and to test this I installed openzwave and libopenzwave from the apt repo's.

After rebooting, I tried to verify that the ZWave module is working by running "sudo MinOZW /dev/ttyS2" but I get the following error:

Code:
2021-01-07 18:45:36.260 Warning, Failed - Network Key Not Set
2021-01-07 18:45:36.261 Info, mgr,     Added driver for controller /dev/ttyS2
2021-01-07 18:45:36.261 Info,   Opening controller /dev/ttyS2
2021-01-07 18:45:36.261 Info, Trying to open serial port /dev/ttyS2 (attempt 1)
2021-01-07 18:45:36.261 Error, ERROR: Failed to set serial port parameters
2021-01-07 18:45:36.261 Error, ERROR: Failed to open serial port /dev/ttyS2
2021-01-07 18:45:36.262 Warning, WARNING: Failed to init the controller (attempt 0)


I also tried ttyS3/S4/S5 but those error out as well. MinOZW is able to open ttyS0 but then I get a different set of errors, which I suspect is because ttyS0 is Console? Can someone let me know how to determine whether my ZWave module is working?
  Reply
#2
I was able to resolve this by running armbian-config and enabling a number of hardware components under System>Hardware:

[Image: 7DKhTZU.png]

Once I enabled these and rebooted, MinOZW started working.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  +LTS/SOPINE PINE64 5 MEGAPIXEL CAMERA MODULE lendi 3 3,268 03-22-2020, 04:34 AM
Last Post: madupine

Forum Jump:


Users browsing this thread: 1 Guest(s)