SSH over USB
#1
I'm running Ubuntu on my desktops, and Mobian on the phone. I can SSH over LAN pretty easily, but I would like to connect directly over USB, if possible.

As a bonus, it could be nice if I could connect to my Mobian phone over LAN, but through the USB. I just figure it would faster than over wi-fi, which is a little spotty in my house.
  Reply
#2
Works out of the box now, just plug in that USB cable.

Ditto via ethernet, you may need to share the IPv4 connection that gets created for eth0 in this case though.
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.16 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edittion, Tow-boot on SPI, Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, daily driver: Tow-boot with Arch/Phosh on eMMC
  Reply
#3
Thanks. MTP seems to be working great, just from connecting the USB. But if I want to log into my Mobian shell, is there a way to do this over USB?

//Edit I get it. It proritizes the cable when you ssh, over wifi LAN. It looks like it also does a reverse tether, where the phone can get an internet connection through the host. Cool!
  Reply
#4
Shoot, this was working, and now it isn't. It seems that sometimes I upgrade my phone, and functions become unavailable. Anyway, how to I manually reinstall and re-enable this functionality? I'd like to get both SSH and IPv4 working over USB.
  Reply
#5
OK I think I have SSH working after all. I just needed to get the IP of the phone when it's over USB. However, my IPv4 sharing isn't working. I see a solution on the wiki, but it's complicated and involves manual modification to both the phone and my computer. Knowing it worked out of the box before, I'm hoping someone can help me with this piece.
  Reply
#6
(01-02-2021, 09:32 PM)3x5co Wrote: OK I think I have SSH working after all. I just needed to get the IP of the phone when it's over USB. However, my IPv4 sharing isn't working. I see a solution on the wiki, but it's complicated and involves manual modification to both the phone and my computer. Knowing it worked out of the box before, I'm hoping someone can help me with this piece.

Unless I am very much mistaken the wiki is superseded. On the assumption you want to share your PinePhone mobile internet connection with the device at the other end of the USB cable then it is (now) much easier.

On Mobian (I am running Arch for today - can swap back if this goes wrong) plug USB-C into your PP and the other end into your Ubuntu desktop. I think (not 100% certain) it should just work, if not open a terminal session both on the PP and the desktop.
Code:
ip a
in both terminals will show you what devices are active for networking - on both ends you are looking for something USB-like and for sure if there is nothing on the PP then there will be nothing on the desktop.

If you have something promising on the desktop end then you may need to reboot the desktop after disconnecting all other internet options - a while back when I was playing it seemed my desktop would get a fixation about the ethernet connection and not bother trying the USB. (I am in no doubt there is an elegant way somewhere to sort this with priorities but ...)

If you have nothing on the desktop but the PP looks promising then try
Code:
nmtui
in the PP terminal. Go to "Edit a connection", select the USB like connection and change its IPv4 configuration from Automatic to Shared.

{As above I am writing this without Mobian in front of me - if things seem a little garble that is my excuse :-) If you still have problems yell and I can fir Mobian!}
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.16 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edittion, Tow-boot on SPI, Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, daily driver: Tow-boot with Arch/Phosh on eMMC
  Reply
#7
Thanks for the help, but this has stopped working again after flashing a nightly. Now, when I run `ip a` I see:

```
usb0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
link/ether xxx brd xxx
```

But no inet or inet 6. I've tweaked the settings in the network manager but I can't get my computer to recognize the phone because it doesn't appear to have an ip address. when I look in the connection manager, it shows a usb connection and the ip listed is the default one (10.66.0.1).
  Reply
#8
I also noticed that when I go to network, under 'Wired', it says 'Cable unplugged' even though the cable is plugged in. I'm using the cable that came with the phone, and I tried a couple alternate cables. The battery is charging, so the phone does recognized the cable in that way.
  Reply
#9
You know, when this stopped working was right around the time I had to install Docker for a project. I noticed I now have this entry, among others:

Code:
3: lxcbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 00:16:3e:00:00:00 brd ff:ff:ff:ff:ff:ff
    inet 10.0.3.1/24 brd 10.0.3.255 scope global lxcbr0
       valid_lft forever preferred_lft forever

This appears to be related to Docker, and it's using 10.0.3.1. I know there's something on the wiki that says you may run into problems if your LAN's router is on the same 10.x.x.x subnet that Mobian is trying to use. Is it possible that Docker is creating a network overlap?
  Reply
#10
Nevermind, I tried connecting to another computer and I have the same problem: the connection says 'cable disconnected' in settings, and the usb connection only works to charge the phone.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)