Owncloud Experience Anyone?
#1
I've been trying to get ownCloud running on my 2Gb Pine64 but it's pretty buggy.  Anyone have any luck getting a solid instance of ownCloud running?

Everything seems to install correctly and the server seems stable, but the Windows desktop client crashes on a regular basis when I'm trying to sync 140Gb of music files.  Sometimes it just hangs and sometimes it aborts in an ugly fashion.  It seems like the desktop client works for others, I can only assume that there's something wrong with my server setup, so I'm hoping someone here has been able to do it successfully and can show the way.
#2
Yup! How can I help ? Smile

If you need help then im on irc for the next 2 hrs or so (see sig) and I can walk you though it.
You can find me on IRC, Discord and Twitter


#3
(05-31-2016, 04:47 PM)Luke Wrote: Yup! How can I help ? Smile

If you need help then im on irc for the next 2 hrs or so (see sig) and I can walk you though it.

That would be great!  I'll be putting the kids to bed until about 8:30.  Can we IRC then?

Should I start with a fresh system image or keep the one I've got and debug it?
#4
(05-31-2016, 05:00 PM)JCMPine64 Wrote:
(05-31-2016, 04:47 PM)Luke Wrote: Yup! How can I help ? Smile

If you need help then im on irc for the next 2 hrs or so (see sig) and I can walk you though it.

That would be great!  I'll be putting the kids to bed until about 8:30.  Can we IRC then?

Should I start with a fresh system image or keep the one I've got and debug it?

Afraid we are in different time zones Wink I may be asleep by your 8.30 (guessing you must be in East Coast US?). But no worries, If you dont catch me tonight then we can always chat tomorrow or the day after that.

[edit] You choose if you want to start from scratch. I would see if we cant figure out what the problem is with the current configuration first
You can find me on IRC, Discord and Twitter


#5
(05-31-2016, 05:18 PM)Luke Wrote:
(05-31-2016, 05:00 PM)JCMPine64 Wrote:
(05-31-2016, 04:47 PM)Luke Wrote: Yup! How can I help ? Smile

If you need help then im on irc for the next 2 hrs or so (see sig) and I can walk you though it.

That would be great!  I'll be putting the kids to bed until about 8:30.  Can we IRC then?

Should I start with a fresh system image or keep the one I've got and debug it?

Afraid we are in different time zones Wink I may be asleep by your 8.30 (guessing you must be in East Coast US?). But no worries, If you dont catch me tonight then we can always chat tomorrow or the day after that.

[edit] You choose if you want to start from scratch. I would see if we cant figure out what the problem is with the current configuration first

I'll keep the config, then.

I'll be able to talk in 50 minutes.  Will try you then, just in case.
#6
Hi,

I have it running too and just set it up last night.  It is stable and is faster than my RPi2.  I am based on the east coast of the US and am in eastern time.
#7
(06-01-2016, 08:08 AM)jl_678 Wrote: Hi,

I have it running too and just set it up last night.  It is stable and is faster than my RPi2.  I am based on the east coast of the US and am in eastern time.

Hi jl_678

I think that the issue JCMPine64 is experiencing is tied to the windows client. Are you using the Win client by any chance ? 

If not the three of us can set a time to meet and chat about this.
You can find me on IRC, Discord and Twitter


#8
(06-01-2016, 08:08 AM)jl_678 Wrote: Hi,

I have it running too and just set it up last night.  It is stable and is faster than my RPi2.  I am based on the east coast of the US and am in eastern time.

Great!  Would you be able to talk me through the steps you took to install/configure it?
#9
Hi,

I do not use the Windows client, only the web client.  I also have Owncloud running on an RPi2 as well.  It is slower, but also rock solid.  I could use the other platform as a comparison point.

Sure, I am happy to help.  It is really quite easy to setup.  How far did you get?  Have you installed Apache and MariaDB yet?  (Are you using Apache?)  After that, you just need to set the proper configs in the webserver, configure the DB and in general you should be good to go.
#10
(06-01-2016, 08:15 AM)jl_678 Wrote: Hi,

I do not use the Windows client, only the web client.  I also have Owncloud running on an RPi2 as well.  It is slower, but also rock solid.  I could use the other platform as a comparison point.

Sure, I am happy to help.  It is really quite easy to setup.  How far did you get?  Have you installed Apache and MariaDB yet?  (Are you using Apache?)  After that, you just need to set the proper configs in the webserver, configure the DB and in general you should be good to go.

I've got everything running, but I'm not sure if it's solid.  Here's basically what I did:
apt-get install owncloud
apt-get install mysql-server
  Created database on 3TB usb drive

Created self-signed certificate
sudo apt-get install openssh-server

From there I haven't done much.  I need to set up memcache, but I've gotten sidetracked by the problems uploading files.


Forum Jump:


Users browsing this thread: 7 Guest(s)