[SOLVED] bluetooth issues
I was facing bluetooth issues with the latest manjaro phosh image.

bluetoothctl only displayed
No default controller available

dmesg would give the following error:
[   11.573943] Bluetooth: hci0: RTL: loading rtl_bt/rtl8723cs_xx_fw.bin
[   11.595217] Bluetooth: hci0: RTL: loading rtl_bt/rtl8723cs_xx_config-pinephone.bin
[   11.602883] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723cs_xx_config-pinephone.bin failed with error -2

the file  rtl8723cs_xx_config-pinephone.bin was missing in /usr/lib/firmware/rtl_bt/
but there was a rtl8723cs_xx_config-pinebook.bin

I just copied it and renamed it as the required one, rebooted, and bluetooth worked.
Just sharing in case someone else faced the problem..

Possibly Related Threads…
Thread Author Replies Views Last Post
  Issues with PinePhone Pro Glenn 1 290 07-28-2022, 11:56 AM
Last Post: Airdale
Question New user/phone here - initial update issues sexywheat 2 378 06-29-2022, 04:27 PM
Last Post: sexywheat
  [Solved] How I got fsck.f2fs to get unstuck and fix not booting PP gab 1 754 02-08-2022, 01:35 PM
Last Post: gab
  Problems with audio via bluetooth connect to car zkajdan 0 480 01-15-2022, 12:35 PM
Last Post: zkajdan
  Bluetooth low energy & ANT+ sports sensors Pinephone distro? Peter Gamma 34 32,998 12-08-2021, 04:50 AM
Last Post: thibaultmol
  bluetooth connection to car multimedia interface problems (no sound) zkajdan 0 574 10-29-2021, 01:34 AM
Last Post: zkajdan
  deep sleep issues on multiple distros discogribbs 0 711 08-19-2021, 08:52 PM
Last Post: discogribbs
  [solved]no more call received [ModemManager, QMI protocol error] alexandre 1 1,711 04-19-2021, 05:57 AM
Last Post: alexandre
  Scaling Issues With Various Programs on Pinephone publiclewdness 3 3,029 11-22-2020, 07:29 PM
Last Post: publiclewdness
  [SOLVED] Brand new pinephone bricked almost immediately out of box... Cree 9 9,485 07-31-2020, 01:51 PM
Last Post: wibble

Forum Jump:

Users browsing this thread: 1 Guest(s)