Correct setup for u-boot and fstab ? Device not booting
#24
I have now tried the following combos:

ATF v2.3 + U-Boot 2020.10 --> does not boot at all
ATF v2.4 + U-Boot 2020.10 --> does boot, but can't parse extlinux.conf does boot but can't find eMMC
ATF v2.4 + U-Boot 2021.01 --> does boot, but can't parse extlinux.conf does boot but can't find eMMC

My Board is stamped PINE_H64_MODEL_B 2018-12-12.

Time to give up, for now, as I can't bring them up to life, especially with the new "SCP" Blob required by U-Boot. when building for the H6 which seems to have an additional OpenRisc Core as power management controller which makes things even more difficult.

Thanks to all for your time and help given, it is appreciated.

After checking the screenlogs again and again it dawned on me.... Idea

Reading up on extlinux and the examples given at linux-sunxi.org, I changed my extlinux.conf from

Code:
TIMEOUT 2
PROMPT 1
DEFAULT debian

LABEL debian
MENU LABEL Debian
KERNEL /vmlinuz
INITRD /initrd.img
DEVICETREEDIR /dtbs
APPEND console=tty1 root=LABEL=root rw rootwait

to

Code:
TIMEOUT 2
DEFAULT debian

LABEL debian
        MENU LABEL Debian
        LINUX /vmlinuz
        INITRD /initrd.img
        FDT /dtbs/allwinner/sun50i-h6-pine-h64-model-b.dtb
        APPEND console=tty1 root=LABEL=root rw rootwait

and now the board boots until u-boot tries to start the kernel, then it just stops.

Code:
U-Boot SPL 2020.10 (Mar 17 2021 - 14:12:11 +0000)
DRAM: 2048 MiB
Trying to boot from MMC2
NOTICE:  BL31: v2.4(release):v2.4
NOTICE:  BL31: Built : 13:48:42, Mar 17 2021
NOTICE:  BL31: Detected Allwinner H6 SoC (1728)
NOTICE:  BL31: Found U-Boot DTB at 0xc086a30, model: Pine H64
NOTICE:  PSCI: System suspend is unavailable


U-Boot 2020.10 (Mar 17 2021 - 14:12:11 +0000) Allwinner Technology

CPU:   Allwinner H6 (SUN50I)
Model: Pine H64
DRAM:  2 GiB
MMC:   mmc@4020000: 0, mmc@4022000: 1
Loading Environment from FAT... Unable to use mmc 1:1... In:    serial@5000000
Out:   serial@5000000
Err:   serial@5000000
Net:   phy interface7
eth0: ethernet@5020000
starting USB...
Bus usb@5101000: USB EHCI 1.00
Bus usb@5101400: USB OHCI 1.0
Bus usb@5311000: USB EHCI 1.00
Bus usb@5311400: USB OHCI 1.0
scanning bus usb@5101000 for devices... 1 USB Device(s) found
scanning bus usb@5101400 for devices... 1 USB Device(s) found
scanning bus usb@5311000 for devices... 1 USB Device(s) found
scanning bus usb@5311400 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Hit any key to stop autoboot:  2  1  0
switch to partitions #0, OK
mmc1(part 0) is current device
Scanning mmc 1:1...
Found /extlinux/extlinux.conf
Retrieving file: /extlinux/extlinux.conf
218 bytes read in 3 ms (70.3 KiB/s)
1:    Debian
Retrieving file: /initrd.img
28382050 bytes read in 2903 ms (9.3 MiB/s)
Retrieving file: /vmlinuz
22722416 bytes read in 2342 ms (9.3 MiB/s)
append: console=tty1 console=ttyS2,115200n8 root=LABEL=root rw rootwait
Retrieving file: /dtbs/allwinner/sun50i-h6-pine-h64-model-b.dtb
32773 bytes read in 8 ms (3.9 MiB/s)
Moving Image from 0x40080000 to 0x40200000, end=41840000
## Flattened Device Tree blob at 4fa00000
   Booting using the fdt blob at 0x4fa00000
EHCI failed to shut down host controller.
   Loading Ramdisk to 484ee000, end 49fff362 ... OK
   Loading Device Tree to 00000000484e2000, end 00000000484ed004 ... OK

Starting kernel ...

I assume u-boot can't find the kernel to finish the process. Any ideas?
  Reply


Messages In This Thread
RE: Correct setup for u-boot and fstab ? Device not booting - by as365n4 - 03-17-2021, 08:37 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  U-boot not booting on H64 model B CGNZVV 2 1,447 06-08-2022, 10:32 AM
Last Post: as365n4
  Unable to boot any armbian linux vicsanca 6 5,711 10-17-2019, 12:08 PM
Last Post: JGwinner

Forum Jump:


Users browsing this thread: 1 Guest(s)