Changing the ringtone?
#1
Is it still not possible to change the ringtone under Mobian to something that will actually get your attention?
Whenever an SMS or call comes in, I still just get that little "bweep" noise.
I want to set it to  something obnoxious and preferably louder.
Also, do the volume buttons actually work with the volume of the ringtone?
  Reply
#2
I only get a very very short burst of the vibrator on my Brave Heart phone for a new incoming text.
So any noise from the speaker would be an improvement.

The current ringtone for an incoming voice calls is actually satisfactory for me, but I do understand the desire for other choices.
Mine has a kind of 'generic cell phone ringing'  ringtone.
( It is louder than my cheap message phones ringtone )
  Reply
#3
You can do this by creating a custom sound profile and replacing the regular system sounds (for ringtones, alarms, or whatever you'd like) with any recording of your choice (I did it recently for the alarms in Clocks, so I could wake to a song, for instance, instead of the horrible beep-bee-beep noise).

First you'll want to copy the regular sound profile to your .local folder (to keep the default one as a backup, in case you mess something up):
Code:
cp -rv /usr/share/sounds/freedesktop ~/.local/share/sounds/my-custom-profile
Then navigate to this new local directory you made, and you'll see it contains a directory called stereo, and a file called index.theme. Open index.theme with a text editor and change the name to 'my-custom-profile'.

Navigate to the stereo directory and you'll see all of the system sounds, in the .oga format. You can replace any of them with sound files of your choosing. Convert your sound file to the .oga or .ogg format, change the name to whichever system sound you want to replace, then copy it into that directory to overwrite the default file for that system sound.

Finally, change your system sound profile to your custom profile. You can do this by using dconf-editor, navigating to /org/gnome/desktop/sound and changing the theme-name to 'my-custom-profile'.
  Reply
#4
I like soothing ringtones. It doesn't embarrass me in public, what about you?
  Reply
#5
I just tried this and now I have no ringtone at all. Sad

Rebooted and still no ringtone. So then I tried setting the dconf-editor setting back to what it was (__custom) and still nothing, just vibration on incoming calls. (That dconf-editor is a bit tough to use on the pinephone screen!) I made sure system sounds are turned on in the Settings program, and the custom .oga files play on the Pinephone using mplayer. Any ideas what might be wrong? Or how to get back the configuration from before I messed with this? (I have a full backup.) I've used dconf-editor before but have no idea where it actually stores its settings.
  Reply
#6
(02-25-2021, 08:45 PM)Zebulon Walton Wrote: I just tried this and now I have no ringtone at all. Sad

Rebooted and still no ringtone. So then I tried setting the dconf-editor setting back to what it was (__custom) and still nothing, just vibration on incoming calls. (That dconf-editor is a bit tough to use on the pinephone screen!) I made sure system sounds are turned on in the Settings program, and the custom .oga files play on the Pinephone using mplayer. Any ideas what might be wrong? Or how to get back the configuration from before I messed with this? (I have a full backup.) I've used dconf-editor before but have no idea where it actually stores its settings.
Try to delete /home/mobian/.cache/event-sound-cache.tdb.*
and test with fbcli -E message-new-instant
  Reply
#7
(02-25-2021, 08:45 PM)Zebulon Walton Wrote: I just tried this and now I have no ringtone at all. Sad

Rebooted and still no ringtone. So then I tried setting the dconf-editor setting back to what it was (__custom) and still nothing, just vibration on incoming calls. (That dconf-editor is a bit tough to use on the pinephone screen!) I made sure system sounds are turned on in the Settings program, and the custom .oga files play on the Pinephone using mplayer. Any ideas what might be wrong? Or how to get back the configuration from before I messed with this? (I have a full backup.) I've used dconf-editor before but have no idea where it actually stores its settings.

I don't know if this will help, but after my custom sounds stopped working on the Pinetab (mobian), I noticed in Settings -> Sound -> Output that 'output' was actually set to the microphone. Switching it back to the internal speaker made sounds play again. I have no idea when/how the setting changed in the first place.

As for where dconf-editor stores changes, pretty sure it is in the binary file ~/.config/dconf/user.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Customizing the ringtone spaetz 2 551 03-13-2021, 02:48 PM
Last Post: ergo owl
  How to change the minimum password length when changing from default passwords arturo2bodegas 3 1,514 07-18-2020, 01:51 PM
Last Post: arturo2bodegas

Forum Jump:


Users browsing this thread: 1 Guest(s)