SMS sending is broken with Quectel+O2 Germany, how to get it fixed?
I have a problem, I can't send SMS (tested both chatty, and then with ModemManager directly) with the carrier O2 Germany and the ModemManager dev helped me out and eventually figured the phone network was apparently sending back a delivery failure and not sending it. I have extensive logs which the ModemManager dev helped me collect, but I can't really paste them here because I don't know what exactly needs retracting. But summed up, the Quectel modem returns a"WmsMessageDeliveryFailure" of type "temporary". (But it never ever gets sent later, so it's pretty permanent.) The SMS service center number, service domain, and GSM sending mode seem all to be set right too, not that I ever changed those.

Some very interesting points though: SMS receiving, calls, mobile data all work. Also sending does work with same SIM in an Android phone, which points to the Quectel modem doing something relevant different. Whether that means the error is on Quectel's side, ModemManager setting a wrong config, or on O2 Germany's side for rejecting some unusual but correct setting as wrong I don't know.

Now the issue is, Quectel is basically saying "we don't want to bother with users directly, ask Pine64." I e-mailed but I assume you guys are both busy, and not really interested in technical support especially since this seems to be pretty obviously something that Quectel or the carrier could most likely answer. I even offered them to be sent QLog and run it, but they didn't even want to send me that. So far neither nor the carrier have responded to my inquiries.

So where do I go from here? SMS sending is pretty essential, and I assume this is an easy fix once somebody who knows what to do looks at it. But how do I get those people involved?
ModemManager[1806]: <debug> [1610284997.201644] [modem0/bearer0] got QMI WDS event report
ModemManager[1806]: [/dev/cdc-wdm0] received message...
<<<<<< RAW:
<<<<<<  length = 29
<<<<<<  data  = XXXXXX(removed this because I'm not sure it doesn't contain like IMEI or something)XXXX
ModemManager[1806]: [/dev/cdc-wdm0] received generic response (translated)...
<<<<<< QMUX:
<<<<<<  length  = 28
<<<<<<  flags  = 0x80
<<<<<<  service = "wms"
<<<<<<  client  = 2
<<<<<< QMI:
<<<<<<  flags      = "response"
<<<<<<  transaction = 13
<<<<<<  tlv_length  = 16
<<<<<<  message    = "Raw Send" (0x0020)
<<<<<< TLV:
<<<<<<  type      = "Result" (0x02)
<<<<<<  length    = 4
<<<<<<  value      = 01:00:38:00
<<<<<<  translated = FAILURE: WmsMessageDeliveryFailure
<<<<<< TLV:
<<<<<<  type      = "Message ID" (0x01)
<<<<<<  length    = 2
<<<<<<  value      = 35:00
<<<<<<  translated = 53
<<<<<< TLV:
<<<<<<  type      = "Message Delivery Failure Type" (0x13)
<<<<<<  length    = 1
<<<<<<  value      = 00
<<<<<<  translated = temporary
Well here's the error quote at least, with the one value removed.

So what's the process, if the ModemManager person has no clue why the Modem does this and Quectel has no interest in responding, then what? If somebody knows what magical email address I could email with the full logs and info to e.g. actually get a response from Quectel other than "ask Pine64 or something" I would be really interested. I can obviously also share logs with anyone who knows their way around these parts, it's just I'd rather not leak my own phone number or the target phone number or the IMEI or similar permanently onto the web so I just can't attach the logs publicly here.
It's tricky - depending on what level things are going wrong at even Quectel may not get to see it - it could be happening in a proprietary Qualcomm blob, or be a problem at O2's end. I would expect the ModemManager guys to be as close as we have to subject matter experts, but you could try the oFono guys too, or see if oFono can send successfully.

I've seen similar behaviour with GiffGaff (UK MVNO on the O2 network, owned by O2) with an Android phone - sometimes the message fails to send, but works after a manual retry, when nothing has visibly changed. I've not looked to see if a similar level of diagnostic information is available there. This doesn't directly help, but it's an indicator that sometimes the phone/modem may not be the problem (or is it? That phone uses Qualcomm chips and blobs too...)
I'm also having problems sending SMS.

Network: MEDIONmobile / Aldi Talk (also German Telefonica/O2)

I figured out sending SMS on 2G works(!), but not on 3G or 4G.
Voice, Data and receiving SMS works fine.

Anyone able to send SMS on this network? Any suggestions?
(03-08-2021, 07:25 AM)h3ndrik Wrote: I'm also having problems sending SMS.

Network: MEDIONmobile / Aldi Talk (also German Telefonica/O2)

I figured out sending SMS on 2G works(!), but not on 3G or 4G.
Voice, Data and receiving SMS works fine.

Anyone able to send SMS on this network? Any suggestions?
successfully sent sms via "blau" (Telefónica O2), in mobian upper left corner it is showing me "4G"
(03-08-2021, 09:11 AM)ncc Wrote: successfully sent sms via "blau" (Telefónica O2), in mobian upper left corner it is showing me "4G"

Thank you. That's interesting, so it can be done...

I'm not sure how to proceed. I've tested Mobian with the 5.10 and 5.11 kernel, both current Phosh and Plasma Mobile Manjaro dev-builds,
tested 2 different modem firmwares (EG25GGBR07A08M2G_01.002.01.002 and _01.003.01.003) and then reset the modem once.

(show kernel version: uname -a
show modem firmware version: mmcli -m any --command='AT+QGMR'

I tried it via the command line, with and without requesting a delivery report, adding the SMSC...
but it's always the same error: 'Timeout was reached'.
In the ModemManager debug log there is a response FAILURE: WmsMessageDeliveryFailure / "Message Delivery Failure Type" (0x13)

Does anybody know how to debug this properly?

Also, this thread seems to be about the same problem:
For me, this was the problem:
(04-08-2021, 06:17 AM)e1337 Wrote: For me, this was the problem:

i tried that. unfortunately it didn't change anything for me. but thanks for the info.
same problem: USA, using T-Mobile (USMOBILE). 

SMS worked when I initially received the phone for about 10 days, then it broke, can't send or receive sms. making calls and texting should be the most important features of a "phone", imo.

Possibly Related Threads…
Thread Author Replies Views Last Post
  VoLTE calls with o2 (Germany) arno_nuehm 5 802 06-09-2021, 10:29 AM
Last Post: asz
  Is there a priority list for features/ bugs, that have to be implemented/ fixed? stamat 17 1,713 06-03-2021, 10:30 AM
Last Post: stamat
Exclamation GPS is broken! Change wiki and page! And where is the antenna ? jack1 4 960 03-23-2021, 07:22 AM
Last Post: jack1
Question APN setting for provider AldiTalk (Germany) robbyk 2 476 02-12-2021, 06:46 AM
Last Post: goapunk
  pinephone in germany (telefonica) ? robotnik 2 909 01-18-2021, 07:14 AM
Last Post: InternetQuatsch
  PinePhone for sale - Germany (no longer for sale) aus 0 608 12-15-2020, 12:58 PM
Last Post: aus
  suggestion the broken screen issues dallytaur 0 464 11-19-2020, 10:27 PM
Last Post: dallytaur
  Germany batch will be delayed vicky 80 43,930 10-01-2020, 12:23 AM
Last Post: tllim
  Trigger happy proximity sensor, broken volume control & other newbie questions grug 3 1,466 09-10-2020, 05:57 AM
Last Post: megous

Forum Jump:

Users browsing this thread: 1 Guest(s)